What are the supported Internet Explorer versions for each phpBB version?

Discuss general development subjects that are not specific to a particular version like the versioning control system we use or other infrastructure.
Post Reply
techboyg5
Registered User
Posts: 6
Joined: Mon Jun 29, 2020 1:02 am

What are the supported Internet Explorer versions for each phpBB version?

Post by techboyg5 »

What are the supported Internet Explorer versions for each phpBB version?
  • phpBB 2.0
  • phpBB 3.0
  • phpBB 3.1
  • phpBB 3.2
  • phpBB 3.3
User avatar
3Di
Registered User
Posts: 866
Joined: Tue Nov 01, 2005 9:50 pm
Location: Milano (I) Frankfurt (D)
Contact:

Re: What are the supported Internet Explorer versions for each phpBB version?

Post by 3Di »

May I ask you the reason why this question?
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫
User avatar
AbaddonOrmuz
Registered User
Posts: 7
Joined: Wed Jul 02, 2014 9:44 pm
Location: /dev/null
Contact:

Re: What are the supported Internet Explorer versions for each phpBB version?

Post by AbaddonOrmuz »

As far as I know phpBB 3.3.0 supports up to Internet Explorer 11, at least that's the requirement for extensions and styles to pass validation.

I don't see the point for older versions than 3.3.0, because they no longer receive support.
Some of my phpBB extensions:
Image Imgur | :chart_with_upwards_trend: SEO Metadata | Image Markdown | :lock: Auto-lock Topics
:trophy: Check out all my validated extensions :trophy:

:penguin: Arch Linux user :penguin:
User avatar
david63
Registered User
Posts: 318
Joined: Mon Feb 07, 2005 7:23 am
Location: Lancashire, UK

Re: What are the supported Internet Explorer versions for each phpBB version?

Post by david63 »

AbaddonOrmuz wrote: Thu Jul 02, 2020 6:21 pm As far as I know phpBB 3.3.0 supports up to Internet Explorer 11
It does not support some of the older versions, cannot remember which ones but there is a topic on here about it.
David
Remember: You only know what you know -
and you do not know what you do not know!
User avatar
3Di
Registered User
Posts: 866
Joined: Tue Nov 01, 2005 9:50 pm
Location: Milano (I) Frankfurt (D)
Contact:

Re: What are the supported Internet Explorer versions for each phpBB version?

Post by 3Di »

Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫
User avatar
hanakin
Front-End Dev Team Lead
Front-End Dev Team Lead
Posts: 941
Joined: Sat Dec 25, 2010 9:02 pm
Contact:

Re: What are the supported Internet Explorer versions for each phpBB version?

Post by hanakin »

This has been somewhat addressed here viewtopic.php?f=131&t=74736 but as for the past versions which I echo 3DI not sure why you need all of those

With that being said in general terms for compatibility for 3.x its Chrome/Firefox/IE x with IE being the outlier any other browsers as per the topic listed above are not fully supported meaning we do not test them directly but rather rely on automated validation methods.

phpBB 2.0 2001 (To old can't help IE 6 and below only? Maybe have to through the name Netscape in as well so yeah stop!)
phpBB 3.0 2007 (Really old still supported IE 6 I believe if not then at lest IE 7)
phpBB 3.1 2014 (IE 8 and up + mobile as of 2014)
phpBB 3.2 2017 (originally IE 9 and up but transitioned to IE 10 and up in later releases as it nears EOL + mobile as of 2017 )
phpBB 3.3 2020 (IE 11 and up + mobile today)
Donations welcome via Paypal Image
Post Reply