phpBB 3.2.0-a1 released

General discussion of development ideas and the approaches taken in the 3.x branch of phpBB. The next feature release of phpBB 3 will be 3.2/Rhea followed by 3.3.
Forum rules
Please do not post support questions regarding installing, updating, or upgrading phpBB 3.1. If you need support for phpBB 3.1 please visit the 3.1.x Support Forum on phpbb.com.

If you have questions regarding writing extensions please post in Extension Writers Discussion to receive proper guidance from our staff and community.
Post Reply
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 1731
Joined: Thu Mar 02, 2006 4:29 pm
Location: Earth
Contact:

Re: phpBB 3.2.0-a1 released

Post by DavidIQ » Thu Nov 26, 2015 8:03 pm

Crizzo wrote:
Thu Nov 26, 2015 7:58 pm
Open a ticket would be usefuller, right?
There's already a ticket for that.
Image

User avatar
RMcGirr83
Registered User
Posts: 357
Joined: Fri Mar 09, 2007 1:51 am
Contact:

Re: phpBB 3.2.0-a1 released

Post by RMcGirr83 » Thu Nov 26, 2015 11:14 pm

VSE wrote:
Thu Nov 26, 2015 7:25 pm

It looks like it's you (something about your setup). I just installed a fresh copy of A1 and every extension I have tried with routing works just fine, with url rewriting on and off.
If that is the case, I'm using wampp locally, and phpbb 3.1.6 doesn't have a problem why would 3.2 have a problem? PHP 5.6.4, I think not at the comp right now. What version of PHP are you running?

Did you also try either Paul's extension or mine?
I have 5.5.3 on my live forum so will try that to see.
Do not hire Christian Bullock he won't finish the job and will keep your money

User avatar
VSE
Extension Customisations
Extension Customisations
Posts: 670
Joined: Mon Mar 08, 2010 9:18 am

Re: phpBB 3.2.0-a1 released

Post by VSE » Fri Nov 27, 2015 1:27 am

RMcGirr83 wrote:
Thu Nov 26, 2015 11:14 pm
VSE wrote:
Thu Nov 26, 2015 7:25 pm

It looks like it's you (something about your setup). I just installed a fresh copy of A1 and every extension I have tried with routing works just fine, with url rewriting on and off.
If that is the case, I'm using wampp locally, and phpbb 3.1.6 doesn't have a problem why would 3.2 have a problem? PHP 5.6.4, I think not at the comp right now. What version of PHP are you running?

Did you also try either Paul's extension or mine?
I have 5.5.3 on my live forum so will try that to see.
I just installed your Flags extension, and routing to the Flags works for me. Are you using "Force server URL settings"? I'm not. The systems we're using should not be the issue (I'm on 5.6.10). Although since your install didn't work, like mine did, something may be a problem starting there. I don't really think reloading the installer and then having it complete after hanging really means the installation is a good one at that point, although routing I don't think has anything to do with the database. Make sure your cache is completely purged.
Has an irascible disposition.

User avatar
RMcGirr83
Registered User
Posts: 357
Joined: Fri Mar 09, 2007 1:51 am
Contact:

Re: phpBB 3.2.0-a1 released

Post by RMcGirr83 » Fri Nov 27, 2015 2:34 am

Nope no "Force server URL settings". Installed it on a non-local site and everything worked fine.

Something to do with the installer and refreshing it I suppose.

Just tried to install it locally again, removed everything started from fresh, and I am still running into the same issue even though the installer finished completely 100% without me refreshing. Version of PHP locally is 5.6.14 :?

Strangest damn thing.
Do not hire Christian Bullock he won't finish the job and will keep your money

User avatar
VSE
Extension Customisations
Extension Customisations
Posts: 670
Joined: Mon Mar 08, 2010 9:18 am

Re: phpBB 3.2.0-a1 released

Post by VSE » Fri Nov 27, 2015 8:44 am

RMcGirr83 wrote:
Fri Nov 27, 2015 2:34 am
Nope no "Force server URL settings". Installed it on a non-local site and everything worked fine.

Something to do with the installer and refreshing it I suppose.

Just tried to install it locally again, removed everything started from fresh, and I am still running into the same issue even though the installer finished completely 100% without me refreshing. Version of PHP locally is 5.6.14 :?

Strangest damn thing.
You don't have PHP caching (opcache, xcache or apc) enabled on your local do you?
Has an irascible disposition.

User avatar
RMcGirr83
Registered User
Posts: 357
Joined: Fri Mar 09, 2007 1:51 am
Contact:

Re: phpBB 3.2.0-a1 released

Post by RMcGirr83 » Fri Nov 27, 2015 12:41 pm

No, no caching. Guess I can try a different version of xampp
Do not hire Christian Bullock he won't finish the job and will keep your money

CHItA
Development Team
Development Team
Posts: 128
Joined: Thu Mar 12, 2015 1:43 pm
Location: Budapest, Hungary

Re: phpBB 3.2.0-a1 released

Post by CHItA » Fri Nov 27, 2015 12:57 pm

Are your routing files in ext_path/config/(default|production|development)/routing?

Nicofuma
3.2 Release Manager
3.2 Release Manager
Posts: 297
Joined: Sun Apr 13, 2014 1:40 am
Location: Paris

Re: phpBB 3.2.0-a1 released

Post by Nicofuma » Fri Nov 27, 2015 1:08 pm

it should works too if they are in ext_path/config/routing
Member of the phpBB Development-Team
No Support via PM

User avatar
RMcGirr83
Registered User
Posts: 357
Joined: Fri Mar 09, 2007 1:51 am
Contact:

Re: phpBB 3.2.0-a1 released

Post by RMcGirr83 » Fri Nov 27, 2015 1:11 pm

No, the file is found in ext_path/config. https://github.com/RMcGirr83/phpBB-3.1- ... ter/config

BTW nicofuma, there is nothing about 3.2 in this page you linked to in your first post. https://area51.phpbb.com/downloads/

and "install" seems to have stalled at 11% again though I see the database tables were made.

EDIT: having same issue with different version of XAMPP. If I install nicofumas webprofiler extension and enable it I get this returned

General Error
The requested environment production is not available.
One last edit, I do now notice that within the cache directory, where everything used to be stored, there are now two other directories, installer and production. Installer directory seems to have container files within it and production has nothing in it but twig stuff.
Do not hire Christian Bullock he won't finish the job and will keep your money

User avatar
VSE
Extension Customisations
Extension Customisations
Posts: 670
Joined: Mon Mar 08, 2010 9:18 am

Re: phpBB 3.2.0-a1 released

Post by VSE » Fri Nov 27, 2015 4:41 pm

RMcGirr83 wrote:
Fri Nov 27, 2015 1:11 pm
One last edit, I do now notice that within the cache directory, where everything used to be stored, there are now two other directories, installer and production. Installer directory seems to have container files within it and production has nothing in it but twig stuff.
Does your config.php file have:
@define('PHPBB_ENVIRONMENT', 'production');
Has an irascible disposition.

Post Reply