phpBB 3.2.0-a1 released

General discussion of development ideas and the approaches taken in the 3.x branch of phpBB. The next feature release of phpBB 3 will be 3.2/Rhea followed by 3.3.
Forum rules
Please do not post support questions regarding installing, updating, or upgrading phpBB 3.1. If you need support for phpBB 3.1 please visit the 3.1.x Support Forum on phpbb.com.

If you have questions regarding writing extensions please post in Extension Writers Discussion to receive proper guidance from our staff and community.
Post Reply
User avatar
VSE
Extension Customisations
Extension Customisations
Posts: 670
Joined: Mon Mar 08, 2010 9:18 am

Re: phpBB 3.2.0-a1 released

Post by VSE » Wed Nov 25, 2015 5:31 am

RMcGirr83 wrote:
Tue Nov 24, 2015 8:40 pm
Actually my extensions are now returning no route found for GET when rewrite urls is on.
I'm not having any issues with my extensions when rewrite urls is on.
Has an irascible disposition.

User avatar
RMcGirr83
Registered User
Posts: 357
Joined: Fri Mar 09, 2007 1:51 am
Contact:

Re: phpBB 3.2.0-a1 released

Post by RMcGirr83 » Wed Nov 25, 2015 11:14 am

:x it's this extension

and I just ran into the same thing as far as the installation bar stopping at 11%. Hit f5 and the installation went through to 100%.

EDIT:
This is what is being returned
"NetworkError: 404 Not Found - http://127.0.0.1/phpbb3/flags"
"NetworkError: 404 Not Found - http://127.0.0.1/assets/css/font-awesom ... version=13"
"NetworkError: 404 Not Found - http://127.0.0.1/styles/prosilver/theme ... version=13"
"NetworkError: 404 Not Found - http://127.0.0.1/styles/prosilver/theme ... version=13"
"NetworkError: 404 Not Found - http://127.0.0.1/styles/prosilver/templ ... version=13"
"NetworkError: 404 Not Found - http://127.0.0.1/ext/rmcgirr83/elonw/st ... version=13"
"NetworkError: 404 Not Found - http://127.0.0.1/assets/javascript/core ... version=13"
"NetworkError: 404 Not Found - http://127.0.0.1/styles/prosilver/templ ... version=13"
"NetworkError: 404 Not Found - http://127.0.0.1/assets/javascript/core ... version=13"
"NetworkError: 404 Not Found - http://127.0.0.1/styles/prosilver/templ ... version=13"
"NetworkError: 404 Not Found - http://127.0.0.1/styles/prosilver/templ ... version=13"
Now that begs the question as to why the formatting is being lost. EG, instead of the path being 127.0.0.1/phpbb3/assets it is 127.0.0.1/assets

and this is in the routing.yml file

Code: Select all

rmcgirr83_nationalflags_display:
    path: /flags
    defaults: { _controller: rmcgirr83.nationalflags.main.controller:displayFlags }
works fine in 3.1.6 :?
Do not hire Christian Bullock he won't finish the job and will keep your money

leschek
Registered User
Posts: 161
Joined: Tue Aug 28, 2012 1:30 pm

Re: phpBB 3.2.0-a1 released

Post by leschek » Wed Nov 25, 2015 10:37 pm

When I tried to download the merged conflicts archive during update from 3.1.6 to 3.2-a1 I got this error:

Code: Select all

Fatal error: Call to a member function format_date() on a non-object in C:\xxx\localweb\quickinstall\boards\phpbb32a1\install\update\new\includes\functions.php on line 4168

User avatar
VSE
Extension Customisations
Extension Customisations
Posts: 670
Joined: Mon Mar 08, 2010 9:18 am

Re: phpBB 3.2.0-a1 released

Post by VSE » Wed Nov 25, 2015 11:07 pm

RMcGirr83 wrote:
Wed Nov 25, 2015 11:14 am
and I just ran into the same thing as far as the installation bar stopping at 11%. Hit f5 and the installation went through to 100%.
Umm, I wouldn't recommend that. When it's at 11%, that's when it is adding schema to the database. Depending on your system, this might take a a minute or few...Just give it a chance.
Has an irascible disposition.

User avatar
RMcGirr83
Registered User
Posts: 357
Joined: Fri Mar 09, 2007 1:51 am
Contact:

Re: phpBB 3.2.0-a1 released

Post by RMcGirr83 » Thu Nov 26, 2015 10:36 am

I waited for 10 minutes or so.

By the way, the official pages extension also fails
No route found for "GET /phpbb3/page/test" (from "http://127.0.0.1/phpbb3/index.php?sid=2 ... 68c9975fe8")
Do not hire Christian Bullock he won't finish the job and will keep your money

janus
Registered User
Posts: 10
Joined: Thu Nov 26, 2015 1:06 pm

Re: phpBB 3.2.0-a1 released

Post by janus » Thu Nov 26, 2015 1:28 pm

Update went without errors, but on the end only a lot of data and no sign of a board

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 1731
Joined: Thu Mar 02, 2006 4:29 pm
Location: Earth
Contact:

Re: phpBB 3.2.0-a1 released

Post by DavidIQ » Thu Nov 26, 2015 2:03 pm

RMcGirr83 wrote:
Thu Nov 26, 2015 10:36 am
I waited for 10 minutes or so.

By the way, the official pages extension also fails
No route found for "GET /phpbb3/page/test" (from "http://127.0.0.1/phpbb3/index.php?sid=2 ... 68c9975fe8")
Are you using the one from the 3.2 branch?
https://github.com/phpbb-extensions/pag ... elop-3.2.x
VSE wrote:
Wed Nov 25, 2015 11:07 pm
RMcGirr83 wrote:
Wed Nov 25, 2015 11:14 am
and I just ran into the same thing as far as the installation bar stopping at 11%. Hit f5 and the installation went through to 100%.
Umm, I wouldn't recommend that. When it's at 11%, that's when it is adding schema to the database. Depending on your system, this might take a a minute or few...Just give it a chance.
Mine stopped at 11% flat out. Turns out if there is an error of any kind during schema generation the result is that the progressbar stays stuck at 11% and the user is not informed of the problem.
Image

User avatar
RMcGirr83
Registered User
Posts: 357
Joined: Fri Mar 09, 2007 1:51 am
Contact:

Re: phpBB 3.2.0-a1 released

Post by RMcGirr83 » Thu Nov 26, 2015 2:20 pm

DavidIQ wrote:
Thu Nov 26, 2015 2:03 pm
RMcGirr83 wrote:
Thu Nov 26, 2015 10:36 am
I waited for 10 minutes or so.

By the way, the official pages extension also fails
No route found for "GET /phpbb3/page/test" (from "http://127.0.0.1/phpbb3/index.php?sid=2 ... 68c9975fe8")
Are you using the one from the 3.2 branch?
https://github.com/phpbb-extensions/pag ... elop-3.2.x
Wasn't then but just tried 2.0.2-dev and
No route found for "GET /phpbb3/testing" (from "http://127.0.0.1/phpbb3/index.php?sid=1 ... 4f5611fa13")
Seems that the new routing method isn't BC and isn't working or maybe I am missing something.

EDIT:

Yep, seems busted. Just tried pauls shoutbox thingy and received an ajax boo boo
No route found for "POST /phpbb3/ajaxshoutbox/post" (from "http://127.0.0.1/phpbb3/index.php?sid=1 ... 4f5611fa13")
Routing is borked.
Do not hire Christian Bullock he won't finish the job and will keep your money

User avatar
VSE
Extension Customisations
Extension Customisations
Posts: 670
Joined: Mon Mar 08, 2010 9:18 am

Re: phpBB 3.2.0-a1 released

Post by VSE » Thu Nov 26, 2015 7:25 pm

RMcGirr83 wrote:
Thu Nov 26, 2015 2:20 pm
Yep, seems busted. Just tried pauls shoutbox thingy and received an ajax boo boo

Routing is borked.
It looks like it's you (something about your setup). I just installed a fresh copy of A1 and every extension I have tried with routing works just fine, with url rewriting on and off.

Collapasible Categories (uses routes to show/hide forums) works (3.1 and 3.2 compat.)
Board Announcements works, uses routes to close an announcement (3.1 and 3.2 compat)
Board Rules uses routes and works (3.2 version)
Pages uses routes and works (3.2 version)

EDIT: Not to mention, this very forum here is using routing, for the FAQ for example, and that works too.
Has an irascible disposition.

User avatar
Crizzo
Translations & International Support Teams Manager
Translations & International Support Teams Manager
Posts: 14
Joined: Sun Jul 14, 2013 11:57 am

Re: phpBB 3.2.0-a1 released

Post by Crizzo » Thu Nov 26, 2015 7:58 pm

Installation process got stuck with 11% (waited about 15mins). Then i restarted the process and it went through to 100%, quite smoothly. :)

PHP 5.6.12
clean, fresh Database with MySQL 5.6.26.

I counldn't find anything useful in the PHP error logs or JS browser log in the browser (Firefox 42.0).

Open a ticket would be usefuller, right?

Post Reply