[RFC|Merged] PHP 5.3.3 or more

These requests for comments/change have lead to an implemented feature that has been successfully merged into the 3.1/Ascraeus branch. Everything listed in this forum will be available in phpBB 3.1.
User avatar
imkingdavid
Registered User
Posts: 1050
Joined: Thu Jul 30, 2009 12:06 pm

[RFC|Merged] PHP 5.3.3 or more

Post by imkingdavid » Fri Nov 02, 2012 7:16 pm

First things first, it might be a good idea to decide on the minimum PHP version later, i.e. when we actually are about ready to release. Yes, people like to have prior notice, but our dependencies keep bumping their minimum PHP version requirements, so if we don't bump it as well, we can't use them.

If we decide not to do that, we need to at least bump our minimum version from 5.3.2 to 5.3.3, though preferably something higher than that.

The reason? Symfony components at version 2.1.* require PHP 5.3.3 as the minimum version (see) and even though Goutte (which we use for functional tests) allows anything >=5.3, it also requiers at least the 2.1.* version of the Symfony components it uses (see).

So long story short, we should hold off on specifying a minimum version until we get ready for a release, at which we should set it to the minimum version needed by our own code as well as all dependencies.
I do custom MODs. PM for a quote!
View My: MODs | Portfolio
Please do NOT contact for support via PM or email.
Remember, the enemy's gate is down.

User avatar
MichaelC
Development Team
Development Team
Posts: 889
Joined: Thu Jan 28, 2010 6:29 pm

Re: [RFC] PHP 5.3.3 or more

Post by MichaelC » Fri Nov 02, 2012 7:20 pm

Symfony 2.2 onwards now has a fixed release cycle so releases are now every may & november. With the exception of 2.2 which will be because its the last chance to break BC and will be in Feb. As such this means we can plan when to announce/decide the minimum version.

As such we can decide now (as 3.1 alpha will be out well before Feb) what version we will choose.

+1 to 5.3.3
Formerly known as Unknown Bliss
psoTFX wrote: I went with Olympus because as I said to the teams ... "It's been one hell of a hill to climb"
No unsolicited PMs please except for quotes.

Oleg
Posts: 1150
Joined: Tue Feb 23, 2010 2:38 am
Contact:

Re: [RFC] PHP 5.3.3 or more

Post by Oleg » Fri Nov 02, 2012 7:23 pm

You need to go through the popular linux distributions and find out who ships what version these days.

Oleg
Posts: 1150
Joined: Tue Feb 23, 2010 2:38 am
Contact:

Re: [RFC] PHP 5.3.3 or more

Post by Oleg » Fri Nov 02, 2012 7:44 pm

Also, you should have researched why the minimum version was increased.

https://github.com/symfony/symfony/comm ... a1732b3748

User avatar
MichaelC
Development Team
Development Team
Posts: 889
Joined: Thu Jan 28, 2010 6:29 pm

Re: [RFC] PHP 5.3.3 or more

Post by MichaelC » Sat Nov 03, 2012 2:01 am

Oleg wrote:Also, you should have researched why the minimum version was increased.

https://github.com/symfony/symfony/comm ... a1732b3748
Doesn't make a difference? For all we know, things requiring the new version could have been added. If you wish you can do an audit of the entire symfony 2.1 codebase with a list of every change in 5.3.3 but its not worth it. Also composer won't install if it detects the php requirement is not met and we can't override it (as far as i know).
Formerly known as Unknown Bliss
psoTFX wrote: I went with Olympus because as I said to the teams ... "It's been one hell of a hill to climb"
No unsolicited PMs please except for quotes.

Oleg
Posts: 1150
Joined: Tue Feb 23, 2010 2:38 am
Contact:

Re: [RFC] PHP 5.3.3 or more

Post by Oleg » Sat Nov 03, 2012 4:20 am

The alternative is to file a bug report or preferably a patch with symfony reinstating compatibility with php 5.3.2.

User avatar
MichaelC
Development Team
Development Team
Posts: 889
Joined: Thu Jan 28, 2010 6:29 pm

Re: [RFC] PHP 5.3.3 or more

Post by MichaelC » Sat Nov 03, 2012 11:07 am

Oleg wrote:The alternative is to file a bug report or preferably a patch with symfony reinstating compatibility with php 5.3.2.
Which won't be accepted for 2 reasons:
1) Symfony is used by hundreds of applications (inc. Drupal), why would they care that 1 application (if abeit a large one) can't make the new php requirement?
2) 2.1 is already in maintenance so I doubt they'd change the php minimum version, even if it is taking it down.
Formerly known as Unknown Bliss
psoTFX wrote: I went with Olympus because as I said to the teams ... "It's been one hell of a hill to climb"
No unsolicited PMs please except for quotes.

User avatar
bantu
3.0 Release Manager
3.0 Release Manager
Posts: 557
Joined: Thu Sep 07, 2006 11:22 am
Location: Karlsruhe, Germany
Contact:

Re: [RFC] PHP 5.3.3 or more

Post by bantu » Sat Nov 03, 2012 6:18 pm

imkingdavid wrote:So long story short, we should hold off on specifying a minimum version until we get ready for a release, at which we should set it to the minimum version needed by our own code as well as all dependencies.
I kind of disagree. As soon as the minimum version increases, it should be communicated to people. Afterall we added the 3.0.x php version warning for that.

User avatar
jsebean
Registered User
Posts: 165
Joined: Wed Nov 17, 2010 1:40 am
Location: Atlantic Canada

Re: [RFC] PHP 5.3.3 or more

Post by jsebean » Sat Nov 03, 2012 7:23 pm

Ubuntu 10.04 comes with 5.3.2, a number of OpenVZ VPS hosts still do not support 12.04 (the latest LTS) because they're too good to update the kernel that 12.04 works with. Luckily I argued with my host enough they updated it today haha. I'm not sure what other distros have in their default repos since I don't use them.

I would say if it's possible I'd say stick with 5.3.2, but if it's a real pain notching it up a bit wont hurt.
-Jonah

User avatar
MichaelC
Development Team
Development Team
Posts: 889
Joined: Thu Jan 28, 2010 6:29 pm

Re: [RFC] PHP 5.3.3 or more

Post by MichaelC » Sat Nov 03, 2012 10:57 pm

We either bump up the requirement or we have to remove functional tests and change (or remove) a substantial amount of extensions infrastructure as well as other things like the DIC.
Formerly known as Unknown Bliss
psoTFX wrote: I went with Olympus because as I said to the teams ... "It's been one hell of a hill to climb"
No unsolicited PMs please except for quotes.

Post Reply