3.1 "Ascraeus" to drop support for PostgreSQL < 8.3

These requests for comments/change have lead to an implemented feature that has been successfully merged into the 3.1/Ascraeus branch. Everything listed in this forum will be available in phpBB 3.1.
Oleg
Posts: 1150
Joined: Tue Feb 23, 2010 2:38 am
Contact:

3.1 "Ascraeus" to drop support for PostgreSQL < 8.3

Post by Oleg » Sun Mar 06, 2011 7:02 am

PostgreSQL 8.1 and below have been end of lifed by postgres.

Necessity to support old versions of postgres makes it difficult to take advantage of performance and functionality improvements offered in later versions. An example of a performance improvement is here; for functionality, fulltext search may be easier to implement if we don't have to support 7.x.

We intend to make phpbb 3.1 require postgres 8.1 or better, or possibly 8.2 or better if the changes between 8.1 and 8.2 warrant it.

Debian lenny ships postgres 8.3; squeeze ships 8.4. RHEL/CentOS 5 ship 8.1.


User avatar
nickvergessen
Former Team Member
Posts: 733
Joined: Sun Oct 07, 2007 11:54 am
Location: Stuttgart, Germany
Contact:

Re: 3.1 "Ascraeus" to drop support for PostgreSQL < 8.2

Post by nickvergessen » Tue Mar 08, 2011 2:09 pm

How about dropping old MySQL versions aswell?
Member of the Development-TeamNo Support via PM

User avatar
igorw
Registered User
Posts: 500
Joined: Thu Jan 04, 2007 11:47 pm

Re: 3.1 "Ascraeus" to drop support for PostgreSQL < 8.2

Post by igorw » Tue Mar 08, 2011 3:52 pm

nickvergessen wrote:How about dropping old MySQL versions aswell?
Looking into that, same with sqlite2.

Oleg
Posts: 1150
Joined: Tue Feb 23, 2010 2:38 am
Contact:

Re: 3.1 "Ascraeus" to drop support for PostgreSQL < 8.2

Post by Oleg » Wed Mar 09, 2011 12:25 am

nickvergessen wrote:How about dropping old MySQL versions aswell?
My impression is that due to supporting myisam we essentially stand no chance of using any 5.0+ specific features.

On the other hand I agree that finding (and thus using) old versions of mysql is extremely tricky, therefore I am not opposed to dropping support for mysql versions that oracle no longer makes available in their archives.

Nils promised us some statistics ;)

User avatar
igorw
Registered User
Posts: 500
Joined: Thu Jan 04, 2007 11:47 pm

Re: 3.1 "Ascraeus" to drop support for PostgreSQL < 8.2

Post by igorw » Thu Mar 17, 2011 11:44 pm

Based on data from the ACP statistics module between 3.0.6 and now-ish, I have following results:

99% of the submitted entries use MySQL, which is 215999 boards. By version: 0.5% mysql4.0, 3.3% mysql4.1, 58.8% mysql5.0, 36% mysql5.1, 0.9% mysql 5.5.

0.1% of total use SQLite2. (we don't support SQLite3 yet)

Of course these stats are not perfect, but they should give an idea.

Oleg
Posts: 1150
Joined: Tue Feb 23, 2010 2:38 am
Contact:

Re: 3.1 "Ascraeus" to drop support for PostgreSQL < 8.2

Post by Oleg » Tue Mar 29, 2011 4:50 am

If we don't use any mysql 5+ features I see no reason to actively drop support for 4.1. However I would support adding UI to the acp to inform board admins that they are running an old version of mysql, similarly to how php 5.2 was handled a while ago.

User avatar
naderman
Product Manager
Product Manager
Posts: 1727
Joined: Sun Jan 11, 2004 2:11 am
Location: Karlsruhe, Germany
Contact:

Re: 3.1 "Ascraeus" to drop support for PostgreSQL < 8.2

Post by naderman » Thu Mar 31, 2011 4:45 pm

Yes we should certainly add that. I talked to Ruslan earlier about generally adding all our install-time checks to the ACP main page and warning the admin if anything is no longer compliant (we were discussing an mbstring related problem). So we should probably come up with a common solution for these things. We should still add this to 3.0 I think, so please talk to Ruslan about this.

JHTech100
Registered User
Posts: 4
Joined: Mon Apr 11, 2011 12:43 am

Re: 3.1 "Ascraeus" to drop support for PostgreSQL < 8.2

Post by JHTech100 » Mon Apr 11, 2011 12:52 am

Well,
I think sqlite 2 should be supported still. On my Mac, I run my home web server with MAMP and the only database type I have had success with is sqlite 2.8.17. I can't see from my average user perspective why it would hurt to just leave in the support. I don't want to be cut off after 3.0.8 or 3.0.9. I don't really have control over the databases that MAMP supports. MySQL has always failed when it comes to creating the tables.

Anyway, for what it's worth, I don't think the people who can only use sqlite 2 should be cut off. phpBB has a good distance to go.

User avatar
naderman
Product Manager
Product Manager
Posts: 1727
Joined: Sun Jan 11, 2004 2:11 am
Location: Karlsruhe, Germany
Contact:

Re: 3.1 "Ascraeus" to drop support for PostgreSQL < 8.2

Post by naderman » Wed Apr 13, 2011 2:01 pm

Well I assume you have sqlite3 support as well, which phpBB 3.0.x doesn't support yet. So that should be a perfectly acceptable solution for you?

Post Reply