Birthday Mod problem

Wondering why that MOD you have won't install correctly? Let's take a look
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
Cdngal
Registered User
Posts: 6
Joined: Fri Jul 13, 2007 6:35 pm

Birthday Mod problem

Post by Cdngal »

I tried installing this mod and in step 2 i got this error

The failed line was:
ALTER TABLE phpbb_users ADD user_birthday INTEGER(8) NOT NULL DEFAULT 0;;


SQL ERROR: 1146
Table 'forumsan_db1.phpbb_users' doesn't exist

What should i do to fix this?
User avatar
Poomerio
Registered User
Posts: 552
Joined: Tue Jan 02, 2007 7:09 pm
Location: 4(x - 20y) = 20

Re: Birthday Mod problem

Post by Poomerio »

Open up the install file.
Cut the SQL part of the MOD.
Open phpMyAdmin.
Paste it into a database query (SQL).
Run the query.
Save the MOD install file.
Run the MOD script.

If done correctly, it should work.

- Poomie
Cdngal
Registered User
Posts: 6
Joined: Fri Jul 13, 2007 6:35 pm

Re: Birthday Mod problem

Post by Cdngal »

Ok Lets see if understand it right. Or maybe I dont.

Basically do a manual install by copying the code from the install file right into the database file itself?
So if so, would i do this for all the files, or just the one im having trouble with?
Cdngal
Registered User
Posts: 6
Joined: Fri Jul 13, 2007 6:35 pm

Re: Birthday Mod problem

Post by Cdngal »

Anyone have any thoughts on what i should do?
User avatar
Poomerio
Registered User
Posts: 552
Joined: Tue Jan 02, 2007 7:09 pm
Location: 4(x - 20y) = 20

Re: Birthday Mod problem

Post by Poomerio »

Well I've been stranded, 500 miles from home for 14+ hours, but I'll give it another go at an explanation.
Only copy the code underneath the ---[SQL]--- section of the install file, and run it in the database.
Then, remove that piece of code from the MOD install file, save, upload and try again.

- Poomie
Cdngal
Registered User
Posts: 6
Joined: Fri Jul 13, 2007 6:35 pm

Re: Birthday Mod problem

Post by Cdngal »

Today i finally had a chance to have antoher look at this. I went into the phpMyadmin files and it seems there is no forumsan_db1.phpbb_users file, just a user file. So how do i fix this to work with my birthday mod?
Locked