[Solved]Install the dependencies (4.0.0-a1-dev)

General discussion of development ideas and the approaches taken in the 3.x branch of phpBB. The next feature release of phpBB 3 will be 3.3/Proteus.
Forum rules
Please do not post support questions regarding installing, updating, or upgrading phpBB 3.2.x. If you need support for phpBB 3.2.x please visit the 3.2.x Support Forum on phpbb.com.

If you have questions regarding writing extensions please post in Extension Writers Discussion to receive proper guidance from our staff and community.
Post Reply
User avatar
Solidjeuh
Registered User
Posts: 40
Joined: Sat Feb 25, 2017 6:42 pm
Location: Aalst, Belgium
Contact:

[Solved]Install the dependencies (4.0.0-a1-dev)

Post by Solidjeuh »

Hey all,

I hope I post this in the correct forum.
I tried to install phpBB 4.0.0-a1-dev for testing. But installing the dependencies give this error:

Code: Select all

-sh-4.2$ php ../composer.phar install
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Package operations: 80 installs, 0 updates, 0 removals
  - Installing ocramius/package-versions (1.4.0): Loading from cache
PHP Warning:  Unsupported declare 'strict_types' in /var/www/vhosts/solidjeuh.be/httpdocs/scripts/phpbbtest/repo/phpBB/vendor/ocramius/package-versions/src/PackageVersions/Installer.php on line 3

Warning: Unsupported declare 'strict_types' in /var/www/vhosts/solidjeuh.be/httpdocs/scripts/phpbbtest/repo/phpBB/vendor/ocramius/package-versions/src/PackageVersions/Installer.php on line 3
PHP Parse error:  syntax error, unexpected 'function' (T_FUNCTION), expecting identifier (T_STRING) or \\ (T_NS_SEPARATOR) in /var/www/vhosts/solidjeuh.be/httpdocs/scripts/phpbbtest/repo/phpBB/vendor/ocramius/package-versions/src/PackageVersions/Installer.php on line 20

Parse error: syntax error, unexpected 'function' (T_FUNCTION), expecting identifier (T_STRING) or \\ (T_NS_SEPARATOR) in /var/www/vhosts/solidjeuh.be/httpdocs/scripts/phpbbtest/repo/phpBB/vendor/ocramius/package-versions/src/PackageVersions/Installer.php on line 20
Can anyone tell me what to do please?

Code: Select all

System: Linux 3.10.0-042stab136.1 
Web Server: Apache
PHP: 7.2.18
Database server: MySQL(i) 5.5.60-MariaDB
Operating system: Redhat
CPU: Intel(R) Xeon(R) CPU E5-2630 v3 @ 2.40GHz 
Image
Last edited by Solidjeuh on Mon May 27, 2019 2:47 am, edited 1 time in total.

User avatar
JoshyPHP
Registered User
Posts: 367
Joined: Fri Jul 08, 2011 9:43 pm

Re: Install the dependencies (4.0.0-a1-dev)

Post by JoshyPHP »

You're probably not using PHP 7, somehow. Try php -v.

Although it's weird Composer didn't warn about it. Might be a weird edge case.

User avatar
Solidjeuh
Registered User
Posts: 40
Joined: Sat Feb 25, 2017 6:42 pm
Location: Aalst, Belgium
Contact:

Re: Install the dependencies (4.0.0-a1-dev)

Post by Solidjeuh »

JoshyPHP wrote:
Mon May 27, 2019 12:58 am
You're probably not using PHP 7, somehow. Try php -v.

Although it's weird Composer didn't warn about it. Might be a weird edge case.
PHP 5.4.16
I now installed PHP 7.2.18 on my system.
Now I get this:

Code: Select all

-sh-4.2$ cd httpdocs/scripts/phpbbtest/4.0/phpBB
-sh-4.2$ php ../composer.phar install
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for facebook/webdriver 1.6.0 -> satisfiable by facebook/webdriver[1.6.0].
    - facebook/webdriver 1.6.0 requires ext-zip * -> the requested PHP extension zip is missing from your system.

  To enable extensions, verify that they are enabled in your .ini files:
    - /etc/php.ini
    - /etc/php.d/20-bz2.ini
    - /etc/php.d/20-calendar.ini
    - /etc/php.d/20-ctype.ini
    - /etc/php.d/20-curl.ini
    - /etc/php.d/20-dom.ini
    - /etc/php.d/20-exif.ini
    - /etc/php.d/20-fileinfo.ini
    - /etc/php.d/20-ftp.ini
    - /etc/php.d/20-gd.ini
    - /etc/php.d/20-gettext.ini
    - /etc/php.d/20-iconv.ini
    - /etc/php.d/20-imap.ini
    - /etc/php.d/20-json.ini
    - /etc/php.d/20-mbstring.ini
    - /etc/php.d/20-mysqlnd.ini
    - /etc/php.d/20-pdo.ini
    - /etc/php.d/20-phar.ini
    - /etc/php.d/20-simplexml.ini
    - /etc/php.d/20-sockets.ini
    - /etc/php.d/20-sqlite3.ini
    - /etc/php.d/20-tokenizer.ini
    - /etc/php.d/20-xml.ini
    - /etc/php.d/20-xmlwriter.ini
    - /etc/php.d/20-xsl.ini
    - /etc/php.d/30-mcrypt.ini
    - /etc/php.d/30-mysqli.ini
    - /etc/php.d/30-pdo_mysql.ini
    - /etc/php.d/30-pdo_sqlite.ini
    - /etc/php.d/30-wddx.ini
    - /etc/php.d/30-xmlreader.ini
    - /etc/php.d/50-mysql.ini
    - /etc/php.d/zend_extensions_psa.ini
  You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.

User avatar
3Di
Registered User
Posts: 762
Joined: Tue Nov 01, 2005 9:50 pm
Location: Milano (I) Frankfurt (D)
Contact:

Re: Install the dependencies (4.0.0-a1-dev)

Post by 3Di »

Needs at least PHP 7.1 like 3.3.0-b1-dev

phpbb4-install.png
try update composer

update_composer_cli.png
Last edited by 3Di on Mon May 27, 2019 4:11 am, edited 1 time in total.
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

User avatar
Solidjeuh
Registered User
Posts: 40
Joined: Sat Feb 25, 2017 6:42 pm
Location: Aalst, Belgium
Contact:

Re: Install the dependencies (4.0.0-a1-dev)

Post by Solidjeuh »

Everything is up-to-date.
I now have:

Code: Select all

[root@vps1704859 ~]# php --version
PHP 7.2.18 (cli) (built: Apr 30 2019 15:26:52) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
And this error
viewtopic.php?f=81&p=326691#p326691

User avatar
3Di
Registered User
Posts: 762
Joined: Tue Nov 01, 2005 9:50 pm
Location: Milano (I) Frankfurt (D)
Contact:

Re: Install the dependencies (4.0.0-a1-dev)

Post by 3Di »

facebook/webdriver 1.6.0 requires ext-zip * -> the requested PHP extension zip is missing from your system.

To enable extensions, verify that they are enabled in your .ini files
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

User avatar
Solidjeuh
Registered User
Posts: 40
Joined: Sat Feb 25, 2017 6:42 pm
Location: Aalst, Belgium
Contact:

Re: Install the dependencies (4.0.0-a1-dev)

Post by Solidjeuh »

Okay that's for tomorrow. 4 am, I go to sleep now.
Thx for the help!

User avatar
Solidjeuh
Registered User
Posts: 40
Joined: Sat Feb 25, 2017 6:42 pm
Location: Aalst, Belgium
Contact:

Re: Install the dependencies (4.0.0-a1-dev)

Post by Solidjeuh »

I cannot sleep, gonna think whole night about that problem :D
So I searched google, and found it.
I needed to install "php-pecl-zip" sudo yum --enablerepo=remi-php72 install php-pecl-zip

And the install went perfect now!
Thank you for the help guys! I'm still learning new things :)

https://www.solidjeuh.be/scripts/phpbbt ... /index.php

User avatar
3Di
Registered User
Posts: 762
Joined: Tue Nov 01, 2005 9:50 pm
Location: Milano (I) Frankfurt (D)
Contact:

Re: [Solved]Install the dependencies (4.0.0-a1-dev)

Post by 3Di »

If you want to use QuickInstall see: https://github.com/phpbb/quickinstall/pull/115
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

Post Reply