phpBB 3.2.0-a2 released

General discussion of development ideas and the approaches taken in the 3.x branch of phpBB. The next feature release of phpBB 3 will be 3.2/Rhea followed by 3.3.
Forum rules
Please do not post support questions regarding installing, updating, or upgrading phpBB 3.1. If you need support for phpBB 3.1 please visit the 3.1.x Support Forum on phpbb.com.

If you have questions regarding writing extensions please post in Extension Writers Discussion to receive proper guidance from our staff and community.
Locked
Nicofuma
3.2 Release Manager
3.2 Release Manager
Posts: 297
Joined: Sun Apr 13, 2014 1:40 am
Location: Paris

phpBB 3.2.0-a2 released

Post by Nicofuma » Sat Dec 19, 2015 4:09 pm

Release highlights

Just a few changes this time, mainly bug fixes and little improvement for the new installer/updater.

The packages can be downloaded from our package archive. Please test the packages to extend, so we can have a fail-save final release.
The phpBB Team
Member of the phpBB Development-Team
No Support via PM

User avatar
RMcGirr83
Registered User
Posts: 357
Joined: Fri Mar 09, 2007 1:51 am
Contact:

Re: phpBB 3.2.0-a2 released

Post by RMcGirr83 » Sun Dec 20, 2015 11:22 am

using install/app.php I get the following
A script on this page may be busy, or it may have stopped responding. You can stop the script now, open the script in the debugger, or let the script continue.

Script: http://127.0.0.1/qi/boards/316…assets/j ... ler.js:245
and in the console
Failed to parse JSON object

Message: JSON.parse: unexpected character at line 1 column 1 of the JSON data

Server Response: <br />
<b>Warning</b>: strpos() expects parameter 1 to be string, array given in <b>F:\xampp\htdocs\qi\boards\316\install\update\new\phpbb\install\helper\iohandler\iohandler_base.php</b> on line <b>104</b><br />
<br />
<b>Warning</b>: htmlspecialchars_decode() expects parameter 1 to be string, array given in <b>F:\xampp\htdocs\qi\boards\316\install\update\new\phpbb\install\helper\iohandler\iohandler_base.php</b> on line <b>106</b><br />

{"errors":[{"title":""}],"warnings":[{"title":"[phpBB debug] \"strpos() expects parameter 1 to be string, array given\" in file F:\\xampp\\htdocs\\qi\\boards\\316\\install\\update\\new\\phpbb\\install\\helper\\iohandler\\iohandler_base.php on line 104"},{"title":"[phpBB debug] \"htmlspecialchars_decode() expects parameter 1 to be string, array given\" in file F:\\xampp\\htdocs\\qi\\boards\\316\\install\\update\\new\\phpbb\\install\\helper\\iohandler\\iohandler_base.php on line 106"}],"logs":[],"success":[],"download":[],"form":"<form id=\"install_install\" method=\"POST\" action=\"\/qi\/boards\/316\/install\/app.php\/update\">\n\n\t\t\t\t\t\t\t\t<legend><\/legend>\n\t\t\t<fieldset class=\"submit-buttons\">\n\t<legend>Submit<\/legend>\n\t\t<input class=\"button1\" type=\"submit\" name=\"install\" value=\"Retest requirements\" \/>\n\t<\/fieldset>\n<\/form>\n"}
and the update never finishes.
Do not hire Christian Bullock he won't finish the job and will keep your money

ForoXL
Registered User
Posts: 2
Joined: Wed Oct 28, 2015 4:27 pm

Re: phpBB 3.2.0-a2 released

Post by ForoXL » Sun Dec 20, 2015 12:27 pm

RMcGirr83 wrote:
Sun Dec 20, 2015 11:22 am
using install/app.php I get the following
A script on this page may be busy, or it may have stopped responding. You can stop the script now, open the script in the debugger, or let the script continue.

Script: http://127.0.0.1/qi/boards/316…assets/j ... ler.js:245
and in the console
Failed to parse JSON object

Message: JSON.parse: unexpected character at line 1 column 1 of the JSON data

Server Response: <br />
<b>Warning</b>: strpos() expects parameter 1 to be string, array given in <b>F:\xampp\htdocs\qi\boards\316\install\update\new\phpbb\install\helper\iohandler\iohandler_base.php</b> on line <b>104</b><br />
<br />
<b>Warning</b>: htmlspecialchars_decode() expects parameter 1 to be string, array given in <b>F:\xampp\htdocs\qi\boards\316\install\update\new\phpbb\install\helper\iohandler\iohandler_base.php</b> on line <b>106</b><br />

{"errors":[{"title":""}],"warnings":[{"title":"[phpBB debug] \"strpos() expects parameter 1 to be string, array given\" in file F:\\xampp\\htdocs\\qi\\boards\\316\\install\\update\\new\\phpbb\\install\\helper\\iohandler\\iohandler_base.php on line 104"},{"title":"[phpBB debug] \"htmlspecialchars_decode() expects parameter 1 to be string, array given\" in file F:\\xampp\\htdocs\\qi\\boards\\316\\install\\update\\new\\phpbb\\install\\helper\\iohandler\\iohandler_base.php on line 106"}],"logs":[],"success":[],"download":[],"form":"<form id=\"install_install\" method=\"POST\" action=\"\/qi\/boards\/316\/install\/app.php\/update\">\n\n\t\t\t\t\t\t\t\t<legend><\/legend>\n\t\t\t<fieldset class=\"submit-buttons\">\n\t<legend>Submit<\/legend>\n\t\t<input class=\"button1\" type=\"submit\" name=\"install\" value=\"Retest requirements\" \/>\n\t<\/fieldset>\n<\/form>\n"}
and the update never finishes.
+1

User avatar
Marc
Development Team Leader
Development Team Leader
Posts: 123
Joined: Thu Sep 09, 2010 11:36 am
Location: Munich, Germany

Re: phpBB 3.2.0-a2 released

Post by Marc » Sun Dec 20, 2015 9:24 pm

Ticket for this has been created and a PR exists, too.

https://tracker.phpbb.com/browse/PHPBB3-14373

leschek
Registered User
Posts: 161
Joined: Tue Aug 28, 2012 1:30 pm

Re: phpBB 3.2.0-a2 released

Post by leschek » Mon Dec 21, 2015 12:29 pm

I tried to do test update from 3.1.3 to 3.2 a2. After checking files installer shows me message CANNOT_DELETE_FILES even if there are not any files to delete (I deleted them before) and I can't continue to update board.
Also, whole updater is in English except introduction page (I used translated language files and I changed language of installer).

I also tried to update 3.2 a1 to 3.2 a2 and when I try to open install/app.php I get this error:

Code: Select all

Catchable fatal error: Argument 1 passed to phpbb\di\container_builder::__construct() must be an instance of phpbb\config_php_file, string given, called in xxx\localweb\quickinstall\boards\ajaxchat\install\startup.php on line 121 and defined in xxx\localweb\quickinstall\boards\ajaxchat\phpbb\di\container_builder.php on line 121

User avatar
RMcGirr83
Registered User
Posts: 357
Joined: Fri Mar 09, 2007 1:51 am
Contact:

Re: phpBB 3.2.0-a2 released

Post by RMcGirr83 » Mon Dec 21, 2015 7:34 pm

called in xxx\localweb\quickinstall\boards\ajaxchat\install\startup.php
seems to have something to do with some ajaxchat thingy?
Do not hire Christian Bullock he won't finish the job and will keep your money

leschek
Registered User
Posts: 161
Joined: Tue Aug 28, 2012 1:30 pm

Re: phpBB 3.2.0-a2 released

Post by leschek » Mon Dec 21, 2015 8:08 pm

RMcGirr83 wrote:
Mon Dec 21, 2015 7:34 pm
called in xxx\localweb\quickinstall\boards\ajaxchat\install\startup.php
seems to have something to do with some ajaxchat thingy?
You are right. I used that board to test ajaxchat extension, but I disabled it and deleted its data and files, and I still have the same error.

Cin
Registered User
Posts: 20
Joined: Mon Mar 23, 2015 11:33 am

Re: phpBB 3.2.0-a2 released

Post by Cin » Mon Dec 28, 2015 4:24 pm

It there a way to update the database manually with CLI or something? When I click update, I get the message that everything upgraded however, my database is not. The version still says 3.1.5 and I get the following error:

Code: Select all

Fatal error: Uncaught Error: Class 'fastImageSize\fastImageSize' not found
I then updated the files manually and get a different error (The updater now doesn't give me the option to only update the db and is stuck updating the files.):

Code: Select all

Fatal error: Uncaught InvalidArgumentException: Invalid scheme name '' in phpBB/vendor/s9e/text-formatter/src/Configurator.php:5947 Stack trace: #0 
phpBB/vendor/s9e/text-formatter/src/Configurator.php(5584): s9e\TextFormatter\Configurator\Collections\SchemeList->normalizeValue('') #1 phpBB/vendor/s9e/text-formatter/src/Configurator.php(5619): s9e\TextFormatter\Configurator\Collections\NormalizedList->append('') #2 
phpBB/vendor/s9e/text-formatter/src/Configurator.php(4974): s9e\TextFormatter\Configurator\Collections\NormalizedList->offsetSet(NULL, '') #3 
phpBB/phpbb/textformatter/s9e/factory.php(207): s9e\TextFormatter\Configurator\UrlConfig->allowScheme('') #4 
phpBB/phpbb/textformatter/s9e/factory. in phpBB/vendor/s9e/text-formatter/src/Configurator.php on line 5947

User avatar
VSE
Extension Customisations
Extension Customisations
Posts: 670
Joined: Mon Mar 08, 2010 9:18 am

Re: phpBB 3.2.0-a2 released

Post by VSE » Mon Dec 28, 2015 5:08 pm

When I ran the Update Database Only option, it did not update the database (no migrations were run).

Yes there is a CLI option:
$ php bin/phpbbcli.php db:migrate
Has an irascible disposition.

Cin
Registered User
Posts: 20
Joined: Mon Mar 23, 2015 11:33 am

Re: phpBB 3.2.0-a2 released

Post by Cin » Wed Dec 30, 2015 3:23 pm

Everything is skipped until:

Code: Select all

...
Migration already effectively installed (skipped): \phpbb\db\migration\data\v320\announce_global_permission
Apply dependencies of \phpbb\db\migration\data\v320\text_reparser.
Installing Data: \phpbb\db\migration\data\v320\text_reparser.
Then I get this error:

Code: Select all

  [InvalidArgumentException]
  Invalid scheme name ''

Locked