Errors 1054/1146 and unable to use backup

Temporary forum to obtain support for MODs/Styles while phpbb.com is down
Locked
JDX
Registered User
Posts: 3
Joined: Tue Feb 10, 2009 2:43 pm

Errors 1054/1146 and unable to use backup

Post by JDX » Tue Feb 10, 2009 2:55 pm

Hello

With 90% of the forum infrastructure I have in place, I decided to make a backup of the forum before proceeding with the installation of several mods I wanted to use (namely using the backup feature in ACP).

The first mod I went to install was a 'did you know?' mod downloaded from: http://www.phpbbhacks.com/download/8673

The German translations were difficult to follow, and inevitably I didn't complete the mod installation correctly - the forum was producing error 1146.
So I decided to uninstall the mod by restoring backups of altered files.

Now, I get error 1146:

Code: Select all

General Error
SQL ERROR [ mysql4 ]

Table 'deathsta_phpb3.CONFIG_TABLE' doesn't exist [1146]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.
I've looked up a solution online, but nothing that's of any use to me (I'm a designer not a coder :lol: , I have absolutely no experience with SQL). Some boards stipulate that I need to run a database update, as provided by the mod. Which is non existent. The installation instructions and readme are equally useless - providing only the basic installation instructions.

Following this, I decided to open the instructions and remove all files listed, which I had been instructed to upload, which brings no benefit.

I've created a temporary forum and uploaded last nights' backup to that, but get error 1054:

Code: Select all

General Error
SQL ERROR [ mysql4 ]

Unknown column 't.template_inherits_id' in 'field list' [1054]

An SQL error occurred while fetching this page. Please contact the Board Administrator if this problem persists.
Presumably backups are specific to the database?

As I've said, I've no previous experience with SQL, but from what I can see - the database has been damaged by this mod. I'm not able to access the ACP of the forum, either. For reference, the forum is http://sf-rp.avstaruk.net/forum, and the temp one is http://sf-rp.avstaruk.net/tempforum.
Thanks in advance for any help you can provide.

User avatar
darcie
Community Team
Community Team
Posts: 189
Joined: Mon Mar 12, 2007 7:32 pm
Location: Davis, California
Contact:

Re: Errors 1054/1146 and unable to use backup

Post by darcie » Tue Feb 10, 2009 4:49 pm

The error on your main forum indicates that a table was deleted from your database. Restoring from that backup should have all the tables. The error you get after restoring indicates that the forum before backup was a version prior to 3.0.3 and the files currently installed are for a version 3.0.3 or greater. The database update you need to run to correct this issue is the one included with the full package of phpBB3. Upload the /install folder to your webspace. Then run http://sf-rp.avstaruk.net/tempforum/ins ... update.php (assuming you want to try this on the test board first!). Then delete the install folder once the script completes.

Let us know how that goes!

JDX
Registered User
Posts: 3
Joined: Tue Feb 10, 2009 2:43 pm

Re: Errors 1054/1146 and unable to use backup

Post by JDX » Tue Feb 10, 2009 9:00 pm

Thanks for the reply

Since I installed phpBB via Fantastico, I downloaded 3.0.2 from Brothersoft, uploaded /install to both forums and ran the php files.

temp forums comes back as the following, with the page formatted:

Code: Select all

Notice: Undefined index: LOG_DELETE_TOPIC in /home/deathsta/public_html/sf-rp/tempforum/language/en_us/common.php on line 877

Notice: Undefined property: dbal_mysql::$mysql_version in /home/deathsta/public_html/sf-rp/tempforum/install/database_update.php on line 544

Warning: Cannot modify header information - headers already sent by (output started at /home/deathsta/public_html/sf-rp/tempforum/language/en_us/common.php:877) in /home/deathsta/public_html/sf-rp/tempforum/install/database_update.php on line 571
Main forums comes back as the following, with the page not formatted:

Code: Select all

Notice: Use of undefined constant CONFIG_TABLE - assumed 'CONFIG_TABLE' in /home/deathsta/public_html/sf-rp/forum/install/database_update.php on line 114

Fatal error: SQL ERROR [ mysql4 ]

Table 'deathsta_phpb3.CONFIG_TABLE' doesn't exist [1146]

SQL

SELECT config_value FROM CONFIG_TABLE WHERE config_name = 'default_lang'

BACKTRACE

FILE: includes/db/mysql.php
LINE: 158
CALL: dbal->sql_error()

FILE: install/database_update.php
LINE: 116
CALL: dbal_mysql->sql_query()

in /home/deathsta/public_html/sf-rp/forum/includes/db/dbal.php on line 602
In both instances, General errors 1054 and 1146 respectively, have not been cleared =/

User avatar
darcie
Community Team
Community Team
Posts: 189
Joined: Mon Mar 12, 2007 7:32 pm
Location: Davis, California
Contact:

Re: Errors 1054/1146 and unable to use backup

Post by darcie » Tue Feb 10, 2009 9:32 pm

Arg, Fantastico. This is why we don't support those type of host provided script installers. :roll:

Please do this:
Download the real 3.0.4 from our package at http://www.ohloh.net/p/phpbb/download?p ... stallation
Upload all files except config.php, and your /images, /files, and /store directories.
Run the database update script http://sf-rp.avstaruk.net/tempforum/ins ... update.php

Your original forum is missing the config table from the database, so this will only be needed on the test forum. If this works out correctly, we can apply the same to your real forum address.

JDX
Registered User
Posts: 3
Joined: Tue Feb 10, 2009 2:43 pm

Re: Errors 1054/1146 and unable to use backup

Post by JDX » Wed Feb 11, 2009 12:16 am

Win. Brilliant. Thanks a lot.

tbh I've not had problems with fantastico before, but if something as minor as dodgy translations can cause a problem like this, I doubt I'll be using it again.
Again, thanks for the help.

(And I'm going to make regular directory backups, too ;) )

Locked