Avatars not appearing?

Temporary forum to obtain support while phpBB.com is offline.
Please use the support forum on phpBB.com
Forum rules
Temporary forum to obtain support while phpBB.com is offline.
Please use the support forum on phpBB.com
Locked
river-grace
Registered User
Posts: 1
Joined: Mon Feb 09, 2009 7:48 am

Avatars not appearing?

Post by river-grace »

Hi,
yesterday for some reason, everyone's avatars stopped showing up - except mine and one of the moderators. Our avatars are both animated gifs, whereas everyone else's were mostly jpegs. The other users have tried re-uploading their avatars from their computers as well as uploading from another site like Photobucket or Tinypic.com and they're still not showing up. When they upload from their hard-drives, it says it's uploaded successfully but it doesn't physically appear. When they upload from something like Tinypic.com, they get this error:

[phpBB Debug] PHP Notice: in file /includes/functions_upload.php on line 787: tempnam() [function.tempnam]: open_basedir restriction in effect. File() is not within the allowed path(s): (/tmp:/var/tmp:/var/www/errors:/usr/share/php:/home/vol3/xtreemhost.com/xth_2527872/myfairyking.net/htdocs)

I double checked everything was 777'd, it is. The upload path is images/avatars/upload. I haven't upgraded to 3.0.4, I'm currently on 3.0.2. Hope I've given enough info about everything, can anyone help me with this?
User avatar
karlsemple
Registered User
Posts: 480
Joined: Mon Jan 23, 2006 8:49 am
Location: Hereford
Contact:

Re: Avatars not appearing?

Post by karlsemple »

[phpBB Debug] PHP Notice: in file /includes/functions_upload.php on line 787: tempnam() [function.tempnam]: open_basedir restriction in effect. File() is not within the allowed path(s): (/tmp:/var/tmp:/var/www/errors:/usr/share/php:/home/vol3/xtreemhost.com/xth_2527872/myfairyking.net/htdocs)
This error is something you will need to take up with the host as it suggests they are making restrictions to the php set up and what file locations php is allowed to access on the server.

However in relation to the images not showing, are the avatar images present and in the right location? Do your gallery avatars work?
Locked