smf to phpbb3 conversion error

Temporary forum to obtain support while phpBB.com is offline.
Please use the support forum on phpBB.com
Forum rules
Temporary forum to obtain support while phpBB.com is offline.
Please use the support forum on phpBB.com
Dicky
Registered User
Posts: 125
Joined: Tue Feb 08, 2005 4:15 am

Re: smf to phpbb3 conversion error

Post by Dicky »

stu83 wrote:there wouldnt be something wrong with my install or database structure to cause that would there?
There may be something wrong. I recommend that you drop the phpBB3 tables, upload an empty config.php and reinstall phpBB3. Also, reupload the SMF convertor files. They may have gotten corrupted.
stu83 wrote:where can i download the v2 converter?
SMF 1.1.1 to phpBB2. I highly recommend that you try to get the phpbB3 convertor to work. The SMF to phpBB3 convertor will give you a much better conversion.

stu83
Registered User
Posts: 12
Joined: Wed Feb 04, 2009 11:11 pm

Re: smf to phpbb3 conversion error

Post by stu83 »

Dicky wrote:
stu83 wrote:there wouldnt be something wrong with my install or database structure to cause that would there?
There may be something wrong. I recommend that you drop the phpBB3 tables, upload an empty config.php and reinstall phpBB3. Also, reupload the SMF convertor files. They may have gotten corrupted.
stu83 wrote:where can i download the v2 converter?
SMF 1.1.1 to phpBB2. I highly recommend that you try to get the phpbB3 convertor to work. The SMF to phpBB3 convertor will give you a much better conversion.

the phpbb3 install was completely fresh, no tables, no posts, no nothing, so the config.php would be blank wouldnt it?


ive already tried re-downloading the forum and coverter files and reinstalling them and had the same issues

Dicky
Registered User
Posts: 125
Joined: Tue Feb 08, 2005 4:15 am

Re: smf to phpbb3 conversion error

Post by Dicky »

stu83 wrote:the phpbb3 install was completely fresh, no tables, no posts, no nothing, so the config.php would be blank wouldnt it?
If the phpBB3 board is installed and running, the config.php is not empty. It will contain the information to connect to your database.

Re your problem: the users and bots are added in the last step. First to be converted are the forums, topics, posts and some other tables. Are these not being converted? If they are being converted, then probably your database user does not have DELETE permissions. If the posts, etc., are not being converted first, there is something wrong with the convertor files you have.

Locked