Solved -- was "CGI misbehaved"

Temporary forum to obtain support while phpBB.com is offline.
Please use the support forum on phpBB.com
Forum rules
Temporary forum to obtain support while phpBB.com is offline.
Please use the support forum on phpBB.com
kalamitykatie
Registered User
Posts: 14
Joined: Wed Feb 04, 2009 4:46 am

Re: CGI misbehaved

Post by kalamitykatie »

One thing that I notice as I look at that is
Configuration File (php.ini) Path C:\WINDOWS

I had php.ini in the PHP directory and in c:\windows\system32 but not in c:\windows.

I placed a copy in c:\windows as well as a copy of php5ts.dll.

No change.

Thanks,
Katie
kalamitykatie
Registered User
Posts: 14
Joined: Wed Feb 04, 2009 4:46 am

Loading blank page using ISAPI, was CGI misbehaved

Post by kalamitykatie »

BTW, if I change it back to CGI, the pages load, but we still get the CGI error.

Thanks,
Katie
kalamitykatie
Registered User
Posts: 14
Joined: Wed Feb 04, 2009 4:46 am

Re: Loading blank page using ISAPI - was CGI misbehaved

Post by kalamitykatie »

Any other ideas?

I've been experimenting -- I get the CGI errors on the forums configured to use CGI and a blank page on forums configured for ISAPI.
kalamitykatie
Registered User
Posts: 14
Joined: Wed Feb 04, 2009 4:46 am

Re: Loading blank page using ISAPI - was CGI misbehaved

Post by kalamitykatie »

It has come to my attention that we do have a phpbb3 board functioning correctly on our server, using php-cgi.exe. I can't find what might be different about that configuration, though. The 3 new installations all throw the CGI Misbehaved error on registration and the forum that I really care about getting working correctly ASAP throws it after ever post.

I'm running out of hair.

Any ideas?

Thanks!

~Katie
hammy
Registered User
Posts: 4
Joined: Fri Oct 14, 2005 11:40 am

Re: Loading blank page using ISAPI - was CGI misbehaved

Post by hammy »

I found this to be a helpfull tutorial link to tutorial
kalamitykatie
Registered User
Posts: 14
Joined: Wed Feb 04, 2009 4:46 am

Re: Solved -- was "CGI misbehaved"

Post by kalamitykatie »

Under the CGI configuration, the board is now working.

If you should have the same problem. Log into the ACP, click on Security Settings under the General tab and check if “Check e-mail domain for valid MX record:” is set to Yes. If so, set it to No.

~Katie
Locked