Solved -- was "CGI misbehaved"

Temporary forum to obtain support while phpBB.com is offline.
Please use the support forum on phpBB.com
Forum rules
Temporary forum to obtain support while phpBB.com is offline.
Please use the support forum on phpBB.com
kalamitykatie
Registered User
Posts: 14
Joined: Wed Feb 04, 2009 4:46 am

Solved -- was "CGI misbehaved"

Post by kalamitykatie »

Hello,

I have a new forum set up, replacing one that was hosted elsewhere on which there was a database corruption, with people registering as I type and starting to populate the board with posts, and we're getting:

"The specified CGI application misbehaved by not returning a complete set of HTTP headers."

I *thought* the error was just happening on registrations and have been searching the web for solutions and have tried a number found, to no avail.

I haven't been able to register here until today.

We have IIS 6 on a Windows Server 2003.

Any help would be immensely appreciated.

Thanks!
~Katie
Last edited by kalamitykatie on Thu Feb 05, 2009 5:42 pm, edited 2 times in total.
bolverk
I've been banned
Posts: 280
Joined: Mon Feb 02, 2009 5:39 pm

Re: CGI misbehaved

Post by bolverk »

Is your IIS running PHP as an ISAPI Extension or as a CGI extension?
kalamitykatie
Registered User
Posts: 14
Joined: Wed Feb 04, 2009 4:46 am

Re: CGI misbehaved

Post by kalamitykatie »

CGI extention, but I've tried it as ISAPI extension as well to no avail, but I might not have configured it correctly when I did so, so I'm open to suggestion.

Thanks!
~Katie
bolverk
I've been banned
Posts: 280
Joined: Mon Feb 02, 2009 5:39 pm

Re: CGI misbehaved

Post by bolverk »

Run PHP as ISAPI. Try setting it up following the tutorial located here.
kalamitykatie
Registered User
Posts: 14
Joined: Wed Feb 04, 2009 4:46 am

Re: CGI misbehaved

Post by kalamitykatie »

I tried that earlier today, but I will try it again in case I screwed up somewhere. Despite the errors, the board is busy enough right now that I'm going to wait a little while.

Thanks!
~Katie
kalamitykatie
Registered User
Posts: 14
Joined: Wed Feb 04, 2009 4:46 am

Re: CGI misbehaved

Post by kalamitykatie »

It occurred to me that I have another board (inactive) with the same problem so I can test on that one now.
I followed those steps and now when I browse to that test forum, which is http://www.christieflowershop.com, I get a blank page.

Thanks,
Katie
kalamitykatie
Registered User
Posts: 14
Joined: Wed Feb 04, 2009 4:46 am

Re: CGI misbehaved

Post by kalamitykatie »

Now on the test site (and I haven't changed anything in IIS), it brings up a login.
Do I need to change permissions somewhere after switching from CGI to ISAPI?

Thanks,
Katie
kalamitykatie
Registered User
Posts: 14
Joined: Wed Feb 04, 2009 4:46 am

Re: CGI misbehaved

Post by kalamitykatie »

I messed around more last night, probably a mistake as I was too tired, following directions on php.net regarding ISAPI and ISAPI filters, and now, once again, the test site, http://www.christieflowershop.com loads a blank page.

I appreciate the help I've received so far, I think you have me going in the right direction. I just need to get past another hurdle now.

Once again, any assistance would be greatly appreciated!

Thanks,
Katie
bolverk
I've been banned
Posts: 280
Joined: Mon Feb 02, 2009 5:39 pm

Re: CGI misbehaved

Post by bolverk »

Create a file named phpinfo.php and paste the following code into it:

Code: Select all

<?php phpinfo(); ?>
Upload this file to your www root and then try to execute it in your browser.....i.e. yourwebsite/phpinfo.php
Post back what your results are.
kalamitykatie
Registered User
Posts: 14
Joined: Wed Feb 04, 2009 4:46 am

Re: CGI misbehaved

Post by kalamitykatie »

This is what was displayed when I loaded phpinfo.php:

Build Date May 4 2006 10:30:29
Configure Command cscript /nologo configure.js "--enable-snapshot-build" "--with-gd=shared"
Server API ISAPI
Virtual Directory Support enabled
Configuration File (php.ini) Path C:\WINDOWS
PHP API 20041225
PHP Extension 20050922
Zend Extension 220051025
Debug Build no
Thread Safety enabled
Zend Memory Manager enabled
IPv6 Support enabled
Registered PHP Streams php, file, http, ftp, compress.zlib
Registered Stream Socket Transports tcp, udp
Registered Stream Filters convert.iconv.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, zlib.*




Thanks,
Katie
Locked