Need some advice

Discussion of general topics related to the new version and its place in the world. Don't discuss new features, report bugs, ask for support, et cetera. Don't use this to spam for other boards or attack those boards!
Forum rules
Discussion of general topics related to the new release and its place in the world. Don't discuss new features, report bugs, ask for support, et cetera. Don't use this to spam for other boards or attack those boards!
Post Reply
backtobasics
Registered User
Posts: 1
Joined: Wed Jan 17, 2007 7:30 am

Need some advice

Post by backtobasics »

OK, so I am running PHPBB 2.0.22 for a website I maintain. I so badly want to move to PHPBB 3 B4, but I don't want to add templates/MODS/themes etc etc if I can't keep all this when beta 5 or RC1 eventually comes out (any word on this?).

But I really do need to upgrade my forum sometime next month. Any advice on what to do?

Thanks

User avatar
karlsemple
Registered User
Posts: 480
Joined: Mon Jan 23, 2006 8:49 am
Location: Hereford
Contact:

Re: Need some advice

Post by karlsemple »

phpBB is still in the beta stages and as such not to be used as a production forum, it is likely there will be no update path from the beta to the final which unless you are highly skilled will leave you stuck on the beta indefinitely. Plus upgrading to phpBB3 from phpBB2 will mean losing all your phpBB2 mods as the phpBB2 mods will not work on phpBB3. your best bet is staying with phpBB2 until at least the release candidate or the final version of phpBB 3 is released :)

User avatar
Nicholas the Italian
Registered User
Posts: 659
Joined: Mon Nov 20, 2006 11:19 pm
Location: 46°8' N, 12°13' E
Contact:

Re: Need some advice

Post by Nicholas the Italian »

The general rule for these questions, I think, is: If you are in doubt, don't risk. Just do not.

The updater will be included in beta5, so probably there's gonna be an upgrade path since then, also because beta5 aim should be only bug fixing (so, no major changes expected). But, who knows? Devs may see that some little modification is still needed, and this may lead them to mess things up as much as they want/deem necessary.
To state it clear: I will not use phpBB3 before RC, for the small board of my site.
Are you not willing to wait? Well, do what you feel: you might be lucky and encounter no problem at all; after all, many think the software is (or will be from beta5) already very good, compared to phpBB2. But, you may lose everything, and you're on your own. I repat: lose everything. I repeat: on your own. So, don't blame us, me, or the phpBB team, don't go complaining and annoying the support staff, if anything goes wrong.
If the board is not so much important to you (few users, just hobby, no work/money involved, etc.), you may want to take the risk. But hey, it's a risk. You win, you lose. You're the only one to blame.

And, to repeat the rule: If you are in doubt, don't risk. Just do not.

Is that clear? ;)

cutaia
Registered User
Posts: 45
Joined: Wed Mar 30, 2005 4:08 am
Location: Aurora, CO
Contact:

Re: Need some advice

Post by cutaia »

The only advice is this: DO NOT upgrade to an unsupported beta unless you are a master in PHPBB programming.

Hint: If you have to ask if you should upgrade to Beta...then you are not said master.



If you do decide to do it, this is the support you can expect in the future when you try to upgrade to RC1: viewtopic.php?f=3&t=26457

Post Reply