Installed Flag mod forum is down

Wondering why that MOD you have won't install correctly? Let's take a look
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
bart0507
Registered User
Posts: 6
Joined: Mon Jun 30, 2008 2:19 am

Installed Flag mod forum is down

Post by bart0507 » Mon Jun 30, 2008 2:24 am

I'm a total newbie i installed easymod and tried to install country flags 2.3.2 the easy mod was doing its thing than it said to finish manualy, It gave me three options.

Method 1: Copy root/install/db_update_en.php to install/db_update_en.php. Execute and delete after it has been run
Method 2: Use EasyMOD to run contrib/install/db_update_en.txt
Method 3: Copy the SQL query from contrib/install/db_update_en.txt and execute it manually

when i log in and goto profiles i get this message:

Couldn't obtain flags information.

DEBUG MODE

SQL Error : 1146 Table 'morayfie_bartforum.phpbb_flags' doesn't exist

SELECT * FROM phpbb_flags ORDER BY flag_name

Line : 952
File : usercp_register.php

I installed easymod because I have no clue how to install manually, no i'm stuck what can I do.

help anyone thanks,

bart0507
Registered User
Posts: 6
Joined: Mon Jun 30, 2008 2:19 am

Re: Installed Flag mod forum is down

Post by bart0507 » Mon Jun 30, 2008 7:20 am

Ok I'm trying method one, do I delete the "install file" and the "contrib file" in the flag mod?

I have read this forum but i'm still confused, sorry but need help. I 'm sure it easy........................

User avatar
Kevin Clark
Support Team
Support Team
Posts: 751
Joined: Thu Feb 10, 2005 5:34 pm
Location: UK
Contact:

Re: Installed Flag mod forum is down

Post by Kevin Clark » Mon Jun 30, 2008 9:36 am

Looks like you haven't done method 1 or it hasn't run correctly.

The MOD is looking for a table in the database which hasn't been made yet. The script in method 1 makes that table.

So, you copy the install folder to your forum folder.
Then go to
yoursite.com/forumfolder/install/db_update_en.php

That will create the table.
Delete the install folder.

Done.
Image

bart0507
Registered User
Posts: 6
Joined: Mon Jun 30, 2008 2:19 am

Re: Installed Flag mod forum is down

Post by bart0507 » Mon Jun 30, 2008 2:56 pm

ok I copied the install folder to my forum folder already run db_update_en.php and i saw it create the table , then i deleted the install , but i still have the same problem.

Couldn't obtain flags information.
DEBUG MODE
SQL Error : 1146 Table 'morayfie_bartforum.phpbb_flags' doesn't exist
SELECT * FROM phpbb_flags ORDER BY flag_name
Line : 952
File : usercp_register.php

what went wrong

bart0507
Registered User
Posts: 6
Joined: Mon Jun 30, 2008 2:19 am

Re: Installed Flag mod forum is down

Post by bart0507 » Mon Jun 30, 2008 3:44 pm

ok i got it, thanks Kevin I have tried for two days

this............. Method 1: Copy root/install/db_update_en.php to install/db_update_en.php. Execute and delete after it has been run

is the best way to fix , but it doesn't explain itself properly to a newbie, what you wrote made more sense

So, you copy the install folder to your forum folder.
Then go to
yoursite.com/forumfolder/install/db_update_en.php


and don't forget to press "yes" at the bottom

however i don't see the flags come up and even weirder all the avatar i cannot see, but i do see them in my profile.

any thoughts. :?:

bart0507
Registered User
Posts: 6
Joined: Mon Jun 30, 2008 2:19 am

Re: Installed Flag mod forum is down

Post by bart0507 » Tue Jul 01, 2008 6:52 am

never mind dumbass fixed it.

Locked