External Forum Redirect

Wondering why that MOD you have won't install correctly? Let's take a look
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
DontWannaName
Registered User
Posts: 7
Joined: Sat Sep 22, 2007 4:39 pm

External Forum Redirect

Post by DontWannaName » Mon Sep 24, 2007 11:54 pm

I searched on forums and found this same question but with no answer. I tried installing it with EM and I get this error:

Code: Select all

Function Trace: open_files[5]->modio_open[1]

Could not open [\admin\admin_forums.php] for reading.
MOD script line #187
I have no idea how to get past that lol.

DontWannaName
Registered User
Posts: 7
Joined: Sat Sep 22, 2007 4:39 pm

Re: External Forum Redirect

Post by DontWannaName » Thu Sep 27, 2007 2:24 am

can anyone help?! plz,

User avatar
Lumpy Burgertushie
Registered User
Posts: 1006
Joined: Tue Feb 28, 2006 5:26 pm

Re: External Forum Redirect

Post by Lumpy Burgertushie » Sat Sep 29, 2007 5:45 pm

DontWannaName wrote:can anyone help?! plz,
make sure that that file has the correct permissions set: chmod 644

make sure that the file is where it is supposed to be and is named correctly.

make sure that your easymod settings are correct for path to the board and for ftp username/password , etc.

robert

DontWannaName
Registered User
Posts: 7
Joined: Sat Sep 22, 2007 4:39 pm

Re: External Forum Redirect

Post by DontWannaName » Sun Sep 30, 2007 5:31 am

Nope didnt work. 644 ruins EasyMod btw. Has to be 777

User avatar
Lumpy Burgertushie
Registered User
Posts: 1006
Joined: Tue Feb 28, 2006 5:26 pm

Re: External Forum Redirect

Post by Lumpy Burgertushie » Sun Sep 30, 2007 5:50 am

DontWannaName wrote:Nope didnt work. 644 ruins EasyMod btw. Has to be 777
the only thing that should be set to 777 is your avatars folder and then only if you are going to allow members to upload avatars to your server.

you should never, ever set any of the php files to 777

I am not sure what you are doing, but you are doing something wrong in the way you are installing easymod or something.

robert

User avatar
Poomerio
Registered User
Posts: 552
Joined: Tue Jan 02, 2007 7:09 pm
Location: 4(x - 20y) = 20

Re: External Forum Redirect

Post by Poomerio » Sun Sep 30, 2007 7:51 am

DontWannaName:
EasyMOD files are supposed to be set to 644, or -rw-r--r--
If you have them set to 777, then that poses as a major security threat.

- Poomie

DontWannaName
Registered User
Posts: 7
Joined: Sat Sep 22, 2007 4:39 pm

Re: External Forum Redirect

Post by DontWannaName » Sun Sep 30, 2007 10:48 pm

I know I channged them. I still cant install this mod though :(

Dicky
Registered User
Posts: 125
Joined: Tue Feb 08, 2005 4:15 am

Re: External Forum Redirect

Post by Dicky » Thu Oct 18, 2007 3:31 am

The problem is with the MOD install file and not with EasyMOD. The MOD was written and meant to be installed by hand, not with EasyMOD.

FIND (line 187)

Code: Select all

\admin\admin_forums.php
REPLACE WITH

Code: Select all

admin\admin_forums.php
The backward slash at the beginning should not be there. There are a couple more OPEN statements like that that you will have to fix also.

DontWannaName
Registered User
Posts: 7
Joined: Sat Sep 22, 2007 4:39 pm

Re: External Forum Redirect

Post by DontWannaName » Thu Oct 18, 2007 3:54 am

Still doesnt work, same error. If I were to do this by hand I would scrue somthing up bigtime and its really hard in notepad and dreamweave to find and paste to the right place.

User avatar
Lumpy Burgertushie
Registered User
Posts: 1006
Joined: Tue Feb 28, 2006 5:26 pm

Re: External Forum Redirect

Post by Lumpy Burgertushie » Sat Oct 27, 2007 4:37 am

DontWannaName wrote:Still doesnt work, same error. If I were to do this by hand I would scrue somthing up bigtime and its really hard in notepad and dreamweave to find and paste to the right place.
notepad is just about useless, and whatever you do , DO NOT open any of the phpbb files in dreamweaver. If you have , then chances are that you have corrupted them and need to start with clean new files.

as for the errror, it means just what it says, it can not find that file where it is looking for it.

either put it where the MOD is looking for it, or change where the MOD is looking.

it is just as simple as that.

robert

Locked