MOD: Nulavatar - Error during install...

Wondering why that MOD you have won't install correctly? Let's take a look
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
nokturn
Registered User
Posts: 1
Joined: Mon Jul 23, 2007 1:55 am

MOD: Nulavatar - Error during install...

Post by nokturn »

I have an error wile trying to install nulavatar.

Code: Select all

FIND FAILED: In file [viewtopic.php] could not find:

'SIGNATURE' => $user_sig,
'EDITED_MESSAGE' => $l_edited_by,
Then I tried by hand, and everything is as the instructions say...
when I go to the management page the following error occurs...

Code: Select all

Template->make_filename(): Error - file admin/nulavatar_admin_body.tpl does not exist 
I thought creating a file with that name could work... but then again... I have not enough experience to do it...
Besides... I run the instal php file and it gives me a series of errors...
Some I understood them, as they only happened because I tried to run the installer more than once...
But the other ones... I'm clueless...
NulAvatar 1.3.1 Installer!

Check if phpbb_nulmods table exists...YES
Check for NulAvatar entry...found! Updating version number... COMPLETED
Creating table "nulavatar_settings"... FAILED
Error Message:Table 'phpbb_nulavatar_settings' already exists
Updating Settings table... COMPLETED
Updating Settings table... COMPLETED
Updating Settings table... COMPLETED
Altering Settings table... FAILED
Error Message:Duplicate column name 'config_isradio'
Altering Settings table... FAILED
Error Message:Duplicate column name 'config_radio_choices'
Updating Settings table... COMPLETED
Updating Settings table... COMPLETED
Updating Settings table... COMPLETED
Creating "nulavatar_layers" table... FAILED
Error Message:Invalid default value for 'dontshowlayer'
Creating "nulavatar_images" table... FAILED
Error Message:Table 'phpbb_nulavatar_layers' already exists
Creating "nulavatar_userchars" table... FAILED
Error Message:Invalid default value for 'user'
Updating Settings table... COMPLETED
Updating Settings table... COMPLETED
Updating Settings table... COMPLETED
Updating Settings table... COMPLETED


Checking if NulAvatar is able to write to ./images/nulavatar_avatars/... YES



Finished!
The installation was not successful. Please try again!
If the problem persists, please post in the NulAvatar thread!
Can anyone help me with this?
User avatar
Poomerio
Registered User
Posts: 552
Joined: Tue Jan 02, 2007 7:09 pm
Location: 4(x - 20y) = 20

Re: MOD: Nulavatar - Error during install...

Post by Poomerio »

It seems as though the installer cannot find:

Code: Select all

'SIGNATURE' => $user_sig,
'EDITED_MESSAGE' => $l_edited_by,
In viewtopic.php

What is the line on which the error occurred?

- Poomie
User avatar
Kevin Clark
Support Team
Support Team
Posts: 751
Joined: Thu Feb 10, 2005 5:34 pm
Location: UK
Contact:

Re: MOD: Nulavatar - Error during install...

Post by Kevin Clark »

nokturn wrote:Then I tried by hand, and everything is as the instructions say...
when I go to the management page the following error occurs...

Code: Select all
Template->make_filename(): Error - file admin/nulavatar_admin_body.tpl does not exist



I thought creating a file with that name could work... but then again... I have not enough experience to do it...
That file will be part of the MOD. See if the MOD comes with a folder called root. That will have files that need to be uploaded.
Image
Locked