Shops/More

Wondering why that MOD you have won't install correctly? Let's take a look
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
Deadfire
Registered User
Posts: 5
Joined: Fri Sep 22, 2006 2:58 am

Re: Shops/More

Post by Deadfire » Fri Sep 22, 2006 12:09 pm

Princessgodess05 wrote:

Code: Select all

$lang['shops'] = 'Shops', $lang['items'] = 'Items',
Warning: Cannot modify header information - headers already sent by (output started at /home/roleplay/public_html/language/lang_english/lang_main.php:1028) in /home/roleplay/public_html/includes/page_header.php on line 487

Warning: Cannot modify header information - headers already sent by (output started at /home/roleplay/public_html/language/lang_english/lang_main.php:1028) in /home/roleplay/public_html/includes/page_header.php on line 489

Warning: Cannot modify header information - headers already sent by (output started at /home/roleplay/public_html/language/lang_english/lang_main.php:1028) in /home/roleplay/public_html/includes/page_header.php on line 490
What is this mean?


That is caused by a space being at the end of the file after the "?>" in your lang_main.php. However this is not the be all/ End all answer, but check that file

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Shops/More

Post by Nightrider » Fri Sep 22, 2006 1:33 pm

Thanks for the assist Deadfire. I hope that proves to be the problem...

Image

Zarath
Registered User
Posts: 20
Joined: Fri Mar 03, 2006 11:43 pm

Re: Shops/More

Post by Zarath » Fri Sep 22, 2006 4:47 pm

That was caused by an error in the install_mod.txt file, specifically "AFTER ADD" instead of "BEFORE ADD". I've just fixed it.

The problem is indeed in your language/lang_english/lang_main.php file, right at the end...

It should look like

Code: Select all

$lang['shops'] = 'Shops';
$lang['items'] = 'Items';
?>
This was also from the latest version of the shop mod, 3.0.2... which is easymod compliant. :)

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Shops/More

Post by Nightrider » Fri Sep 22, 2006 5:09 pm

Thanks Zarath. I downloaded Shop MOD 3.0.2 but in the MOD script found in the install folder, it says that it is version 3.0.1. Also, I don't see anywhere in the MOD script where it is modifying the lang_main.php file. Perhaps if the download link to 3.0.2 is actually giving me the older version, that would explain it. This is where I found the download...

Free Modifications

Edit: I just downloaded the file again. The MOD version is still 3.0.1, but this time there is a section that modifies the lang_main.php file. You must have added that section after I downloaded 3.0.2 the first time around several weeks ago...

Image

Zarath
Registered User
Posts: 20
Joined: Fri Mar 03, 2006 11:43 pm

Re: Shops/More

Post by Zarath » Sat Sep 23, 2006 2:30 am

Ahh, that figures... from all the files where I updated the version, the one file I forgot to update was the install file. :)

Well, I've fixed it now. The mod_install.txt file is also in the root folder now, so new installers don't have to move it.
I added the extra lang variables the other night, but didn't bother updating the version. It didn't actually change anything in the shop. I did it when I made it EasyMod compatible. :)

User avatar
Princessgodess05
Registered User
Posts: 40
Joined: Sat Sep 16, 2006 6:21 am

Re: Shops/More

Post by Princessgodess05 » Sat Sep 23, 2006 3:03 am

I am Sorry WHAT?
I love you!

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Shops/More

Post by Nightrider » Sat Sep 23, 2006 5:00 am

Thanks Zarath. The MOD Version really isn't a major problem, just a bit confusing when it didn't match the download version. I figured that you didn't get around to changing it...

The question has come up several times asking whether some of the other associated MODs will work with the latest version of the Shop MOD. The comment on a few says that they will work with 2.6.0. Will they work with 3.0.2 too???

Image

Zarath
Registered User
Posts: 20
Joined: Fri Mar 03, 2006 11:43 pm

Re: Shops/More

Post by Zarath » Sat Sep 23, 2006 9:58 am

Depends on the mod... I've updated most of my mods to work with them, on my site. So if they say under requires "3.x" then they work with it. User shops are being updated at the moment to work with the new version. Mods by other people...

NulAvatar works with it, apparently, although this mod has a large exploit in the item handling system the author hasn't fixed.

Others, like Moogie's, will not work with it. Unless someone has updated them... The reason is because I changed the item handling system significantly, and these still rely on the old unreliable, and bad method. :(
I suggest they ask the authors if they've updated it to work with shop 3.x...

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Shops/More

Post by Nightrider » Sat Sep 23, 2006 12:26 pm

Ok, so for now, the Lottery and User Shops MOD are only compatible with 2.6.0? If so, I will let people know when they ask. Do you have any plans to upgrade these MODs or can you find the same functionality in some of the other MODs that you have made available???

Image

Zarath
Registered User
Posts: 20
Joined: Fri Mar 03, 2006 11:43 pm

Re: Shops/More

Post by Zarath » Sun Sep 24, 2006 1:47 am

Lottery mod works fine with 3.x as long as you don't try use the items feature of it...

I'm currently working on updating the user shops to work with 3.x, just need to fix a restore item problem in the admin panel and lang file the mod and it's ready to go. :)

Locked