phpgarage mod

Wondering why that MOD you have won't install correctly? Let's take a look
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
Goucho
Posts: 86
Joined: Sun Aug 20, 2006 12:54 am

phpgarage mod

Post by Goucho »

hi there get these errors (diiferent forum this time).............
Error Detail

Warning

FIND FAILED: In file [templates/AdInfinitum/viewtopic_body.tpl] could not find:

{postrow.POSTER_JOINED}<br />{postrow.POSTER_POSTS}<br />{postrow.POSTER_FROM}

MOD script line #847 :: FAQ :: Report

Error Detail

Warning

IN-LINE FIND FAILED: In file [templates/Glass2X/viewtopic_body.tpl] could not find:

{postrow.POSTER_FROM}

MOD script line #856 :: FAQ :: Report

Error Detail

Warning

FIND FAILED: In file [templates/Glass2X/overall_footer.tpl] could not find:

<div align="center"><span class="copyright"><br />

MOD script line #867 :: FAQ :: Report

Error Detail

Warning

IN-LINE FIND FAILED: In file [templates/SoftBlue/overall_footer.tpl] could not find:

<span class="copyright"><br />

MOD script line #875 :: FAQ :: Report

Error Detail

Warning

FIND FAILED: In file [templates/AdInfinitum/overall_header.tpl] could not find:

<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">

MOD script line #886 :: FAQ :: Report

Error Detail

Warning

FIND FAILED: In file [templates/Glass2X/overall_header.tpl] could not find:

<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">

MOD script line #886 :: FAQ :: Report

Error Detail

Warning

FIND FAILED: In file [templates/SoftBlue/overall_header.tpl] could not find:

<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">

MOD script line #886 :: FAQ :: Report

Error Detail

Warning

FIND FAILED: In file [templates/wow_alliance/overall_header.tpl] could not find:

<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">

MOD script line #886 :: FAQ :: Report

Error Detail

Warning

FIND FAILED: In file [templates/AdInfinitum/profile_view_body.tpl] could not find:

//--></script><noscript>{ICQ_IMG}</noscript></td>
</tr>

MOD script line #903 :: FAQ :: Report

Error Detail

Warning

FIND FAILED: In file [templates/Glass2X/profile_view_body.tpl] could not find:

//--></script><noscript>{ICQ_IMG}</noscript></td>
</tr>

MOD script line #903 :: FAQ :: Report

Error Detail

Warning

FIND FAILED: In file [templates/wow_alliance/profile_view_body.tpl] could not find:

//--></script><noscript>{ICQ_IMG}</noscript></td>
</tr>

MOD script line #903 :: FAQ :: Report

Code: Select all

http://www.phpbb.com/phpBB/viewtopic.php?t=369533&highlight=garage
thanx
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: phpgarage mod

Post by Nightrider »

Ok, try this:

OPEN
Install Garage.txt

FIND

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
# this is a partial search : the full line is longer
{postrow.POSTER_JOINED}<br />{postrow.POSTER_POSTS}<br />{postrow.POSTER_FROM}
REPLACE WITH

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
# this is a partial search : the full line is longer
{postrow.POSTER_FROM}
FIND

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
<div align="center"><span class="copyright"><br />
#
#-----[ IN-LINE FIND ]------------------------------------------
#
<span class="copyright"><br />
REPLACE WITH

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
copyright"><br />
#
#-----[ IN-LINE FIND ]------------------------------------------
#
copyright"><br />
FIND

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">
#
#-----[ IN-LINE FIND ]------------------------------------------
#
<span class="mainmenu">&nbsp;
REPLACE WITH

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
mainmenu">&nbsp;
#
#-----[ IN-LINE FIND ]------------------------------------------
#
mainmenu">&nbsp;
FIND

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
		  //--></script><noscript>{ICQ_IMG}</noscript></td>
		</tr>
REPLACE WITH

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
{ICQ_IMG}
</tr>
Save, upload, and try again using EM...

Image
Goucho
Posts: 86
Joined: Sun Aug 20, 2006 12:54 am

Re: phpgarage mod

Post by Goucho »

get this now......
Error Detail

Warning

FIND FAILED: In file [templates/Glass2X/overall_footer.tpl] could not find:

copyright"><br />

MOD script line #867 :: FAQ :: Report

Error Detail

Warning

IN-LINE FIND FAILED: In file [templates/SoftBlue/overall_footer.tpl] could not find:

copyright"><br />

MOD script line #874 :: FAQ :: Report

Error Detail

Warning

FIND FAILED: In file [templates/AdInfinitum/overall_header.tpl] could not find:

mainmenu">&nbsp;

MOD script line #885 :: FAQ :: Report

Error Detail

Warning

FIND FAILED: In file [templates/Glass2X/overall_header.tpl] could not find:

mainmenu">&nbsp;

MOD script line #885 :: FAQ :: Report

Error Detail

Warning

FIND FAILED: In file [templates/wow_alliance/overall_header.tpl] could not find:

mainmenu">&nbsp;

MOD script line #885 :: FAQ :: Report

Error Detail

Warning

IN-LINE FIND FAILED: In file [templates/SoftBlue/overall_header.tpl] could not find:

mainmenu">&nbsp;

MOD script line #894 :: FAQ :: Report

Error Detail

Warning

FIND FAILED: In file [templates/wow_alliance/profile_view_body.tpl] could not find:

{ICQ_IMG}
</tr>

MOD script line #903 :: FAQ :: Report
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: phpgarage mod

Post by Nightrider »

That's unfortunate. I'm going to need to see text links to all of these template files...

Image
Goucho
Posts: 86
Joined: Sun Aug 20, 2006 12:54 am

Re: phpgarage mod

Post by Goucho »

thanx m8

Code: Select all

www.awesome-forums.co.uk/dl/files.rar
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: phpgarage mod

Post by Nightrider »

Ok, try this:

OPEN
Install Garage.txt

FIND

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
copyright"><br />
#
#-----[ IN-LINE FIND ]------------------------------------------
#
copyright"><br />
#
#-----[ IN-LINE AFTER, ADD ]------------------------------------------
#
{PENDING_LINK}
REPLACE WITH

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
{ADMIN_LINK}
#
#-----[ IN-LINE FIND ]------------------------------------------
#
{ADMIN_LINK}
#
#-----[ IN-LINE BEFORE, ADD ]------------------------------------------
#
{PENDING_LINK}
FIND

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
mainmenu">&nbsp;
#
#-----[ IN-LINE FIND ]------------------------------------------
#
mainmenu">&nbsp;
#
#-----[ IN-LINE AFTER, ADD ]------------------------------------------
#
REPLACE WITH

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
<a href="{U_FAQ}
#
#-----[ IN-LINE FIND ]------------------------------------------
#
<a href="{U_FAQ}
#
#-----[ IN-LINE BEFORE, ADD ]------------------------------------------
#
FIND

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
{ICQ_IMG}
</tr>
REPLACE WITH

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
{L_ICQ_NUMBER}
#
#-----[ FIND ]------------------------------------------
#
</tr>
The double FIND in the last modification might look odd, but it is a neat trick that you can use to locate the correct location in the phpBB file when there is no other easy way to do this for all of your templates...

Save, upload, and try again using EM...

Image
Goucho
Posts: 86
Joined: Sun Aug 20, 2006 12:54 am

Re: phpgarage mod

Post by Goucho »

all installed no problems and used the install php in browser as instructed all went succsessful but now garage button doesnt work but the garage does when u type the url in. BIG problems tho when u try to view a post .............
General Error

Could not obtain post/user information.

DEBUG MODE

SQL Error : 1054 Unknown column 'p.poster_id' in 'on clause'

SELECT u.username, u.user_id, u.user_posts, u.user_from, u.user_website, u.user_email, u.user_icq, u.user_aim, u.user_yim, u.user_regdate, u.user_msnm, u.user_viewemail, u.user_rank, u.user_sig, u.user_sig_bbcode_uid, u.user_avatar, u.user_avatar_type, u.user_allowavatar, u.user_allowsmile, p.*, pt.post_text, pt.post_subject, pt.bbcode_uid, g.made_year, makes.make, models.model, g.id as garage_id FROM phpbb_posts p, phpbb_users u, phpbb_posts_text pt LEFT JOIN phpbb_garage AS g on g.member_id = p.poster_id and g.main_vehicle = 1 LEFT JOIN phpbb_garage_makes AS makes ON g.make_id = makes.id LEFT JOIN phpbb_garage_models AS models ON g.model_id = models.id WHERE p.topic_id = 25 AND pt.post_id = p.post_id AND u.user_id = p.poster_id ORDER BY p.post_time ASC LIMIT 0, 20

Line : 407
File : viewtopic.php
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: phpgarage mod

Post by Nightrider »

If this is preventing you from using your board, Restore your Backups for the Garage MOD until I can get a chance to figure this out. I think I have an idea why this is happening but I'm not quite sure how to correct the problem right off hand. I am heading out the door right now, so I won't be able to look at it until later...

Image
Goucho
Posts: 86
Joined: Sun Aug 20, 2006 12:54 am

Re: phpgarage mod

Post by Goucho »

All reverted to pre garage :)

Boy it looked ace m8 too........ we were able to add to it etc all worked ok except for the link.................. and the forum lol ;) Lets hope we can sort this one out :)
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: phpgarage mod

Post by Nightrider »

Ok, this is a tough call. I think this might correct the problem though...

OPEN
Install Garage.txt

FIND

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
	FROM " . POSTS_TABLE . " p, " . USERS_TABLE . " u, " . POSTS_TEXT_TABLE . " pt
#
#-----[ AFTER, ADD ]------------------------------------------
#
		LEFT JOIN " . GARAGE_TABLE ." AS g on g.member_id = p.poster_id and g.main_vehicle = 1
                LEFT JOIN " . GARAGE_MAKES_TABLE . " AS makes ON g.make_id = makes.id
                LEFT JOIN " . GARAGE_MODELS_TABLE . " AS models ON g.model_id = models.id
REPLACE WITH

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
	FROM " . POSTS_TABLE . " p, " . USERS_TABLE . " u, " . POSTS_TEXT_TABLE . " pt
#
#-----[ AFTER, ADD ]------------------------------------------
#
		 , " . GARAGE_TABLE . " g, " . GARAGE_MAKES_TABLE . " makes, " . GARAGE_MODELS_TABLE . " models 
#
#-----[ FIND ]------------------------------------------
#
WHERE
#
#-----[ AFTER, ADD ]------------------------------------------
#
		AND g.member_id=p.poster_id 
		AND g.main_vehicle=1 
		AND g.make_id=makes.id 
		AND g.model_id=models.id
Save, upload, and try again using EM...

Image
Locked