ultimate quiz mod

Wondering why that MOD you have won't install correctly? Let's take a look
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
Goucho
Posts: 86
Joined: Sun Aug 20, 2006 12:54 am

ultimate quiz mod

Post by Goucho »

i swear ill slow down m8 :)

Got these errors ..............

Warning

FIND FAILED: In file [templates/SoftBlue/overall_header.tpl] could not find:

<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_FAQ}" class="mainmenu"><img src="templates/SoftBlue/images/icon_mini_faq.gif" width="12" height="13" border="0" alt="{L_FAQ}" hspace="3" />{L_FAQ}</a>&nbsp; &nbsp;

MOD script line #238 :: FAQ :: Report

Error Detail

Warning

FIND FAILED: In file [templates/snowSilver/overall_header.tpl] could not find:

<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_FAQ}" class="mainmenu"><img src="templates/SoftBlue/images/icon_mini_faq.gif" width="12" height="13" border="0" alt="{L_FAQ}" hspace="3" />{L_FAQ}</a>&nbsp; &nbsp;

MOD script line #238 :: FAQ :: Report

Error Detail

Warning

FIND FAILED: In file [templates/chunkstyle/overall_header.tpl] could not find:

<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_FAQ}" class="mainmenu"><img src="templates/SoftBlue/images/icon_mini_faq.gif" width="12" height="13" border="0" alt="{L_FAQ}" hspace="3" />{L_FAQ}</a>&nbsp; &nbsp;

MOD script line #238 :: FAQ :: Report

Error Detail

Warning

FIND FAILED: In file [templates/BrinkOfInsanity/overall_header.tpl] could not find:

<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_FAQ}" class="mainmenu"><img src="templates/SoftBlue/images/icon_mini_faq.gif" width="12" height="13" border="0" alt="{L_FAQ}" hspace="3" />{L_FAQ}</a>&nbsp; &nbsp;

MOD script line #238 :: FAQ :: Report

Error Detail

Warning

FIND FAILED: In file [templates/Cobalt/overall_header.tpl] could not find:

<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_FAQ}" class="mainmenu"><img src="templates/SoftBlue/images/icon_mini_faq.gif" width="12" height="13" border="0" alt="{L_FAQ}" hspace="3" />{L_FAQ}</a>&nbsp; &nbsp;

MOD script line #238 :: FAQ :: Report

Error Detail

Warning

FIND FAILED: In file [templates/dvdfuture/overall_header.tpl] could not find:

<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_FAQ}" class="mainmenu"><img src="templates/SoftBlue/images/icon_mini_faq.gif" width="12" height="13" border="0" alt="{L_FAQ}" hspace="3" />{L_FAQ}</a>&nbsp; &nbsp;

MOD script line #238 :: FAQ :: Report

Error Detail

Warning

FIND FAILED: In file [templates/ezSerenity/overall_header.tpl] could not find:

<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_FAQ}" class="mainmenu"><img src="templates/SoftBlue/images/icon_mini_faq.gif" width="12" height="13" border="0" alt="{L_FAQ}" hspace="3" />{L_FAQ}</a>&nbsp; &nbsp;

MOD script line #238 :: FAQ :: Report

Error Detail

Warning

FIND FAILED: In file [templates/invertedNeonGlow/overall_header.tpl] could not find:

<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_FAQ}" class="mainmenu"><img src="templates/SoftBlue/images/icon_mini_faq.gif" width="12" height="13" border="0" alt="{L_FAQ}" hspace="3" />{L_FAQ}</a>&nbsp; &nbsp;

MOD script line #238 :: FAQ :: Report

Error Detail

Warning

FIND FAILED: In file [templates/Galaxian/overall_header.tpl] could not find:

<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_FAQ}" class="mainmenu"><img src="templates/SoftBlue/images/icon_mini_faq.gif" width="12" height="13" border="0" alt="{L_FAQ}" hspace="3" />{L_FAQ}</a>&nbsp; &nbsp;

MOD script line #238 :: FAQ :: Report

Error Detail

Warning

FIND FAILED: In file [templates/GetawayPurple/overall_header.tpl] could not find:

<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_FAQ}" class="mainmenu"><img src="templates/SoftBlue/images/icon_mini_faq.gif" width="12" height="13" border="0" alt="{L_FAQ}" hspace="3" />{L_FAQ}</a>&nbsp; &nbsp;

MOD script line #238 :: FAQ :: Report

Error Detail

Warning

FIND FAILED: In file [templates/wow_alliance/overall_header.tpl] could not find:

<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_FAQ}" class="mainmenu"><img src="templates/SoftBlue/images/icon_mini_faq.gif" width="12" height="13" border="0" alt="{L_FAQ}" hspace="3" />{L_FAQ}</a>&nbsp; &nbsp;

MOD script line #238 :: FAQ :: Report

Error Detail

Warning

FIND FAILED: In file [templates/purplePulse/overall_header.tpl] could not find:

<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_FAQ}" class="mainmenu"><img src="templates/SoftBlue/images/icon_mini_faq.gif" width="12" height="13" border="0" alt="{L_FAQ}" hspace="3" />{L_FAQ}</a>&nbsp; &nbsp;

MOD script line #238 :: FAQ :: Report

Error Detail

Warning

FIND FAILED: In file [templates/Solaris/overall_header.tpl] could not find:

<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_FAQ}" class="mainmenu"><img src="templates/SoftBlue/images/icon_mini_faq.gif" width="12" height="13" border="0" alt="{L_FAQ}" hspace="3" />{L_FAQ}</a>&nbsp; &nbsp;

MOD script line #238 :: FAQ :: Report

Error Detail

Warning

FIND FAILED: In file [templates/whatisreal/overall_header.tpl] could not find:

<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_FAQ}" class="mainmenu"><img src="templates/SoftBlue/images/icon_mini_faq.gif" width="12" height="13" border="0" alt="{L_FAQ}" hspace="3" />{L_FAQ}</a>&nbsp; &nbsp;

MOD script line #238 :: FAQ :: Report


Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: ultimate quiz mod

Post by Nightrider »

Ok, do this:

OPEN
UQM_Installation.mod.txt

FIND

Code: Select all

# 
#-----[ FIND ]------------------------------------------ 
#
<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_FAQ}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_faq.gif" width="12" height="13" border="0" alt="{L_FAQ}" hspace="3" />{L_FAQ}</a>&nbsp; &nbsp;
REPLACE WITH

Code: Select all

# 
#-----[ FIND ]------------------------------------------ 
#
{U_FAQ}
Since you have many different templates, it is possible that the added menu option may not be installed correctly into some since the code varies widely from template to template. So you may be forced to correct some of the code in your overall_header.tpl files after this MOD is installed...

Save, upload, and try again using EM...

Image

Goucho
Posts: 86
Joined: Sun Aug 20, 2006 12:54 am

Re: ultimate quiz mod

Post by Goucho »

thanx installed no problem but in admin when i got to quiz this shows??
Could not get category data

DEBUG MODE

SQL Error : 1146 Table 'web29-a-forum-76.phpbb_quiz_categories' doesn't exist

SELECT * FROM phpbb_quiz_categories

Line : 338
File : admin_quiz.php

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: ultimate quiz mod

Post by Nightrider »

You really should read the Author's Notes, DIY INSTRUCTIONS section (if it exists), and/or readme.txt files before completing a MOD install. It could prevent things like this from ever happening...

You should have seen and read this in EM after completing the MOD install...

Code: Select all

#
#-----[ DIY INSTRUCTIONS ]------------------------------------------
#
Run quiz_install.php (found in the install/ folder of this package) to execute the SQL. Run quiz_install.php from the root folder of your forum.
Make file changes first, before running the file.
So once you upload the install folder to your forum root and then run the quiz_install.php file in your browser, it will update your database and the error will go away. Of course your board will be down the entire time that the install folder exists. So after completing the database update, you will want to delete the install folder...

NOTE: Be careful not to accidentally delete the includes folder by mistake. Things will definitely be a mess if you make that mistake...

The path to the quiz_install.php file may look similar to this in your browser:

Code: Select all

http://yourdomain.com/forum/install/quiz_install.php
Image

Goucho
Posts: 86
Joined: Sun Aug 20, 2006 12:54 am

Re: ultimate quiz mod

Post by Goucho »

installed thanx

Another ace conclusion thanx to nightrider :)

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: ultimate quiz mod

Post by Nightrider »

Great!!! ImageImageImage

That was a bit confusing about the install folder. Without reading the author's notes, it is an easy mistake to make since everyone is moving toward including an install folder for the db update file...

Image

Goucho
Posts: 86
Joined: Sun Aug 20, 2006 12:54 am

Re: ultimate quiz mod

Post by Goucho »

:(

This happens now when first you set it up in admin.........
Query 17 did not execute correctly

DEBUG MODE

SQL Error : 1054 Unknown column 'user_points' in 'field list'

UPDATE phpbb_config SET config_value = user_points WHERE config_name = 'Quiz_Cash_Currency'

Line : 84
File : admin_quiz.php


and second after a quiz is entered and you try to play.......
Could not get statistics data to check Quiz_Play_Once setting

DEBUG MODE

SQL Error : 1146 Table 'web29-a-forum-76.phpbb_quiz_statistics' doesn't exist

SELECT * FROM phpbb_quiz_statistics WHERE quiz_id = 1 AND user_id = 5

Line : 246
File : quiz.php


any ideas :(

It installed ok.

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: ultimate quiz mod

Post by Nightrider »

Try running this file from your forum root. You will have to strip the txt extension before it will "run" in your browser:

User_Points_DB_Update.php.txt

The path in your browser could look something like this after you have renamed the User_Points_DB_Update.php.txt file:

Code: Select all

http://yourdomain.com/forum/User_Points_DB_Update.php
Image

Goucho
Posts: 86
Joined: Sun Aug 20, 2006 12:54 am

Re: ultimate quiz mod

Post by Goucho »

Did that and got "done" but still same errors as above :(

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: ultimate quiz mod

Post by Nightrider »

Didn't you successfully run the quiz_install.php file from your browser? Were there any errors? The missing database entries came from the quiz_install.php database update file. So if you are seeing the errors that you posted, that implies that you never successfully ran the quiz_install.php file from your browser...

Image

Locked