Help for easymod

Having problems installing EM? Let's fix that
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
Demyx
Registered User
Posts: 20
Joined: Wed Mar 07, 2007 9:43 pm

Re: Help for easymod

Post by Demyx » Sat Mar 10, 2007 4:18 pm

FINALLY!!!! THANK YOU!!! IT WORKS NOW
so this whole time it was because i had it Mods and Easymod?

Demyx
Registered User
Posts: 20
Joined: Wed Mar 07, 2007 9:43 pm

Re: Help for easymod

Post by Demyx » Sat Mar 10, 2007 4:22 pm

well now i have another problem, when i use localhost it gives me a error about that
(formatted for forum posting)
EM installer v0.3.0 wrote: EM status: New Install
phpBB version: 2.0.21
Working Dir: /www/5gbfree.com/d/e/m/demyx/htdocs/forum/admin/mods/easymod
Install Step: 2
Mode: debug

The Error wrote: No error.



Permissions: (including system errors)
read access :: OK
write access :: No
root path write :: OK
chmod access :: unattempted
unlink access :: unattempted
mkdir access :: unattempted
tmp path write :: No
FTP extension :: OK
Safe Mode :: ON
copy access :: OK


Additional System Information:

System: Linux www2.5gbfree.com 2.6.9-42.0.8.ELsmp #1 SMP Tue Jan 23 13:01:26 EST 2007 i686
Configure Command: './configure' '--enable-memory-limit' '--disable-debug' '--with-regex=php' '--disable-rpath' '--disable-static' '--with-pic' '--with-layout=GNU' '--with-pear=/usr/share/php' '--enable-calendar' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--enable-track-vars' '--enable-trans-sid' '--enable-bcmath' '--with-bz2' '--enable-ctype' '--with-db4' '--with-iconv' '--enable-exif' '--enable-filepro' '--enable-ftp' '--with-gettext' '--enable-mbstring' '--with-pcre-regex=/usr' '--enable-shmop' '--enable-sockets' '--enable-wddx' '--disable-xml' '--with-expat-dir=/usr' '--with-xmlrpc' '--enable-yp' '--enable-dio' '--with-zlib' '--without-pgsql' '--with-kerberos=/usr' '--with-openssl=/usr' '--with-zip=/usr' '--enable-dbx' '--with-mime-magic=/usr/share/misc/file/magic.mime' '--with-exec-dir=/usr/lib/php4/libexec' '--prefix=/usr' '--with-apxs2=/usr/bin/apxs2' '--with-config-file-path=/etc/php4/apache2' '--with-jpeg-dir=/usr/lib' '--with-gd' '--with-curl' '--with-mysql'
PHP version: 5.1.6
register_globals: OFF
magic_quotes_gpc: ON
magic_quotes_runtime: OFF
allow_url_fopen: OFF
sockets_support: enabled


Recommendations:
write: buffer & ftp
move: automated FTP

Selected settings:
write: ftpb
move: ftpa
ftp dir: /forum
ftp host: localhost
ftp port: 21
ftp debug: false
ftp ext: fsock
ftp cache: false

CWD Listing:

Code: Select all

-rwxr-xr-x easymod.gif
drwxr-xr-x ..
drwxr-xr-x em_includes
drwxr-xr-x languages
-rwxr-xr-x easymod_install.php
drwxr-xr-x includes
-rwxr-xr-x easymod_display_functions.php
drwxr-xr-x .
drwxr-xr-x templates
Testing FTP access...
Trying to connect to localhost:21 ...
Error : Cannot connect to remote host "localhost:21"
Error : fsockopen() ()

FTP ERROR: connection to localhost:21 failed.
This error occurs frequently, particularly on hosts like Lycos. Back on step 1 you should try changing the FTP Server from "localhost" to whatever hostname you typically use when you FTP.

Demyx
Registered User
Posts: 20
Joined: Wed Mar 07, 2007 9:43 pm

Re: Help for easymod

Post by Demyx » Sat Mar 10, 2007 4:34 pm

i tried changing the server name to demyx.5gbfree.com
because thats what i use for ftp, but i still get a error :?

heres what i did next, i tried to change localhost to demyx.5gbfree.com (my website)
(formatted for forum posting)
EM installer v0.3.0 wrote: EM status: New Install
phpBB version: 2.0.21
Working Dir: /www/5gbfree.com/d/e/m/demyx/htdocs/forum/admin/mods/easymod
Install Step: 2
Mode: debug

The Error wrote: No error.



Permissions: (including system errors)
read access :: OK
write access :: No
root path write :: OK
chmod access :: unattempted
unlink access :: unattempted
mkdir access :: unattempted
tmp path write :: No
FTP extension :: OK
Safe Mode :: ON
copy access :: OK


Additional System Information:

System: Linux www2.5gbfree.com 2.6.9-42.0.8.ELsmp #1 SMP Tue Jan 23 13:01:26 EST 2007 i686
Configure Command: './configure' '--enable-memory-limit' '--disable-debug' '--with-regex=php' '--disable-rpath' '--disable-static' '--with-pic' '--with-layout=GNU' '--with-pear=/usr/share/php' '--enable-calendar' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--enable-track-vars' '--enable-trans-sid' '--enable-bcmath' '--with-bz2' '--enable-ctype' '--with-db4' '--with-iconv' '--enable-exif' '--enable-filepro' '--enable-ftp' '--with-gettext' '--enable-mbstring' '--with-pcre-regex=/usr' '--enable-shmop' '--enable-sockets' '--enable-wddx' '--disable-xml' '--with-expat-dir=/usr' '--with-xmlrpc' '--enable-yp' '--enable-dio' '--with-zlib' '--without-pgsql' '--with-kerberos=/usr' '--with-openssl=/usr' '--with-zip=/usr' '--enable-dbx' '--with-mime-magic=/usr/share/misc/file/magic.mime' '--with-exec-dir=/usr/lib/php4/libexec' '--prefix=/usr' '--with-apxs2=/usr/bin/apxs2' '--with-config-file-path=/etc/php4/apache2' '--with-jpeg-dir=/usr/lib' '--with-gd' '--with-curl' '--with-mysql'
PHP version: 5.1.6
register_globals: OFF
magic_quotes_gpc: ON
magic_quotes_runtime: OFF
allow_url_fopen: OFF
sockets_support: enabled


Recommendations:
write: buffer & ftp
move: automated FTP

Selected settings:
write: ftpb
move: ftpa
ftp dir: /forum
ftp host: demyx.5gbfree.com
ftp port: 21
ftp debug: false
ftp ext: fsock
ftp cache: false

CWD Listing:

Code: Select all

-rwxr-xr-x easymod.gif
drwxr-xr-x ..
drwxr-xr-x em_includes
drwxr-xr-x languages
-rwxr-xr-x easymod_install.php
drwxr-xr-x includes
-rwxr-xr-x easymod_display_functions.php
drwxr-xr-x .
drwxr-xr-x templates
Testing FTP access...
Trying to connect to demyx.5gbfree.com:21 ...
Error : Cannot connect to remote host "demyx.5gbfree.com:21"
Error : fsockopen() ()

FTP ERROR: connection to demyx.5gbfree.com:21 failed.
This error occurs frequently when the port number is incorrect. Back on step 1 you should try changing the FTP Port from 21 to whatever port you typically use when you FTP.

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Help for easymod

Post by Nightrider » Sat Mar 10, 2007 7:10 pm

Did you set your file permissions to 755 or is this a requirement by your host? If your host requires that your file permissions be set to 755, you will need to install a modified version of EM to work on your site. Let me know if you need it. If you are unsure what your host allows/requires and if you have already modified all the file permissions to 755, simply upload a file and check it's file permissions. The server software will correctly set the file permissions for you...

Rescan Option

Ok, do you see a rescan option at the bottom of this page displaying this latest error? If so, click on it. Hopefully on the next page, you will be given the Automcatic Detection option. If so, go with it...

Image

Image

Demyx
Registered User
Posts: 20
Joined: Wed Mar 07, 2007 9:43 pm

Re: Help for easymod

Post by Demyx » Sun Mar 11, 2007 12:38 am

Code: Select all


This is the worst case scenario. EasyMOD does not have permission to either create new files or to replace the old files with the new ones. There are several things you can do:

   1. If you have FTP access, then use the FTP option.
   2. Your server has "safe mode" enabled which means EasyMOD cannot automaticly replace your phpBB files. You might consider using chmod or chown to allow access.
   3. You might consider using chmod to allow access. However, this is not advised in a shared server environment.
   4. Otherwise you will have to download the files and then manually move them into place.


Select One:
	I'll try using the FTP option. (requires FTP access)
	I have now modified my file permissions, try rescanning to see if EasyMOD has access.
	I will have to download the files and manually move them into place
	I'd like to select something else. (Advanced Mode)
uh i get this... and all my permissions ARE 755

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Help for easymod

Post by Nightrider » Sun Mar 11, 2007 1:00 am

Ok, if your host requires that your file permissions be set to 755, then you will have to install this modified version of EM before it will work on your site...

Awardspace Instructions w/Download

You can download this EM version that I have modified to work on Awardspace sites. The file can be found in the downloads/phpBB/EasyMod section at the top of the page. Make sure that all uploaded file permissions are set to 755:

easymod_awardspace.zip

Here are the instructions for modifying your EM installation files if you choose to do it yourself rather than use the modified EM version that I supplied above:

Awardspace Modifications

Your board requires script file permissions to be set to 755 instead of 644 like most other boards. So even if EM installs correctly, the EM file permissions would be set to 644...

Unfortunately for sites like your's, EM sets the file permissions to 644 when it modifies them. So go into the following files to set all matches of 0644 to 0755 before you install EM:
  1. easymod/em_includes/em_modio.php
  2. easymod/em_includes/em_ftp.php
Also, modify the check_file_scope function in your easymod/includes/admin_easymod.php.txt file by copying and pasting the code:

OPEN
easymod/includes/admin_easymod.php.txt

FIND

Code: Select all

if( !@file_exists(phpbb_realpath($filename)) || !strstr(phpbb_realpath($filename), phpbb_realpath($expected_scope)) )
REPLACE WITH

Code: Select all

//if( !@file_exists(phpbb_realpath($filename)) || !strstr(phpbb_realpath($filename), phpbb_realpath($expected_scope)) )
	if( !@file_exists(phpbb_realpath($filename)) )
The check_file_scope function should now look like this:

Code: Select all

function check_file_scope($filename, $expected_scope, $simply_die = false)
{
	global $db, $lang;

	// make sure a file is located somewhere inside the specified directory
	//if( !@file_exists(phpbb_realpath($filename)) || !strstr(phpbb_realpath($filename), phpbb_realpath($expected_scope)) )
	if( !@file_exists(phpbb_realpath($filename)) )
	{
		$message = sprintf($lang['EM_modio_open_read'], $filename);
		if( $simply_die )
		{
			$db->sql_close();
			die($message);
		}
		message_die(GENERAL_ERROR, $message);
	}
}
Save all the modified files and upload them to their proper sub-folders in the admin/mods/easymod folder. Then go ahead and try the EM install again...

Image

Demyx
Registered User
Posts: 20
Joined: Wed Mar 07, 2007 9:43 pm

Re: Help for easymod

Post by Demyx » Sun Mar 11, 2007 1:06 am

wait how do i get out of safemode

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Help for easymod

Post by Nightrider » Sun Mar 11, 2007 1:16 am

On a few sites, you can turn it on and off in your Host CPanel. But for the majority of sites, you have to get your host to turn it off for you. Some will, some won't. Hopefully your host is one of the good ones...

Image

Demyx
Registered User
Posts: 20
Joined: Wed Mar 07, 2007 9:43 pm

Re: Help for easymod

Post by Demyx » Sun Mar 11, 2007 1:21 am

well... i used the awardspace and still the same thing, it gives me that worst case scenerio

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Help for easymod

Post by Nightrider » Sun Mar 11, 2007 1:47 am

Contact your host and see if you can convince them to turn Safe Mode off. Hopefully they will be happy to help you...

Image

Locked