it can't find [../admin/em_includes/em_functions.php]

Having problems installing EM? Let's fix that
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
NoDeity
Registered User
Posts: 22
Joined: Wed Sep 22, 2004 7:16 pm

it can't find [../admin/em_includes/em_functions.php]

Post by NoDeity »

Hi. I've had previous versions of easymod working okay. However, when installing 0.3.0 today, I had this warning:

Storing config table entries:
Warning: crypt_ftp_pass(../../../admin/em_includes/em_cipher.php): failed to open stream: Permission denied in /home/grave/public_html/forum/admin/mods/easymod/em_includes/em_functions.php on line 59

When I try to access easymod from my board's admin panel, I get this:

Critical Error: could not find [../admin/em_includes/em_functions.php]. Aborting.

I deleted the old easymod directory before upgrading. I ran the install file as instructed and, except for that warning at the very end, it seemed to go well. When I encountered that problem, I deleted my easymod directory again and resinstalled again. Same problem.

Suggestions?
markus_petrux
Registered User
Posts: 376
Joined: Fri Jun 18, 2004 10:58 pm
Location: Girona, Catalunya (Spain)
Contact:

Re: it can't find [../admin/em_includes/em_functions.php]

Post by markus_petrux »

Maybe EM was not able to override the files in admin/em_includes and there was even no error reported during the installation process, or it was but it was not noticed.

Try copying the files in mods/easymod/em_includes to admin/em_includes yourself and see what happens.
NoDeity
Registered User
Posts: 22
Joined: Wed Sep 22, 2004 7:16 pm

Re: it can't find [../admin/em_includes/em_functions.php]

Post by NoDeity »

Thanks for the reply. It was a good idea but it didn't work. I'm still getting the same error mesage.

When I tried your idea, I deleted the old files in /em_includes/ to make sure that I really did have the new ones in there. The file em_functions.php from the 0.3.0 release is definitely in .../admin/em_lincludes/ so why is it not being found? Is it somehow being looked for somewhere else?
NoDeity
Registered User
Posts: 22
Joined: Wed Sep 22, 2004 7:16 pm

Re: it can't find [../admin/em_includes/em_functions.php]

Post by NoDeity »

I re-installed again and, this time, there were no errors and no warnings. And I can now access EM through my admin panel. Before re-installing this time, I double-checked to make sure absolutely all phpbb files were chmod 755 -- it turned out that some weren't. So, that must have been the problem.

Is it safe to leave all my phpbb files at chmod 755? (I put my config.php file back to 644 already.)
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: it can't find [../admin/em_includes/em_functions.php]

Post by Nightrider »

Your file permissions should be set to 644 unless otherwise specified. Your folder permissions should set to 755...

Image
NoDeity
Registered User
Posts: 22
Joined: Wed Sep 22, 2004 7:16 pm

Re: it can't find [../admin/em_includes/em_functions.php]

Post by NoDeity »

Thanks. That's something that wasn't clear to me before. :)
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: it can't find [../admin/em_includes/em_functions.php]

Post by Nightrider »

I hope the install went smoothly for you...

Image
NoDeity
Registered User
Posts: 22
Joined: Wed Sep 22, 2004 7:16 pm

Re: it can't find [../admin/em_includes/em_functions.php]

Post by NoDeity »

Yes, all seems to be well now.
Locked