Instalation Problem

Having problems installing EM? Let's fix that
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
Javier830
Registered User
Posts: 2
Joined: Wed Jul 21, 2004 2:47 am

Instalation Problem

Post by Javier830 »

I am sorry to post instalation errors here. But the forum did not let me post in the instalation topic. Anyways while installing it gave me the following error.

[code]Error :: Table 'test.forums_easymod' doesn't exist

SQL :: INSERT INTO forums_easymod ( mod_title, mod_file, mod_version, mod_author_handle, mod_author_email, mod_author_name, mod_author_url, mod_description, mod_process_date, mod_phpBB_version, mod_processed_themes, mod_processed_langs, mod_files_edited, mod_tables_added, mod_tables_altered, mod_rows_inserted) VALUES ( 'EasyMOD', 'easymod/easymod_install.php', '0.0.10a', 'Nuttzy', 'pktoolkit@blizzhackers.com', 'n/a', 'http://www.blizzhackers.com', 'EasyMOD automatically perfoms in seconds which previously required the tedious task of manually editing files.', 1090378447, '2.0.10', 'subSilver', 'english', 0, 1, 0, 1)[/code]

Then this at the debug

[code](formatted for forum posting)

[quote="EM installer v0.0.10a"]
[b]phpBB version:[/b] 2.0.10
[b]Working Dir:[/b] C:\Program Files\Apache Group\Apache2\htdocs\forum\admin\mods\easymod
[b]Install Step:[/b] 7
[b]Mode:[/b]

[quote="The Error"]
[color=red]
Could not successfully update table. Something is wrong and install cannot complete.

[/color]
[/quote]

[b]Permissions:[/b] (including system errors)
[b]read access[/b] :: [b][color=green]OK[/color][/b]
[b]write access[/b] :: [b][color=green]OK[/color][/b]
[b]root path write[/b] :: [b][color=green]OK[/color][/b]
[b]chmod access[/b] :: [b][color=green]OK[/color][/b]
[b]unlink access[/b] :: [b][color=green]OK[/color][/b]
[b]mkdir access[/b] :: [b][color=green]OK[/color][/b]
[b]tmp path write[/b] :: [b][color=green]OK[/color][/b]
[b]FTP extension[/b] :: [b][color=green]OK[/color][/b]
[b]copy access[/b] :: [b][color=green]OK[/color][/b]



[b]Recommendations:[/b]
[b]write:[/b] server
[b]move:[/b] copy

[b]Selected settings:[/b]
[b]write:[/b] server
[b]move:[/b] copy
[b]ftp dir:[/b]

[b]CWD Listing:[/b]
[code]
drwxrwxrwx .
drwxrwxrwx ..
−rw−rw−rw− admin_easymod_functions.php
drwxrwxrwx backups
−rw−rw−rw− easymod.gif
−rw−rw−rw− easymod_install.php
drwxrwxrwx includes
−rw−rw−rw− lang_easymod.php
−rwxrwxrwx post_process.bat
−rw−rw−rw− post_process.sh
drwxrwxrwx processed [/code]

Not testing FTP since it is not being used.

Can anybody tell me what did i do wrong? Thanks
User avatar
GPHemsley
Registered User
Posts: 1617
Joined: Fri Apr 18, 2003 4:01 am
Location: Long Beach, NY
Contact:

Re: Instalation Problem

Post by GPHemsley »

8O 8O 8O

I think you might be trying to install an old version.... The latest is 0.0.11a2, and a new one is on the way!

8O 8O 8O
User avatar
GPHemsley
Registered User
Posts: 1617
Joined: Fri Apr 18, 2003 4:01 am
Location: Long Beach, NY
Contact:

Re: Instalation Problem

Post by GPHemsley »

Also make sure that your forum works (i.e. that your database information is correct) before trying to install EasyMOD. 8)
Javier830
Registered User
Posts: 2
Joined: Wed Jul 21, 2004 2:47 am

Re: Instalation Problem

Post by Javier830 »

it gave me the error but it still installed, lets say the new version comes out, can i just update it or do i need to uninstall?
User avatar
A_Jelly_Doughnut
Registered User
Posts: 1780
Joined: Wed Jun 04, 2003 4:23 pm

Re: Instalation Problem

Post by A_Jelly_Doughnut »

You'll Just update it.
A_Jelly_Doughnut
Dranore
Registered User
Posts: 1
Joined: Wed Jul 28, 2004 9:50 pm

Re: Instalation Problem

Post by Dranore »

I can't post a new topic... and this error is very similar. Any help would be appreciated. Thanks in advanced.

[quote="EM installer v0.0.11a"]
[b]phpBB version:[/b] 2.0.10
[b]Working Dir:[/b] D:\InetPub\existence2web\www\forum\admin\mods\easymod
[b]Install Step:[/b] 7
[b]Mode:[/b]

[quote="The Error"]
[color=red]

Could not successfully update table. Something is wrong and install cannot complete.
[/color]
[/quote]

[b]Permissions:[/b] (including system errors)
[b]read access[/b] :: [b][color=green]OK[/color][/b]
[b]write access[/b] :: [b][color=green]OK[/color][/b]
[b]root path write[/b] :: [b][color=green]OK[/color][/b]
[b]chmod access[/b] :: [b][color=green]OK[/color][/b]
[b]unlink access[/b] :: [b][color=green]OK[/color][/b]
[b]mkdir access[/b] :: [b][color=green]OK[/color][/b]
[b]tmp path write[/b] :: [b][color=green]OK[/color][/b]
[b]FTP extension[/b] :: [b][color=green]OK[/color][/b]
[b]copy access[/b] :: [b][color=green]OK[/color][/b]



[b]Recommendations:[/b]
[b]write:[/b] server
[b]move:[/b] copy

[b]Selected settings:[/b]
[b]write:[/b] ftpb
[b]move:[/b] ftpa
[b]ftp dir:[/b] /existence2web/www/forum/
[b]ftp debug:[/b] false
[b]ftp ext:[/b] fsock

[b]CWD Listing:[/b]
[code]
drwxrwxrwx .
drwxrwxrwx ..
drwxrwxrwx backups
−rw−rw−rw− easymod.gif
−rw−rw−rw− easymod_install.php
drwxrwxrwx em_includes
drwxrwxrwx includes
−rw−rw−rw− lang_easymod.php
−rwxrwxrwx post_process.bat
−rw−rw−rw− post_process.sh
drwxrwxrwx processed
[/code]
Testing FTP access...
1) Logged in successfully
2) CD to EasyMOD path successfully
3) wrote to phpBB root successfully

[b]FTP access test[/b] :: [b][color=green]successful[/color][/b]
[/quote]
cryptoknight
Registered User
Posts: 3
Joined: Thu Jul 29, 2004 3:02 pm

Re: Instalation Problem

Post by cryptoknight »

Yah it won't let me post a new topic... so here's my problem...

[quote="EM installer v0.0.11a"]
[b]phpBB version:[/b] 2.0.6
[b]Working Dir:[/b] /home/crypto/public_html/msgboard/admin/mods/easymod
[b]Install Step:[/b] 3
[b]Mode:[/b]

[quote="The Error"]
[color=red]Critical Error

Function Trace: open_files[3]->modio_open[1]

Could not open [language/lang_english/lang_admin.php] for reading.[/color]
[/quote]

[b]Permissions:[/b] (including system errors)
[b]read access[/b] :: [b][color=green]OK[/color][/b]
[b]write access[/b] :: failed
[b]root path write[/b] :: failed
[b]chmod access[/b] :: unattempted
[b]unlink access[/b] :: unattempted
[b]mkdir access[/b] :: unattempted
[b]tmp path write[/b] :: [b][color=green]OK[/color][/b]
[b]FTP extension[/b] :: [b][color=green]OK[/color][/b]
[b]copy access[/b] :: failed



[b]Recommendations:[/b]
[b]write:[/b] buffer & ftp
[b]move:[/b] automated FTP

[b]Selected settings:[/b]
[b]write:[/b] ftpb
[b]move:[/b] ftpa
[b]ftp dir:[/b] /public_html/msgboard
[b]ftp debug:[/b] false
[b]ftp ext:[/b] fsock

[b]CWD Listing:[/b]
[code]
drwxr−xr−x .
drwxr−xr−x ..
drwxr−xr−x em_includes
drwxr−xr−x includes
−rwxr−−r−− easymod.gif
−rwxr−−r−− easymod_install.php
−rwxr−−r−− lang_easymod.php
drwxr−xr−x processed
drwxr−xr−x backups
[/code]

Testing FTP access...
1) Logged in successfully
2) CD to EasyMOD path successfully
3) wrote to phpBB root successfully

[b]FTP access test[/b] :: [b][color=green]successful[/color][/b]
[/quote]
cryptoknight
Registered User
Posts: 3
Joined: Thu Jul 29, 2004 3:02 pm

Re: Instalation Problem

Post by cryptoknight »

aaah nevermind... found my problem.

The install instructions say to go 744 for the chmod permissions... when 766 is what you need to make it all work properly.
fongchun
Registered User
Posts: 2
Joined: Thu Jul 29, 2004 6:46 pm

Re: Instalation Problem

Post by fongchun »

Step 2 (of 5): EasyMOD is now confirming your file access settings.

Testing selected write method
Testing FTP access...
Trying to connect to ftp.members.lycos.co.uk:21 ...
Error : Cannot connect to remote host "ftp.members.lycos.co.uk:21"
Error : fsockopen() ()

FTP ERROR: connection to ftp.members.lycos.co.uk failed.
The FTP Server you have specified could not be connected to. The following is recommended:

Have you tried the default setting of localhost? This should be tried first.
Did you correctly enter the hostname? Try reentering.
Are you sure you have FTP access to the phpBB2 files? Obviously this is a requirement.
Some servers have issues with the fsockopen method that EasyMOD attempts to use by default. If you have the PHP FTP extension loaded, then enable that option in step 1.



This is the problem I am getting, and I can't seem to find a way to solve it. I can connect to the FTP server easily using WS_FTP, but when trying to install it using the easymod_install.php it can't connect. Can anyone help me?
User avatar
A_Jelly_Doughnut
Registered User
Posts: 1780
Joined: Wed Jun 04, 2003 4:23 pm

Re: Instalation Problem

Post by A_Jelly_Doughnut »

Well, did you try "localhost" for the FTP server name?
A_Jelly_Doughnut
Locked