Prevent multiple inclusions of jQuery UI

Note: We are moving the topics of this forum and it will be deleted at some point

Publish your own request for comments/change or patches for the next version of phpBB. Discuss the contributions and proposals of others. Upcoming releases are 3.2/Rhea and 3.3.
User avatar
Darkness_demoN
Registered User
Posts: 89
Joined: Mon Jul 29, 2013 1:48 pm
Contact:

Re: Prevent multiple inclusions of jQuery UI

Post by Darkness_demoN »

What happend with this ?

User avatar
PayBas
Registered User
Posts: 305
Joined: Tue Jul 29, 2008 6:08 pm
Contact:

Re: Prevent multiple inclusions of jQuery UI

Post by PayBas »

I'll start working on a patch


User avatar
PayBas
Registered User
Posts: 305
Joined: Tue Jul 29, 2008 6:08 pm
Contact:

Re: Prevent multiple inclusions of jQuery UI

Post by PayBas »

jQuery UI 1.11.0 has just been released. http://blog.jqueryui.com/2014/06/jquery-ui-1-11-0/

We'll need an AMD loader first though. Perhaps https://github.com/hearsayit/HearsayRequireJSBundle

User avatar
VSE
Extension Customisations
Extension Customisations
Posts: 673
Joined: Mon Mar 08, 2010 9:18 am

Re: Prevent multiple inclusions of jQuery UI

Post by VSE »

PayBas wrote:jQuery UI 1.11.0 has just been released. http://blog.jqueryui.com/2014/06/jquery-ui-1-11-0/

We'll need an AMD loader first though. Perhaps https://github.com/hearsayit/HearsayRequireJSBundle
Great. Now jQuery UI can be added in the optimal way :)
Has an irascible disposition.

User avatar
callumacrae
Former Team Member
Posts: 1046
Joined: Tue Apr 27, 2010 9:37 am
Location: England
Contact:

Re: Prevent multiple inclusions of jQuery UI

Post by callumacrae »

PayBas wrote:jQuery UI 1.11.0 has just been released. http://blog.jqueryui.com/2014/06/jquery-ui-1-11-0/

We'll need an AMD loader first though. Perhaps https://github.com/hearsayit/HearsayRequireJSBundle
Project seems to be dead: https://github.com/hearsayit/HearsayReq ... le/pull/74

Not sure what the problem with just using RequireJS is.
Made by developers, for developers!
My blog

User avatar
VSE
Extension Customisations
Extension Customisations
Posts: 673
Joined: Mon Mar 08, 2010 9:18 am

Re: Prevent multiple inclusions of jQuery UI

Post by VSE »

yeah, we should just use RequireJS to keep it simple
http://learn.jquery.com/jquery-ui/environments/amd/
Has an irascible disposition.

User avatar
callumacrae
Former Team Member
Posts: 1046
Joined: Tue Apr 27, 2010 9:37 am
Location: England
Contact:

Re: Prevent multiple inclusions of jQuery UI

Post by callumacrae »

I'll make an RFC.
Made by developers, for developers!
My blog

Post Reply