Search found 963 matches

by brunoais
Sun May 01, 2016 4:56 pm
Forum: [3.x] Tickets Discussion
Topic: PHPBB3-10418 - WYSIWYG Editor/Rich Text Editor
Replies: 460
Views: 308046

Re: PHPBB3-10418 - WYSIWYG Editor/Rich Text Editor

I'm the one that gave most implementation code to phpBB's WYSIWYG editor project. @DavidIQ . I can tell you. My implementation works with all BBCode I was able to put my hands on, both custom and included. The only BBCode I'm completely unable to cope with, which is also what lead me to enter in thi...
by brunoais
Fri Aug 28, 2015 5:41 pm
Forum: [3.x][Archive] RFCs
Topic: [RFC] Topic Title Prefixes / Subject Prefixes
Replies: 37
Views: 47846

Re: [RFC] Topic Title Prefixes / Subject Prefixes

There's an extension, ATM.
Let's see how popular it is first.
by brunoais
Thu Aug 27, 2015 4:21 pm
Forum: [3.x] Discussion
Topic: Smiley Management
Replies: 9
Views: 8838

Re: Smiley Management

What MIGHT be useful is to "float" the posting area so that if there is a long list of smileys, a problem caused by the administrator themselves, the posting box along with the buttons moves down when the user scrolls down, docking that section to the top of the screen. I disagree. In my opinion, t...
by brunoais
Thu Aug 27, 2015 10:40 am
Forum: [3.x] Discussion
Topic: Smiley Management
Replies: 9
Views: 8838

Re: Smiley Management

Even when scrolling I don't get what the image is supposed to represent...
by brunoais
Mon Aug 24, 2015 7:51 pm
Forum: [3.x] Discussion
Topic: PHP requirement
Replies: 46
Views: 80569

Re: PHP requirement

My suggestion for a trade off would probably be something like this: Support the PHP version not EOL on release of final, unless a dependency requires a larger version. Seems good enough for me. @Nicofuma, what do you think? That would be 5.5 for phpBB 3.2. I thought it was 5.4 O_O. Did I misread? ...
by brunoais
Mon Aug 24, 2015 5:38 pm
Forum: [3.x] Discussion
Topic: PHP requirement
Replies: 46
Views: 80569

Re: PHP requirement

bantu wrote:
Mon Aug 24, 2015 12:59 pm
My suggestion for a trade off would probably be something like this: Support the PHP version not EOL on release of final, unless a dependency requires a larger version.
Seems good enough for me.
@Nicofuma, what do you think?
by brunoais
Sun Aug 23, 2015 9:17 pm
Forum: [3.x] Discussion
Topic: PHP requirement
Replies: 46
Views: 80569

Re: PHP requirement

I think that announcing phpBB 5.2 requiring php 5.5 now is too late. I believe you should warn with much more time in advance.
However, announcing phpBB 5.3 requiring php 5.5 seems fine to me. We might even require php 7 if it comes out this year...
by brunoais
Sun Jul 26, 2015 12:52 pm
Forum: [3.x] Discussion
Topic: Proposal: new JS functionality to add for extensions
Replies: 17
Views: 17423

Re: Proposal: new JS functionality to add for extensions

Personally, I don't mind as long as it shouldn't be something to forcefully being relied on when it could have been done differently.
by brunoais
Sat Jul 25, 2015 5:59 pm
Forum: [3.x] Discussion
Topic: Proposal: new JS functionality to add for extensions
Replies: 17
Views: 17423

Re: Proposal: new JS functionality to add for extensions

Yep you are right. The fact that the unit is the file doesn't help at all. It an easily cause extensions to start fighting eachother... Way more than if just using the events. My main point is that extensions can also remove complete stuff altogether, not just add. Other than that... yeah. It still ...
by brunoais
Sat Jul 25, 2015 3:14 pm
Forum: [3.x] Discussion
Topic: Proposal: new JS functionality to add for extensions
Replies: 17
Views: 17423

Re: Proposal: new JS functionality to add for extensions

I think you got a wrong idea.
At the extension points, it's true, you may only add HTML, js, etc...
BUT!
You may also replace the HTML files completely in your extension. The problem there, though... The unit is the file...