Search found 588 matches

by 3Di
Wed Jan 01, 2020 11:00 pm
Forum: [3.x] Discussion
Topic: phpBB 3.3.0-RC1 released
Replies: 33
Views: 8230

Re: phpBB 3.3.0-RC1 released

david63 wrote:
Fri Dec 27, 2019 10:01 am
Just noticed that 3.3 now has a tables.yml by default - that makes all my extensions compatible (I have been injecting tables for a while now) - not sure why some tables had to be renamed though!!
tables.yml is identical to version 3.2.8.
by 3Di
Thu Dec 26, 2019 9:06 pm
Forum: [3.x] Discussion
Topic: phpBB 3.3.0-RC1 released
Replies: 33
Views: 8230

Re: phpBB 3.3.0-RC1 released

If there is an error in the ext.php, this extension can not be installed in 3.3, you will not get an error message. You're right, I tested with an extension ready for 3.3 and I put a wrong square bracket there on purpose. I was able to see the debug error only with F12 (developer tools) 2019-12-26 ...
by 3Di
Thu Dec 26, 2019 8:33 pm
Forum: [3.x] Discussion
Topic: phpBB 3.2.9-RC1 released
Replies: 14
Views: 2836

Re: phpBB 3.2.9-RC1 released

by 3Di
Wed Dec 25, 2019 9:11 pm
Forum: [3.x] Discussion
Topic: phpBB 3.3.0-RC1 released
Replies: 33
Views: 8230

Re: phpBB 3.3.0-RC1 released

Kirk wrote:
Wed Dec 25, 2019 8:50 am
DavidIQ wrote:
Tue Dec 24, 2019 1:10 pm
What exactly is in your ext.php file?
Here is my ext.php:

Code: Select all

... SNIP ...
You are using custom messages in ext.php. The function is_enableable() changed in phpBB 3.3, see:

[3.3.0-b1] ext.php & custom reasons
by 3Di
Wed Dec 25, 2019 3:27 am
Forum: [3.x] Discussion
Topic: phpBB 3.3.0-RC1 released
Replies: 33
Views: 8230

Re: phpBB 3.3.0-RC1 released

[phpBB Debug] "Trying to access array offset on value of type null" in file /var/www/vhosts/supportforum.be/httpdocs/phpbb/install/module_base.php on line 134 That's already fixed in https://tracker.phpbb.com/browse/PHPBB3-16261 It doesn't harm the installation though. [phpBB Debug] "password_hash(...
by 3Di
Mon Dec 23, 2019 9:27 pm
Forum: [3.x] Discussion
Topic: phpBB 3.3.0-RC1 released
Replies: 33
Views: 8230

Re: phpBB 3.3.0-RC1 released

Hi In an extension I have e.g. in the ext.php a ] instead of a ) , the ext cannot be activated (no error message). Under 3.2.8 I get this error message: Parse error: syntax error, unexpected ']', expecting ',' or ')' You should enable debug, in 3.3.x has changed, see: https://phpbbstudio.com/viewto...
by 3Di
Mon Dec 23, 2019 9:12 pm
Forum: [3.x] Discussion
Topic: phpBB 3.3.0-RC1 released
Replies: 33
Views: 8230

Re: phpBB 3.3.0-RC1 released

You can use a local stack like this:

http://wampserver.aviatechno.net/?lang=en (for Windows)

Available PHP: from 5.3.28 to 7.4.1 ;)
by 3Di
Mon Dec 23, 2019 8:45 pm
Forum: [3.x] Discussion
Topic: phpBB 3.3.0-RC1 released
Replies: 33
Views: 8230

Re: phpBB 3.3.0-RC1 released

Let's help us determine any bugs by also using PHP 7.4.x ;)
by 3Di
Mon Dec 23, 2019 8:42 pm
Forum: [3.x] Discussion
Topic: Future support for Sphinx Search
Replies: 15
Views: 10843

Re: Future support for Sphinx Search

I created that PR based on trusting his report.
by 3Di
Fri Dec 20, 2019 4:24 pm
Forum: [3.x] Discussion
Topic: phpBB 3.3.0-b1 released
Replies: 47
Views: 29051

Re: phpBB 3.3.0-b1 released

Just as a reminder, 3.3.0-b2 has been released long ago


viewtopic.php?f=81&t=72291