Multiple attachment bug (v3.2.2)

Discuss requests for comments/changes posted in the Issue Tracker for the development of phpBB. Upcoming releases are 3.2/Rhea and 3.3.
Post Reply
yukayuka
Registered User
Posts: 1
Joined: Mon Jan 15, 2018 8:11 am

Multiple attachment bug (v3.2.2)

Post by yukayuka » Mon Jan 15, 2018 8:16 am

Hi. Multiple attachments not shown on post editing. Looks like little bug in posting_gen_attachment_entry function:

Code: Select all

		

		foreach ($attachment_data as $count => $attach_row)
		{
			$hidden = '';
			$attachrow_template_vars = array();
			$attach_row['real_filename'] = utf8_basename($attach_row['real_filename']);
Should be

Code: Select all

		$attachrow_template_vars = array();

		foreach ($attachment_data as $count => $attach_row)
		{
			$hidden = '';
			$attach_row['real_filename'] = utf8_basename($attach_row['real_filename']);

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 1776
Joined: Thu Mar 02, 2006 4:29 pm
Location: Earth
Contact:

Re: Multiple attachment bug (v3.2.2)

Post by DavidIQ » Mon Jan 15, 2018 5:21 pm

Hello,

Is this in the tracker? This forum is meant as a way to discuss tickets already in the tracker.
Image

User avatar
canonknipser
Registered User
Posts: 67
Joined: Mon Sep 19, 2011 4:42 am
Location: Germany

Re: Multiple attachment bug (v3.2.2)

Post by canonknipser » Tue Jan 16, 2018 5:25 am

Greetings
Frank
phpbb.de support team member - no support via PM or mail
English is not my native language
Extensions and scripts for phpBB

Post Reply