FTP ftp_put error

Having problems installing EM? Let's fix that
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
User avatar
Culprit
Registered User
Posts: 12
Joined: Wed Feb 07, 2007 6:50 pm

FTP ftp_put error

Post by Culprit » Wed Feb 07, 2007 7:36 pm

Hi, I have tried to install easymod with access over FTP.

1) With PHP FTP extensions:
I become this error

Code: Select all

Testing selected write method
Testing FTP access...
1) Logged in successfully
Current Working Directory: /
Directory listing: (1 files being listed)
[]
2) CD to EasyMOD path successfully

Warning: ftp_put() [function.ftp-put]: Failed to establish connection. in /www/phpbb2/admin/mods/easymod/em_includes/em_ftp.php on line 1103

Warning: ftp_put() [function.ftp-put]: Failed to establish connection. in /www/phpbb2/admin/mods/easymod/em_includes/em_ftp.php on line 1110

FTP ERROR: could not write to phpBB root
EasyMOD requires that your ... account have write access on all directories and files in the phpBB directory. Please confirm all files and directories are set to at least 744 access.
FTP ERROR: access right are irelevant, because when I try to test ftp_put in another folder with same files its successfull.
Otherwise is all sets to 755 or 777.

2) Without PHP FTP extension:
I become these error

Code: Select all

1) Logged in successfully
> PWD
257 "/"
Current Working Directory: 257 "/" 
> PASV
227 Entering Passive Mode (xxx,xxx,xxx,xxx,xxx)
> NLST
Trying to a.b.c.d:1820 ...
Error : Cannot open data connection to a.b.c.d:1820
Error : Connection timed out (110)
Error : Cannot connect to remote host
Error : NLST command failed
Directory listing: (1 files being listed)
[]
> CWD www/phpbb2/admin/mods/easymod
425 Failed to establish connection.
Error : CWD command failed
Any hint below does not have success.

Have someone some hint for me, how to install easymod with FTP access. Installing easymod with download and copy files is not prefered.

User avatar
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: FTP ftp_put error

Post by Nightrider » Wed Feb 07, 2007 7:51 pm

Rescan Option

Ok, do you see a rescan option at the bottom of this page? If so, click on it. Hopefully on the next page, you will be given the Automcatic Detection option. If so, go with it...

Image

If you don't get the Rescan and Automatic Detection option, we need to figure out why EM is struggling with Write access to your directories...

Image

User avatar
Culprit
Registered User
Posts: 12
Joined: Wed Feb 07, 2007 6:50 pm

Re: FTP ftp_put error

Post by Culprit » Wed Feb 07, 2007 7:55 pm

thnx for quick reply, I will try it witin one hour, and give feedback.

User avatar
Culprit
Registered User
Posts: 12
Joined: Wed Feb 07, 2007 6:50 pm

Re: FTP ftp_put error

Post by Culprit » Wed Feb 07, 2007 8:07 pm

I forgot to write it into first post, offcourse that I have tried "RESCAN" button
but I I become this error:

Code: Select all

COPY ERROR: You do not have copy access. Move method cannot be used.
EM installer v0.4.0 wrote: EM status: New Install
phpBB version: 2.0.22
Working Dir: /www/phpbb2/admin/mods/easymod
Install Step: 2
Mode: debug

The Error wrote: No error.



Permissions: (including system errors)

read access :: OK
write access :: OK
root path write :: No
chmod access :: OK
unlink access :: OK
mkdir access :: OK
tmp path write :: No
FTP extension :: OK
Safe Mode :: OFF
copy access :: OK


Additional System Information:

System: Linux xxxxx.xx 2.6.16-2-686 #1 Fri Aug 18 19:01:49 UTC 2006 i686
Configure Command: N/A
PHP version: 5.2.0-8
register_globals: ON
magic_quotes_gpc: ON
magic_quotes_runtime: OFF
allow_url_fopen: ON
sockets_support: enabled


Recommendations:
write: server
move: automated FTP

Selected settings:
write: server
move: copy
ftp dir: /
ftp host: localhost
ftp port: 21
ftp debug: false
ftp ext: fsock
ftp cache: false

CWD Listing:

Code: Select all

drwxrwxrwx . 
drwxrwxrwx .. 
-rwxrwxrwx easymod.gif 
-rwxrwxrwx easymod_display_functions.php 
-rwxrwxrwx easymod_install.php 
-rw-r--r-- modx_inside.png 
drwxrwxrwx em_includes 
drwxrwxrwx includes 
drwxrwxrwx languages 
drwxrwxrwx templates 

Not testing FTP since it is not being used.

Any another hint?

User avatar
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: FTP ftp_put error

Post by Nightrider » Wed Feb 07, 2007 8:12 pm

Why are all of your file and folder permissions set to 777? That is an extremely dangerous setting that invites hackers to your site. Most of your folder permissions should be set to 755...

If you are unsure what the file permissions were before you modified them, upload a file to your server and check it's permissions. That is what all the rest of your file permissions should be set to. On most servers, the file permissions should be set to 644. If that is not the case on your server, you will need to install a modified version of EM to work on your site...

CHMOD Permissions

Do you have the permissions of the folders set to 755 and the files set to 644? On most boards, the folder permissions must be set to 755 and the file permissions to 644. However on some, such as Awardspace and Lycos, the folder and file permissions MUST BE set to 755. Check some of your other non-EM file and folder permissions to determine what works on your site...

You can probably find instructions on how to do that at the site that provides your FTP application. I'm sure it varies from application to application...

I use SmartFTP. All you need to do is click on a folder or file in the right hand viewer and choose Properties/CHMOD or Alt+Enter

Image

Then you can either enter the value, like 755 or 644, or you can click on the read, write, execute options, which do the same thing...

Image

Image

User avatar
Culprit
Registered User
Posts: 12
Joined: Wed Feb 07, 2007 6:50 pm

Re: FTP ftp_put error

Post by Culprit » Wed Feb 07, 2007 9:36 pm

Offcourse, on first are allthere 755 and 644. I have tried to change only to allow to install.
Just now I have reverted all permission back to start values.

EM is using only pasiv mode? is any way to use active connection?

User avatar
Culprit
Registered User
Posts: 12
Joined: Wed Feb 07, 2007 6:50 pm

Re: FTP ftp_put error

Post by Culprit » Wed Feb 07, 2007 10:07 pm

After revert into original permisions
EM installer v0.3.0 wrote: EM status: New Install
phpBB version: 2.0.22
Working Dir: /www/phpbb2/admin/mods/easymod
Install Step: 3
Mode: debug

The Error wrote: No error.



Permissions: (including system errors)

read access :: OK
write access :: No
root path write :: No
chmod access :: unattempted
unlink access :: unattempted
mkdir access :: unattempted
tmp path write :: No
FTP extension :: OK
Safe Mode :: OFF
copy access :: No


Additional System Information:

System: Linux xxxx.xx 2.6.16-2-686 #1 Fri Aug 18 19:01:49 UTC 2006 i686
Configure Command: N/A
PHP version: 5.2.0-8
register_globals: ON
magic_quotes_gpc: ON
magic_quotes_runtime: OFF
allow_url_fopen: ON
sockets_support: enabled


Recommendations:
write: buffer & ftp
move: automated FTP

Selected settings:
write:
move:
ftp dir:
ftp host:
ftp port: 0
ftp debug: false
ftp ext:
ftp cache: false

CWD Listing:

Code: Select all

drwxr-xr-x . 
drwxr-xr-x .. 
-rw-r--r-- easymod.gif 
-rw-r--r-- easymod_display_functions.php 
-rw-r--r-- easymod_install.php 
drwxr-xr-x em_includes 
drwxr-xr-x includes 
drwxr-xr-x languages 
drwxr-xr-x templates 

Not testing FTP since it is not being used.

User avatar
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: FTP ftp_put error

Post by Nightrider » Thu Feb 08, 2007 1:32 am

There is no setting to change the mode that EM uses. Passive mode works on most servers, so it should do the same on your's too...

So have you re-attempted the EM install after changing all the permissions back? If so, are you seeing the same error message or something new???

Image

User avatar
Culprit
Registered User
Posts: 12
Joined: Wed Feb 07, 2007 6:50 pm

Re: FTP ftp_put error

Post by Culprit » Thu Feb 08, 2007 6:39 am

same error

User avatar
Culprit
Registered User
Posts: 12
Joined: Wed Feb 07, 2007 6:50 pm

Re: FTP ftp_put error

Post by Culprit » Thu Feb 08, 2007 8:45 am

I have tried to instal EM from my local machine to FTP access to remote machine.

Debug mode give me no error.
So than I go to install EM from local (XP) to FTP (UNIX). (I know that is incorrect install, but I would like to know where the problem is.)
Everything is OK, only 30s execution timeout.

So there should be some configuration problem on remote machine.

I hope so.

I will do these steps.
  1. Install phpbb2 on windows server
  2. Install EM - could I install 0.4.0?
  3. Prepare all mods on windows server and than copy it into FTP

Locked