Big Prob, Help Please!

Having problems installing EM? Let's fix that
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
Playa
Registered User
Posts: 9
Joined: Thu Apr 07, 2005 12:48 am

Big Prob, Help Please!

Post by Playa » Thu Apr 07, 2005 12:52 am

ok, everytime I try to install easy mod, I get past everything and set my pass for easymod and it comes up with this and stays there forever, doesnt do anything else.......? This is a screenshot. http://tinypic.com/view.html?pic=2lw5za" target="_blank Please help because I really need this......

Playa
Registered User
Posts: 9
Joined: Thu Apr 07, 2005 12:48 am

Re: Big Prob, Help Please!

Post by Playa » Thu Apr 07, 2005 4:47 pm

*bump*

User avatar
GPHemsley
Registered User
Posts: 1617
Joined: Fri Apr 18, 2003 4:01 am
Location: Long Beach, NY
Contact:

Re: Big Prob, Help Please!

Post by GPHemsley » Thu Apr 07, 2005 11:33 pm

Please go to the step before that and post the Expanded Debug Info from the link at the bottom of the page.

And please do not bump so close to your last post. We're not extremely fast workers around these parts.

Playa
Registered User
Posts: 9
Joined: Thu Apr 07, 2005 12:48 am

Re: Big Prob, Help Please!

Post by Playa » Fri Apr 08, 2005 3:26 am

Code: Select all

(formatted for forum posting)

[quote="EM installer v0.1.13"]
[b]phpBB version&#58[/b] 2.0.13
[b]Working Dir&#58[/b] C&#58\apache2triad\htdocs\LeetGraphix\admin\mods\easymod
[b]Install Step&#58[/b] 1
[b]Mode&#58[/b] debug

[quote="The Error"]
[color=green][b]No error.[/b][/color]
[/quote]

[b]Permissions&#58[/b] (including system errors)

read access  &#58&#58  [b][color=green]OK[/b] 
write access  &#58&#58  [b][color=green]OK[/b] 
root path write  &#58&#58  [b][color=green]OK[/b] 
chmod access  &#58&#58  [b]No[/b] 
unlink access  &#58&#58  [b]No[/b] 
mkdir access  &#58&#58  [b]No[/b] 
tmp path write  &#58&#58  [b][color=green]OK[/b] 
FTP extension  &#58&#58  [b][color=green]OK[/b] 
Safe Mode  &#58&#58  [b][color=green]OFF[/b] 
copy access  &#58&#58  [b]No[/b] 



[b]Recommendations&#58[/b]
[b]write&#58[/b] server
[b]move&#58[/b] automated FTP

[b]Selected settings&#58[/b]
[b]write&#58[/b] ftpb
[b]move&#58[/b] ftpa
[b]ftp dir&#58[/b] /
[b]ftp host&#58[/b] localhost
[b]ftp debug&#58[/b] false
[b]ftp ext&#58[/b] ext
[b]ftp cache&#58[/b] false

[b]CWD Listing&#58[/b]
[code]
drwxrwxrwx . 
drwxrwxrwx .. 
−rw−rw−rw− easymod.gif 
−rw−rw−rw− easymod_display_functions.php 
−rw−rw−rw− easymod_install.php 
drwxrwxrwx em_includes 
drwxrwxrwx includes 
drwxrwxrwx templates 
−rw−rw−rw− lang_easymod.php 
Testing FTP access...

FTP ERROR&#58 connection to localhost failed.
This error occurs frequently, particularly on hosts like Lycos. Back on step 1 you should try changing the FTP Server from 'localhost' to whatever hostname you typically use when you FTP.
[/quote]
[/code]

That's what it says and I see that it cannot connect to the localhost. What does it mean localhost?

Playa
Registered User
Posts: 9
Joined: Thu Apr 07, 2005 12:48 am

Re: Big Prob, Help Please!

Post by Playa » Fri Apr 08, 2005 3:33 am

I got that working, I put my ftp server address in there instead of local address but now i have another error when i click install. this is it.

Code: Select all

Critical Error

Function Trace&#58 open_files[3]->modio_open[2]->modio_mkdirs[1]->ftp_mkdir_struct[4]

FTP ERROR&#58 could not change directory to [../../../../../]
Current dir&#58 [/admin/mods/easymod/processed]
this is my debug info for that

Code: Select all

(formatted for forum posting)

[quote="EM installer v0.1.13"]
[b]phpBB version&#58[/b] 2.0.13
[b]Working Dir&#58[/b] C&#58\apache2triad\htdocs\LeetGraphix\admin\mods\easymod
[b]Install Step&#58[/b] 3
[b]Mode&#58[/b] 

[quote="The Error"]
[color=red]Critical Error

Function Trace&#58 open_files[3]->modio_open[2]->modio_mkdirs[1]->ftp_mkdir_struct[4]

FTP ERROR&#58 could not change directory to [../../../../../]
Current dir&#58 [/admin/mods/easymod/processed][/color]
[/quote]

[b]Permissions&#58[/b] (including system errors)

read access  &#58&#58  [b][color=green]OK[/b] 
write access  &#58&#58  [b][color=green]OK[/b] 
root path write  &#58&#58  [b][color=green]OK[/b] 
chmod access  &#58&#58  [b]No[/b] 
unlink access  &#58&#58  [b]No[/b] 
mkdir access  &#58&#58  [b]No[/b] 
tmp path write  &#58&#58  [b][color=green]OK[/b] 
FTP extension  &#58&#58  [b][color=green]OK[/b] 
Safe Mode  &#58&#58  [b][color=green]OFF[/b] 
copy access  &#58&#58  [b]No[/b] 



[b]Recommendations&#58[/b]
[b]write&#58[/b] server
[b]move&#58[/b] automated FTP

[b]Selected settings&#58[/b]
[b]write&#58[/b] ftpb
[b]move&#58[/b] ftpa
[b]ftp dir&#58[/b] /
[b]ftp host&#58[/b] 66.207.1.29
[b]ftp debug&#58[/b] false
[b]ftp ext&#58[/b] ext
[b]ftp cache&#58[/b] false

[b]CWD Listing&#58[/b]
[code]
drwxrwxrwx . 
drwxrwxrwx .. 
−rw−rw−rw− easymod.gif 
−rw−rw−rw− easymod_display_functions.php 
−rw−rw−rw− easymod_install.php 
drwxrwxrwx em_includes 
drwxrwxrwx includes 
drwxrwxrwx templates 
−rw−rw−rw− lang_easymod.php 
drwxrwxrwx processed 
Testing FTP access...
1) Logged in successfully
PWD&#58 /
Dir listing&#58 (25 files being listed)
[.//admin]
[.//cache]
[.//main]
[.//db]
[.//docs]
[.//images]
[.//includes]
[.//language]
[.//templates]
[.//common.php]
[.//config.php]
[.//extension.inc]
[.//faq.php]
[.//groupcp.php]
[.//index.php]
[.//login.php]
[.//memberlist.php]
[.//modcp.php]
[.//posting.php]
[.//privmsg.php]
[.//profile.php]
[.//search.php]
[.//viewforum.php]
[.//viewonline.php]
[.//viewtopic.php]
2) CD to EasyMOD path successfully
3) wrote to phpBB root successfully

FTP access test &#58&#58 successful
[/quote] [/code]

It also says this at the top of the page "Parsing: language/lang_english/lang_admin.php"

User avatar
GPHemsley
Registered User
Posts: 1617
Joined: Fri Apr 18, 2003 4:01 am
Location: Long Beach, NY
Contact:

Re: Big Prob, Help Please!

Post by GPHemsley » Sat Apr 09, 2005 1:02 am

Use "server" as your write method, leave the FTP path field blank, enable FTP debugging, and post your debug info if it doesn't work. Please do not use code tags to post the debug info.

Playa
Registered User
Posts: 9
Joined: Thu Apr 07, 2005 12:48 am

Re: Big Prob, Help Please!

Post by Playa » Sat Apr 09, 2005 2:40 am

ok, this is what i got, here's the screenshot http://tinypic.com/view.html?pic=2mxk6o" target="_blank

User avatar
GPHemsley
Registered User
Posts: 1617
Joined: Fri Apr 18, 2003 4:01 am
Location: Long Beach, NY
Contact:

Re: Big Prob, Help Please!

Post by GPHemsley » Sat Apr 09, 2005 9:18 am

Grr, alright.... Set it back to FTP and then follow the rest of my directions above.

Playa
Registered User
Posts: 9
Joined: Thu Apr 07, 2005 12:48 am

Re: Big Prob, Help Please!

Post by Playa » Sat Apr 09, 2005 5:53 pm

This is the screenshot of the prob http://tinypic.com/view.html?pic=2n3m8z" target="_blank

this is the debug info

(formatted for forum posting)
EM installer v0.1.13 wrote:
phpBB version:
2.0.13
Working Dir: C:\apache2triad\htdocs\LeetGraphix\admin\mods\easymod
Install Step: 3
Mode:
The Error wrote:
Critical Error

Function Trace: open_files[3]->modio_open[2]->modio_mkdirs[1]->ftp_mkdir_struct[4]

FTP ERROR: could not change directory to [../../../../../]
Current dir: [/admin/mods/easymod/processed]
Permissions: (including system errors)

read access :: OK
write access :: OK
root path write :: OK
chmod access :: No
unlink access :: No
mkdir access :: No
tmp path write :: OK
FTP extension :: OK
Safe Mode :: OFF
copy access :: No



Recommendations:
write: server
move: automated FTP

Selected settings:
write: ftpb
move: ftpa
ftp dir: /
ftp host: 66.207.1.29
ftp debug: true
ftp ext: ext
ftp cache: false

CWD Listing:

Code: Select all

drwxrwxrwx . 
drwxrwxrwx .. 
−rw−rw−rw− easymod.gif 
−rw−rw−rw− easymod_display_functions.php 
−rw−rw−rw− easymod_install.php 
drwxrwxrwx em_includes 
drwxrwxrwx includes 
drwxrwxrwx templates 
−rw−rw−rw− lang_easymod.php 
drwxrwxrwx processed 
Testing FTP access...
1) Logged in successfully
PWD: /
Dir listing: (25 files being listed)
[.//admin]
[.//cache]
[.//main]
[.//db]
[.//docs]
[.//images]
[.//includes]
[.//language]
[.//templates]
[.//common.php]
[.//config.php]
[.//extension.inc]
[.//faq.php]
[.//groupcp.php]
[.//index.php]
[.//login.php]
[.//memberlist.php]
[.//modcp.php]
[.//posting.php]
[.//privmsg.php]
[.//profile.php]
[.//search.php]
[.//viewforum.php]
[.//viewonline.php]
[.//viewtopic.php]
2) CD to EasyMOD path successfully
3) wrote to phpBB root successfully

FTP access test :: successful

User avatar
GPHemsley
Registered User
Posts: 1617
Joined: Fri Apr 18, 2003 4:01 am
Location: Long Beach, NY
Contact:

Re: Big Prob, Help Please!

Post by GPHemsley » Sun Apr 10, 2005 3:23 pm

Try leaving the FTP path field entirely empty, and see if that solves it. Otherwise, I'm not really sure what the problem is.

Locked