[possible solved] phpBB upgrade MOD - Errors on some files

Wondering why that MOD you have won't install correctly? Let's take a look
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
Arka
Registered User
Posts: 3
Joined: Fri Aug 13, 2004 4:59 pm

[possible solved] phpBB upgrade MOD - Errors on some files

Post by Arka » Fri Aug 13, 2004 5:48 pm

Hello,

I'm running phpBB 2.0.6
I just upgraded to EM 0.1.13 beta 5 minutes ago

I want to install the phpBB upgrade MOD 2.0.6 to 2.0.7a and so on till last version

I go on and do a preview on the modifications. Most of them open a window with
CRITICAL ERROR: Could not modify [%s]

Some of them are opening fine with the modifications inside.

I've looked at the files with error, it seems that the files which are giving this error are already modified. Means that EM can't find some strings to update because they are already updated...

Maybe I have already done some modifications from 2.0.6 to 2.0.7a a long time ago ?? But then I would have forgotten some files (because some of them still need to be modified) ?

It would be nice to have an error message more detailed in the preview ;)

Anyway I think I'm going to do this one by hand, then I'll try to run the next 2.0.7a to 2.0.8 MOD with EM :)

Thanks :)

Arka
Registered User
Posts: 3
Joined: Fri Aug 13, 2004 4:59 pm

Re: [phpBB upgrade MOD] Errors on some files

Post by Arka » Fri Aug 13, 2004 6:01 pm

Btw, what is the behaviour of EM with files that give errors on preview ?

Will it still modify the files that look correct on preview ? (could save time)

Thanks

[Edit : I tried to process the MOD anyway: EM stops on the first error, which here is detailed, it tells what it can't found, that's perfect.
Maybe there could be a global parsing telling which files can be updated and if we want to update them at our own risks, leaving the uncorrect ones aside. But then the MOD won't be completely installed, I know.
Or maybe an additionnal check telling that the file is already updated.
Just ideas... For now I'm going to check my files and update my phpbb manually] :)

Nuttzy99
Registered User
Posts: 927
Joined: Fri Aug 03, 2001 7:09 am
Contact:

Re: [phpBB upgrade MOD] Errors on some files

Post by Nuttzy99 » Fri Aug 13, 2004 6:28 pm

On my way out the door now. Will think about your problem. When I get back I'll tell you why I wouldn't allow a partial install ;)

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
My Other Site

Nuttzy99
Registered User
Posts: 927
Joined: Fri Aug 03, 2001 7:09 am
Contact:

Re: [phpBB upgrade MOD] Errors on some files

Post by Nuttzy99 » Sat Aug 14, 2004 3:39 am

Arka wrote:[Edit : I tried to process the MOD anyway: EM stops on the first error, which here is detailed, it tells what it can't found, that's perfect.
So, sounds like you got the problem solved?
Maybe there could be a global parsing telling which files can be updated and if we want to update them at our own risks, leaving the uncorrect ones aside.
[/quote] Nah, let's just say that EM caters to a "less sophisticated" audience. Meaning that there's a lot of dumbasses out there that won't read warnings, will continue with the install, break their boards, and then ask me or MOD Authors to bail them out. No thanks :P If a person is knowledgeable, like yourself, then you can probably make a few changes to get past the problem without having to bother anyone ;)

So, are we all set here?

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
My Other Site

Arka
Registered User
Posts: 3
Joined: Fri Aug 13, 2004 4:59 pm

Re: [possible solved] phpBB upgrade MOD - Errors on some fil

Post by Arka » Sat Aug 14, 2004 9:31 am

all set :)

( btw, on the preview windows for each file, is it possible to also have a detailed error message (in the next versions) ? )

Thanks

Nuttzy99
Registered User
Posts: 927
Joined: Fri Aug 03, 2001 7:09 am
Contact:

Re: [possible solved] phpBB upgrade MOD - Errors on some fil

Post by Nuttzy99 » Sat Aug 14, 2004 2:36 pm

Hrmmmm... I'll think about that one. Preview mode needs an overhaul anyway. I'll have to see why the error message is not printing.

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
My Other Site

Locked