Dependency Management: Composer

General discussion of development ideas and the approaches taken in the 3.x branch of phpBB. The next feature release of phpBB 3 will be 3.2/Rhea followed by 3.3.
Forum rules
Please do not post support questions regarding installing, updating, or upgrading phpBB 3.1. If you need support for phpBB 3.1 please visit the 3.1.x Support Forum on phpbb.com.

If you have questions regarding writing extensions please post in Extension Writers Discussion to receive proper guidance from our staff and community.
Post Reply
User avatar
nextgen
Registered User
Posts: 128
Joined: Sat Jul 24, 2010 4:59 am
Location: Guatemala
Contact:

Re: Dependency Management: Composer

Post by nextgen » Sun Apr 07, 2013 4:50 pm

There is no way to install this version. :lol:
*Imagine a signature super spectacular.*

User avatar
oddfish
Registered User
Posts: 110
Joined: Tue Mar 27, 2007 5:53 am
Location: on my way home
Contact:

Re: Dependency Management: Composer

Post by oddfish » Sun Apr 07, 2013 6:24 pm

Arty wrote:5.3.23 is actually newer than 5.3.3. ".23" does not mean ".2.3"
5.3.2x is newer than 5.3.3 I know. That is not the issue as 5.3.2x is not >= 5.3.3.

Perhaps Phar should get a new abacus.

As I say, update to greater than or equal to 5.3.3 and you'll be good to go.

User avatar
nextgen
Registered User
Posts: 128
Joined: Sat Jul 24, 2010 4:59 am
Location: Guatemala
Contact:

Re: Dependency Management: Composer

Post by nextgen » Sun Apr 07, 2013 6:47 pm

I have run these commands

php --re Phar | grep version

Result: none

php -v

Result:

Code: Select all

PHP 5.2.17 (cli) (built: Feb  1 2012 15:01:30)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2010 Zend Technologies
    with the ionCube PHP Loader v4.2.2, Copyright (c) 2002-2012, by ionCube Ltd.          , and
    with Zend Optimizer v3.3.9, Copyright (c) 1998-2009, by Zend Technologies
php -i | grep Configure

Result:

Code: Select all

Configure Command =>  './configure'  '--disable-cgi' '--enable-bcmath' '--enable          -calendar' '--enable-dbase' '--enable-exif' '--enable-fastcgi' '--enable-ftp' '-          -enable-gd-native-ttf' '--enable-libxml' '--enable-magic-quotes' '--enable-mbstr          ing' '--enable-pdo=shared' '--enable-soap' '--enable-sockets' '--enable-sqlite-u          tf8' '--enable-wddx' '--enable-zip' '--prefix=/usr/local' '--with-bz2' '--with-c          url=/opt/curlssl/' '--with-freetype-dir=/usr' '--with-gd' '--with-gettext' '--wi          th-imap=/opt/php_with_imap_client/' '--with-imap-ssl=/opt/openssl' '--with-jpeg-          dir=/usr' '--with-kerberos' '--with-libdir=lib64' '--with-libexpat-dir=/usr' '--          with-libxml-dir=/opt/xml2' '--with-libxml-dir=/opt/xml2/' '--with-mcrypt=/opt/li          bmcrypt/' '--with-mhash=/opt/mhash/' '--with-mime-magic' '--with-mssql=/usr' '--          with-mysql=/usr' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--with-mysqli=/u          sr/bin/mysql_config' '--with-openssl=/opt/openssl' '--with-openssl-dir=/opt/open          ssl' '--with-pcre-regex=/opt/pcre' '--with-pdo-mysql=shared' '--with-pdo-sqlite=          shared' '--with-pic' '--with-png-dir=/usr' '--with-pspell' '--with-sqlite=shared          ' '--with-tidy=/opt/tidy/' '--with-ttf' '--with-unixODBC=/usr' '--with-xmlrpc' '          --with-xpm-dir=/usr' '--with-xsl=/opt/xslt/' '--with-zlib' '--with-zlib-dir=/usr 
I've seen this line in my .htaccess

Code: Select all

# Use PHP 5.3
AddType application/x-httpd-php53 .php
Then have to talk to my hosting to put 5.3.23 version by default or not?

Edit: This sucks
My Hosting wrote:Ok this error isn't related to the php version but the program itself.
My Hosting wrote:Unfortunately in terms of writing code we do not support coding issues and I would have to point you towards the developer who wrote the code for troubleshooting support as I can see that there is nothing wrong with your server and it is running at 100%
I'll have to wait to buy a vps or dedicated :lol:
*Imagine a signature super spectacular.*

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 1731
Joined: Thu Mar 02, 2006 4:29 pm
Location: Earth
Contact:

Re: Dependency Management: Composer

Post by DavidIQ » Sun Apr 07, 2013 8:02 pm

oddfish wrote:
Arty wrote:5.3.23 is actually newer than 5.3.3. ".23" does not mean ".2.3"
5.3.2x is newer than 5.3.3 I know. That is not the issue as 5.3.2x is not >= 5.3.3.

Perhaps Phar should get a new abacus.

As I say, update to greater than or equal to 5.3.3 and you'll be good to go.
As Arty already pointed out, 5.3.23 IS >= 5.3.3. You should review the PHP version history page if you're still confused or insist that it is not.
Image

User avatar
Arty
Registered User
Posts: 970
Joined: Wed Mar 06, 2002 2:36 pm
Location: Mars
Contact:

Re: Dependency Management: Composer

Post by Arty » Sun Apr 07, 2013 9:18 pm

Why not do installation of vendor files on your computer instead and then upload to server?
Formerly known as CyberAlien.

Free phpBB styles | Premium responsive XenForo styles

User avatar
oddfish
Registered User
Posts: 110
Joined: Tue Mar 27, 2007 5:53 am
Location: on my way home
Contact:

Re: Dependency Management: Composer

Post by oddfish » Mon Apr 08, 2013 5:41 am

DavidIQ wrote:As Arty already pointed out, 5.3.23 IS >= 5.3.3. You should review the PHP version history page if you're still confused or insist that it is not.
Why not give an answer instead of pointing me to what I already have stated as knowing? Is this being constructive and useful? :roll:

I could point you to a math page to show you are confused about simple math but that too is defeating the option to actually be useful in supplying a result.

The reason for my suggestion is simple. Having tested 5.3.10 to 5.3.23 with various software with set requirements including 3.1 from introducing composer (still 5.3.2), composer has refused to install regularly with the same error (line 13) on various setups for whatever reason you want to not suggest. I propose to use a greater number (note: not version) and I get that response from a developer? :roll: Oh well, there goes another moment in the annals.

EDIT : removed concept explanation since I feel there is little to be gained by it.

User avatar
Arty
Registered User
Posts: 970
Joined: Wed Mar 06, 2002 2:36 pm
Location: Mars
Contact:

Re: Dependency Management: Composer

Post by Arty » Mon Apr 08, 2013 9:53 am

I think you don't understand how version numbers work. .23 does not equal 0.23 number, it equals 23. Each part of version number should be treated separately, not like floating digit. So 23 > 3

5.3.23 > 5.3.3
Each number should be compared separately:
5 = 5 -> moving on to next number
3 = 3 -> moving on to next number
23 > 3

PHP scripts use version_compare() function, not mathematical comparison of floating numbers (which wouldn't work anyway because there are 2 dots). That function compares each part of number separately, so in php scripts 5.3.23 is newer than 5.3.3
Formerly known as CyberAlien.

Free phpBB styles | Premium responsive XenForo styles

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 1731
Joined: Thu Mar 02, 2006 4:29 pm
Location: Earth
Contact:

Re: Dependency Management: Composer

Post by DavidIQ » Tue Apr 09, 2013 12:23 am

oddfish wrote:The reason for my suggestion is simple. Having tested 5.3.10 to 5.3.23 with various software with set requirements including 3.1 from introducing composer (still 5.3.2), composer has refused to install regularly with the same error (line 13) on various setups for whatever reason you want to not suggest. I propose to use a greater number (note: not version) and I get that response from a developer? :roll: Oh well, there goes another moment in the annals.
That was really unnecessary. You are completely wrong with everything you've said about versions and even math and numbers (when did 3 become less than 23?) so before you continue making a fool of yourself I suggest you look up how versioning actually works, specifically how it is being used in PHP. Attempting to make diagrams doesn't replace how it actually works nor will it convince anyone that 3 is a higher version than 23. :roll:
nextgen wrote:I'll have to wait to buy a vps or dedicated :lol:
To emphasize what Arty already stated and so you don't go mistakenly asking your hosting company to downgrade you from 5.3.23 to 5.3.3, this is your best option at this point:
Arty wrote:Why not do installation of vendor files on your computer instead and then upload to server?
Image

User avatar
nextgen
Registered User
Posts: 128
Joined: Sat Jul 24, 2010 4:59 am
Location: Guatemala
Contact:

Re: Dependency Management: Composer

Post by nextgen » Tue Apr 09, 2013 1:35 am

DavidIQ wrote:To emphasize what Arty already stated and so you don't go mistakenly asking your hosting company to downgrade you from 5.3.23 to 5.3.3, this is your best option at this point:
Arty wrote:Why not do installation of vendor files on your computer instead and then upload to server?
Yes, I just try this method and I got this message.

Code: Select all

 Fatal error: Class 'Symfony\Component\HttpKernel\DependencyInjection\Extension' not found in /home/starrk/public_html/area51/phpBB/includes/di/extension/core.php on line 27
:|
*Imagine a signature super spectacular.*

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 1731
Joined: Thu Mar 02, 2006 4:29 pm
Location: Earth
Contact:

Re: Dependency Management: Composer

Post by DavidIQ » Tue Apr 09, 2013 1:45 am

Have you tried the attachment in this post?
Image

Post Reply