eviL3 wrote:It would be nice if the tasks were more extensible/generic, with one file per task, either implementing or extending an interface or base class.
Perhaps CRON_ID can be defined outside of the cron_lock class or replaced with a static property (which isn't great either, but at least more namespaced).
nn- wrote:While I see some benefits of this, would you mind writing them down? Doing so will probably formalize some of the requirements and/or 'nice to have' items that the implementation can be judged against.
nn- wrote:I only kept it because it was in original code. There is no other reason to keep it as a constant. In my implementation CRON_ID should actually be a plan instance variable.
nn- wrote:Are we targeting 3.x line and php4 compatibility?
Users browsing this forum: No registered users and 6 guests