[RFC] Update jQuery included in 3.1 to 1.11.0

These requests for comments/change have lead to an implemented feature that has been successfully merged into the 3.1/Ascraeus branch. Everything listed in this forum will be available in phpBB 3.1.
User avatar
VSE
Extension Customisations
Extension Customisations
Posts: 670
Joined: Mon Mar 08, 2010 9:18 am

[RFC] Update jQuery included in 3.1 to 1.11.0

Post by VSE » Mon Mar 31, 2014 6:48 pm

When we added jQuery to phpBB 3.1, I remember arguing for 1.8.3 (released Nov 2012) because at the time, the new release was 1.9, which deprecated bunch of features (like live() and browser()).

As far as I can tell, and I'll test it with their migration tool, but phpBB 3.1 is not be using any of that deprecated jQuery code. And extensions should not either. And really, MODs may be the only old stuff lying around that may have deprecated code, but even they should be updated for phpBB 3.1 anyway.

So with that in mind, I really don't see any reason why phpBB 3.1 can't ship with the slimmer and more up to date version 1.11.0.

The 1.X line still supports old IE browsers (it's the 2.X line that drops support for IE8 and below).
Has an irascible disposition.

User avatar
Pico88
Registered User
Posts: 73
Joined: Tue Apr 12, 2011 2:32 pm

Re: [RFC] Update jQuery included in 3.1 to 1.11.0

Post by Pico88 » Mon Mar 31, 2014 7:23 pm

I'm for updating jQuery to 2.X line and don't care about outdated browsers. ;)

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 1731
Joined: Thu Mar 02, 2006 4:29 pm
Location: Earth
Contact:

Re: [RFC] Update jQuery included in 3.1 to 1.11.0

Post by DavidIQ » Tue Apr 01, 2014 12:51 am

I'm all for doing that. The sooner the better.
Image

User avatar
EXreaction
Registered User
Posts: 1555
Joined: Sat Sep 10, 2005 2:15 am

Re: [RFC] Update jQuery included in 3.1 to 1.11.0

Post by EXreaction » Tue Apr 01, 2014 1:28 am

Sounds good to me

User avatar
VSE
Extension Customisations
Extension Customisations
Posts: 670
Joined: Mon Mar 08, 2010 9:18 am

Re: [RFC] Update jQuery included in 3.1 to 1.11.0

Post by VSE » Tue Apr 01, 2014 4:19 am

Has an irascible disposition.

User avatar
BioLogIn
Registered User
Posts: 28
Joined: Mon Dec 10, 2012 6:55 pm

Re: [RFC] Update jQuery included in 3.1 to 1.11.0

Post by BioLogIn » Tue Apr 01, 2014 11:57 am

I'm for updating jQuery to 2.X line
+1

User avatar
Pico88
Registered User
Posts: 73
Joined: Tue Apr 12, 2011 2:32 pm

Re: [RFC] Update jQuery included in 3.1 to 1.11.0

Post by Pico88 » Tue Apr 01, 2014 12:14 pm

DavidIQ wrote:I'm all for doing that. The sooner the better.
For which ver.? :)

User avatar
VSE
Extension Customisations
Extension Customisations
Posts: 670
Joined: Mon Mar 08, 2010 9:18 am

Re: [RFC] Update jQuery included in 3.1 to 1.11.0

Post by VSE » Tue Apr 01, 2014 2:40 pm

Pico88 wrote:
DavidIQ wrote:I'm all for doing that. The sooner the better.
For which ver.? :)
1.11.0

Version 2 is for IE9 and newer. Still too soon to totally break phpBB on IE8.

Version 2 should be saved for phpBB 3.2 (by then I'm sure there'll be a jQuery 3 though).
Has an irascible disposition.

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 1731
Joined: Thu Mar 02, 2006 4:29 pm
Location: Earth
Contact:

Re: [RFC] Update jQuery included in 3.1 to 1.11.0

Post by DavidIQ » Tue Apr 01, 2014 4:40 pm

Pico88 wrote:
DavidIQ wrote:I'm all for doing that. The sooner the better.
For which ver.? :)
What VSE+ said of course and doing this quickly means that MOD/Extension authors won't have to re-do their jQuery code due to changes in 1.11. I completely agree that it's too soon to adopt version 2 and break all sorts of things for IE8. 3.2 is a good target version for that newer version of jQuery and could possibly still be too soon. I mean from what I read on their blog a while back, the majority of the benefit in removing older browser support was so they didn't have to concentrate on or deal with bugs from those browsers and to make jQuery even smaller/lighter. So really on our end and the user's there's not a whole lot of benefit in going with 2.x and breaking many people's forum experience.

And before anyone goes and says that these users shouldn't be using old browsers anyways you have to take into consideration that users don't always have control over what can be on their computers. At my job we upgraded the CKEditor WYSIWYG editor from 3.x to 4.3 for our main product, which also went the route of removing older browser support as of that version. Well guess what...client (government) was behind in upgrading all of their systems and had over 100 PCs still running XP and IE7 :shock: Had to go back and add a "legacy" version of CKEditor (version 4.1.3 was the last to support IE7) and decide on the back end which of the two to load based on the browser agent.

While we don't really care about IE7 at this point, since it's last supported OS was XP and Microsoft support for XP is ending this month, we do sort of still care about IE8 since it was included in Vista which will continue to be supported for some time by MS.
Image

User avatar
Pony99CA
Registered User
Posts: 986
Joined: Sun Feb 08, 2009 2:35 am
Location: Hollister, CA
Contact:

Re: [RFC] Update jQuery included in 3.1 to 1.11.0

Post by Pony99CA » Wed Apr 02, 2014 3:00 am

And IE 8 is still in use at some government facilities (like this one).

Steve
Silicon Valley Pocket PC (http://www.svpocketpc.com)
Creator of manage_bots and spoof_user (ask me)
Need hosting for a small forum with full cPanel & MySQL access? Contact me or PM me.

Post Reply