[RFC|Merged] Require PHP 5.3

These requests for comments/change have lead to an implemented feature that has been successfully merged into the 3.1/Ascraeus branch. Everything listed in this forum will be available in phpBB 3.1.
Post Reply
User avatar
igorw
Registered User
Posts: 500
Joined: Thu Jan 04, 2007 11:47 pm

Re: [RFC] Require PHP 5.3

Post by igorw » Wed Feb 08, 2012 6:09 pm

Thanks for the stats, I will make a PR. I don't think there are any arguments against it now.

User avatar
Erik Frèrejean
Registered User
Posts: 207
Joined: Thu Oct 25, 2007 2:25 pm
Location: surfnet
Contact:

Re: [RFC] Require PHP 5.3

Post by Erik Frèrejean » Wed Feb 08, 2012 7:08 pm

igorw wrote:Thanks for the stats, I will make a PR. I don't think there are any arguments against it now.
I honestly can't understand how its so easily dismissed that currently over half the phpBB installations are on a 5.2 system, and that over more than a year that percentage did decrease by as little as 7.7 percentage point. So assume that, that rate will increase significant before the 3.1 release and risk a big portion of the user base not able to upgrade, which is something I still vote against because it is still pretty vague what advantage it will bring (terms like could/would/think), while the major disadvantage at this moment shows in the stats.
Available on .com
Support Toolkit developer

Oleg
Posts: 1150
Joined: Tue Feb 23, 2010 2:38 am
Contact:

Re: [RFC] Require PHP 5.3

Post by Oleg » Wed Feb 08, 2012 8:22 pm

The question is not what percentage of hosts currently offer version X, but rather what percentage of hosts are unable to offer version X.

A big issue is what version ships with the distribution that hosts use. LAMP stack pieces must be compiled together, otherwise they won't work. Therefore if we require hosts to compile php in order to use phpbb this is a significant, and likely unacceptable, burden, as they would have to also recompile everything else running in their apaches.

The current situation is all major distributions are shipping 5.3. This means their QA processes verified that their php packages work with 5.3. 5.3 has been around long enough and is installed on enough servers that all maintained php software by now should be 5.3-compatible. Which means there should not be a problem with using 5.3 in production at this time.

What that means in turn is the only reason hosts still run 5.2 is because they have no incentive to upgrade to 5.3. With ajax being added and stylesheet refactoring we have a choice between reimplementing assetic, not shipping asset management or requiring 5.3 to use assetic. Of these three options requiring 5.3 has no drawbacks other than requiring hosts to upgrade, but this is exactly the sort of incentive they need to upgrade.
Erik Frèrejean wrote: risk a big portion of the user base not able to upgrade
This risk is essentially nonexistent.

User avatar
callumacrae
Infrastructure Team
Infrastructure Team
Posts: 1046
Joined: Tue Apr 27, 2010 9:37 am
Location: England
Contact:

Re: [RFC] Require PHP 5.3

Post by callumacrae » Wed Feb 08, 2012 9:21 pm

Erik Frèrejean wrote:
igorw wrote:Thanks for the stats, I will make a PR. I don't think there are any arguments against it now.
I honestly can't understand how its so easily dismissed that currently over half the phpBB installations are on a 5.2 system, and that over more than a year that percentage did decrease by as little as 7.7 percentage point. So assume that, that rate will increase significant before the 3.1 release and risk a big portion of the user base not able to upgrade, which is something I still vote against because it is still pretty vague what advantage it will bring (terms like could/would/think), while the major disadvantage at this moment shows in the stats.
+1 to this, and -1 to the RFC.
Made by developers, for developers!
My blog

wGEric
Registered User
Posts: 521
Joined: Wed Jun 11, 2003 2:07 am
Contact:

Re: [RFC] Require PHP 5.3

Post by wGEric » Wed Feb 08, 2012 9:50 pm

Eric

User avatar
Erik Frèrejean
Registered User
Posts: 207
Joined: Thu Oct 25, 2007 2:25 pm
Location: surfnet
Contact:

Re: [RFC] Require PHP 5.3

Post by Erik Frèrejean » Wed Feb 08, 2012 10:18 pm

Oleg wrote:
Erik Frèrejean wrote: risk a big portion of the user base not able to upgrade
This risk is essentially nonexistent.
No because 59.9% is a nonexistent portion.
Available on .com
Support Toolkit developer

User avatar
A_Jelly_Doughnut
Registered User
Posts: 1780
Joined: Wed Jun 04, 2003 4:23 pm

Re: [RFC] Require PHP 5.3

Post by A_Jelly_Doughnut » Thu Feb 09, 2012 12:31 am

naderman wrote:The way I see this is the following: We want to finish 3.1 as soon as possible. Extensions need to be finished to release 3.1. Extensions would be easier and quicker to implement fully if we could use third party components for them. Third party components we would like to use for extensions require PHP 5.3. So let's just require PHP 5.3, to get 3.1 done already, so we can move on.
Perfect. +1
A_Jelly_Doughnut

User avatar
bantu
3.0 Release Manager
3.0 Release Manager
Posts: 557
Joined: Thu Sep 07, 2006 11:22 am
Location: Karlsruhe, Germany
Contact:

Re: [RFC] Require PHP 5.3

Post by bantu » Thu Feb 16, 2012 5:19 pm

I have considered the information provided in this topic and come to the conclustion that upgrading requirements to PHP 5.3 is "okay" to do.

User avatar
naderman
Product Manager
Product Manager
Posts: 1727
Joined: Sun Jan 11, 2004 2:11 am
Location: Karlsruhe, Germany
Contact:

Re: [RFC] Require PHP 5.3

Post by naderman » Wed Feb 22, 2012 3:55 pm

wGEric wrote:The hosts phpBB suggests don't even support 5.3.

Bluehost: https://my.bluehost.com/cgi/help/386
Hostmonster: https://my.hostmonster.com/cgi/help/386
Fastdomain: https://my.fastdomain.com/cgi/help/386
That might be the case, but we are talking about them moving to a newer version of PHP in the future. And they quite certainly will move to 5.3 eventually.

Oleg quite correctly points out, that the cost of upgrading to PHP5.3 is very low now, so yes the percentages will start to shift more strongly.

Can someone please create a ticket for changing the warning in the next 3.0 release, and changing requirements info for 3.1? We will also have to announce this change on phpbb.com.

User avatar
imkingdavid
Registered User
Posts: 1050
Joined: Thu Jul 30, 2009 12:06 pm

Re: [RFC] Require PHP 5.3

Post by imkingdavid » Wed Feb 22, 2012 4:19 pm

naderman wrote:Can someone please create a ticket for changing the warning in the next 3.0 release, and changing requirements info for 3.1? We will also have to announce this change on phpbb.com.
Will do. EDIT: Did
I do custom MODs. PM for a quote!
View My: MODs | Portfolio
Please do NOT contact for support via PM or email.
Remember, the enemy's gate is down.

Post Reply