[RFC|Merged] Require PHP 5.3

These requests for comments/change have lead to an implemented feature that has been successfully merged into the 3.1/Ascraeus branch. Everything listed in this forum will be available in phpBB 3.1.
Post Reply
Oleg
Posts: 1150
Joined: Tue Feb 23, 2010 2:38 am
Contact:

Re: [RFC|Accepted] Require PHP 5.3

Post by Oleg » Fri Mar 09, 2012 4:21 pm

I posted the announcement, it is now pending approval.

User avatar
brunoais
Registered User
Posts: 958
Joined: Fri Dec 18, 2009 3:55 pm

Re: [RFC|Accepted] Require PHP 5.3

Post by brunoais » Fri Mar 09, 2012 5:34 pm

^
approval?
You cannot post announcements without approval?

User avatar
MichaelC
Development Team
Development Team
Posts: 889
Joined: Thu Jan 28, 2010 6:29 pm

Re: [RFC|Accepted] Require PHP 5.3

Post by MichaelC » Fri Mar 09, 2012 5:47 pm

brunoais wrote:^
approval?
You cannot post announcements without approval?
All team members can create new announcements but it requires approval by a manager (as in permissions approval, not verbal approval).

Oleg is only a release manager, not a member of the management team.
Formerly known as Unknown Bliss
psoTFX wrote: I went with Olympus because as I said to the teams ... "It's been one hell of a hill to climb"
No unsolicited PMs please except for quotes.

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 1731
Joined: Thu Mar 02, 2006 4:29 pm
Location: Earth
Contact:

Re: [RFC|Accepted] Require PHP 5.3

Post by DavidIQ » Sat Mar 10, 2012 12:32 pm

Oleg wrote:I posted the announcement, it is now pending approval.
Meant to say it last night but...approved. :mrgreen:
Image

User avatar
naderman
Product Manager
Product Manager
Posts: 1727
Joined: Sun Jan 11, 2004 2:11 am
Location: Karlsruhe, Germany
Contact:

Re: [RFC] Require PHP 5.3

Post by naderman » Tue Jul 31, 2012 12:54 pm

naderman wrote:Stats for 3.0.10 to date:

Code: Select all

4.3: <  1.0%
4.4:    2.5%
5.0: <  1.0%
5.1:    1.2%
5.2:   56.9%
5.3:   39.0%
5.4: <  1.0%
Stats for 3.0.8:

Code: Select all

4.3: < 1.0%
4.4:   4.2%
5.0: < 1.0%
5.1:   2.2%
5.2:  67.6%
5.3:  25.5%
Based on this, I think it's fair to assume that by the time 3.1 is released, 5.3 and 5.4 will make up a large majority of our users' platforms. Certainly enough to simply force the rest to upgrade their PHP to 5.3 if they want to update to phpBB 3.1. Do keep in mind that we will continue to support 3.0.x for a while after the release 3.1 as well. So I really do not see a problem with requiring PHP 5.3 at all.
Brief update, as I compiled this data for a discussion in PHP internals. The stats for everyone who sent us data in the last 3 months:

Code: Select all

4.3: < 1.0%
4.4:   1.9%
5.0: < 1.0%
5.1: < 1.0%
5.2:  49.4%
5.3:  46.2%
5.4:   1.4%
Looks like we're on a good path to sufficient 5.3 support by the time of final release.

jamesbond22
Registered User
Posts: 1
Joined: Wed Jan 02, 2013 6:27 am

Re: [RFC|Merged] Require PHP 5.3

Post by jamesbond22 » Fri Jan 04, 2013 6:34 am

The php version 5.3 will reach EOL status in March 2013.
Maybe is it better to choose for php 5.4+
The PHP development team announces the immediate availability of PHP 5.4.10 and PHP 5.3.20. These releases fix about 15 bugs. Please note that the PHP 5.3 series will enter an end of life cycle and receive only critical fixes as of March 2013. All users of PHP are encouraged to upgrade to PHP 5.4.

User avatar
brunoais
Registered User
Posts: 958
Joined: Fri Dec 18, 2009 3:55 pm

Re: [RFC|Merged] Require PHP 5.3

Post by brunoais » Fri Jan 04, 2013 10:03 pm

There are many hosting companies like x10hosting that are a pain before they upgrade. Better stay as 5.3, if possible.

Oleg
Posts: 1150
Joined: Tue Feb 23, 2010 2:38 am
Contact:

Re: [RFC|Merged] Require PHP 5.3

Post by Oleg » Sat Jan 05, 2013 12:08 am

We choose to require a certain minimum version because of features added in that version. Until we want to use something that is only present in 5.4 there is no reason to require it.

Post Reply