3.1 "Ascraeus" to drop support for PostgreSQL < 8.3

These requests for comments/change have lead to an implemented feature that has been successfully merged into the 3.1/Ascraeus branch. Everything listed in this forum will be available in phpBB 3.1.
Oleg
Posts: 1150
Joined: Tue Feb 23, 2010 2:38 am
Contact:

Re: 3.1 "Ascraeus" to drop support for PostgreSQL < 8.2

Post by Oleg » Tue Mar 20, 2012 7:33 am

Per viewtopic.php?p=235659#p235659 when we do the fulltext search in postgres we should bump the minimum version to 8.3.

Oleg
Posts: 1150
Joined: Tue Feb 23, 2010 2:38 am
Contact:

Re: 3.1 "Ascraeus" to drop support for PostgreSQL < 8.3

Post by Oleg » Sun Dec 02, 2012 5:55 am

With the postgres fulltext search merged (which requires 8.3), overall postgres requirement will now be 8.3+.

Squeeze ships 8.4 http://packages.debian.org/squeeze/postgresql

I guess redhat/centos at 8.1 are going to be out of luck. I cannot imagine too many people who would insist on running postgres 8.1 in this day and age however.

User avatar
MichaelC
Development Team
Development Team
Posts: 889
Joined: Thu Jan 28, 2010 6:29 pm

Re: 3.1 "Ascraeus" to drop support for PostgreSQL < 8.3

Post by MichaelC » Tue Dec 04, 2012 4:40 pm

Is it worth making an announcement or topic/blog post on .com about thi?s
Formerly known as Unknown Bliss
psoTFX wrote: I went with Olympus because as I said to the teams ... "It's been one hell of a hill to climb"
No unsolicited PMs please except for quotes.

User avatar
imkingdavid
Registered User
Posts: 1050
Joined: Thu Jul 30, 2009 12:06 pm

Re: 3.1 "Ascraeus" to drop support for PostgreSQL < 8.3

Post by imkingdavid » Tue Dec 04, 2012 4:42 pm

I'm not sure a full announcement is needed for this, though it probably wouldn't hurt. At the very least, we should add a notice on the upgrade page for users that are using an older version of postgresql.
I do custom MODs. PM for a quote!
View My: MODs | Portfolio
Please do NOT contact for support via PM or email.
Remember, the enemy's gate is down.

User avatar
MichaelC
Development Team
Development Team
Posts: 889
Joined: Thu Jan 28, 2010 6:29 pm

Re: 3.1 "Ascraeus" to drop support for PostgreSQL < 8.3

Post by MichaelC » Tue Dec 04, 2012 4:43 pm

imkingdavid wrote:I'm not sure a full announcement is needed for this, though it probably wouldn't hurt. At the very least, we should add a notice on the upgrade page for users that are using an older version of postgresql.
An ACP warning like we have done for PHP?
Formerly known as Unknown Bliss
psoTFX wrote: I went with Olympus because as I said to the teams ... "It's been one hell of a hill to climb"
No unsolicited PMs please except for quotes.

User avatar
imkingdavid
Registered User
Posts: 1050
Joined: Thu Jul 30, 2009 12:06 pm

Re: 3.1 "Ascraeus" to drop support for PostgreSQL < 8.3

Post by imkingdavid » Tue Dec 04, 2012 5:03 pm

Probably just on the requirements check of the upgrade script it should test for the current database version being too low.
I do custom MODs. PM for a quote!
View My: MODs | Portfolio
Please do NOT contact for support via PM or email.
Remember, the enemy's gate is down.

Oleg
Posts: 1150
Joined: Tue Feb 23, 2010 2:38 am
Contact:

Re: 3.1 "Ascraeus" to drop support for PostgreSQL < 8.3

Post by Oleg » Tue Dec 04, 2012 6:31 pm

Please create a ticket.

User avatar
MichaelC
Development Team
Development Team
Posts: 889
Joined: Thu Jan 28, 2010 6:29 pm

Re: 3.1 "Ascraeus" to drop support for PostgreSQL < 8.3

Post by MichaelC » Tue Dec 04, 2012 9:24 pm

imkingdavid wrote:Probably just on the requirements check of the upgrade script it should test for the current database version being too low.
I believe there was something rxu was working on as we don't check all requirements properly in the update/install process. We should also warn in the ACP when future phpBB requirements are not met in existing installs. I'll make an RFC for this.
Formerly known as Unknown Bliss
psoTFX wrote: I went with Olympus because as I said to the teams ... "It's been one hell of a hill to climb"
No unsolicited PMs please except for quotes.

Post Reply