phpBB 3.3.0-RC1 released

General discussion of development ideas and the approaches taken in the 3.x branch of phpBB. The next feature release of phpBB 3 will be 3.3/Proteus.
Forum rules
Please do not post support questions regarding installing, updating, or upgrading phpBB 3.2.x. If you need support for phpBB 3.2.x please visit the 3.2.x Support Forum on phpbb.com.

If you have questions regarding writing extensions please post in Extension Writers Discussion to receive proper guidance from our staff and community.
Kirk
Registered User
Posts: 7
Joined: Mon Dec 23, 2019 7:43 pm

Re: phpBB 3.3.0-RC1 released

Post by Kirk »

Hi
In an extension I have e.g. in the ext.php a ] instead of a ), the ext cannot be activated (no error message).
Under 3.2.8 I get this error message:
Parse error: syntax error, unexpected ']', expecting ',' or ')'

User avatar
3Di
Registered User
Posts: 784
Joined: Tue Nov 01, 2005 9:50 pm
Location: Milano (I) Frankfurt (D)
Contact:

Re: phpBB 3.3.0-RC1 released

Post by 3Di »

Let's help us determine any bugs by also using PHP 7.4.x ;)
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

Kirk
Registered User
Posts: 7
Joined: Mon Dec 23, 2019 7:43 pm

Re: phpBB 3.3.0-RC1 released

Post by Kirk »

I can only test until PHP 7.3.7

User avatar
3Di
Registered User
Posts: 784
Joined: Tue Nov 01, 2005 9:50 pm
Location: Milano (I) Frankfurt (D)
Contact:

Re: phpBB 3.3.0-RC1 released

Post by 3Di »

You can use a local stack like this:

http://wampserver.aviatechno.net/?lang=en (for Windows)

Available PHP: from 5.3.28 to 7.4.1 ;)
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

User avatar
3Di
Registered User
Posts: 784
Joined: Tue Nov 01, 2005 9:50 pm
Location: Milano (I) Frankfurt (D)
Contact:

Re: phpBB 3.3.0-RC1 released

Post by 3Di »

Kirk wrote:
Mon Dec 23, 2019 7:51 pm
Hi
In an extension I have e.g. in the ext.php a ] instead of a ), the ext cannot be activated (no error message).
Under 3.2.8 I get this error message:
Parse error: syntax error, unexpected ']', expecting ',' or ')'
You should enable debug, in 3.3.x has changed, see: https://phpbbstudio.com/viewtopic.php?f=11&t=130
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

Kirk
Registered User
Posts: 7
Joined: Mon Dec 23, 2019 7:43 pm

Re: phpBB 3.3.0-RC1 released

Post by Kirk »

I have tested it on another server with PHP 7.4.x including debug change, the same result.

User avatar
david63
Registered User
Posts: 299
Joined: Mon Feb 07, 2005 7:23 am
Location: Lancashire, UK

Re: phpBB 3.3.0-RC1 released

Post by david63 »

Perhaps telling us which extension it is might help.

Also if you have a problem with an extension (which you has with 3.2.8) then the correct place to deal with it is in the support topic for the extension.
David
Remember: You only know what you know -
and you do not know what you do not know!

Kirk
Registered User
Posts: 7
Joined: Mon Dec 23, 2019 7:43 pm

Re: phpBB 3.3.0-RC1 released

Post by Kirk »

It's an extension of mine, I made this bug on purpose to see how 3.3 behaves.

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 1842
Joined: Thu Mar 02, 2006 4:29 pm
Location: Earth
Contact:

Re: phpBB 3.3.0-RC1 released

Post by DavidIQ »

What exactly is in your ext.php file?
Image

User avatar
Solidjeuh
Registered User
Posts: 46
Joined: Sat Feb 25, 2017 6:42 pm
Location: Aalst, Belgium
Contact:

Re: phpBB 3.3.0-RC1 released

Post by Solidjeuh »

I have an error on clean/new install

Code: Select all

[phpBB Debug] "Trying to access array offset on value of type null" in file /var/www/vhosts/supportforum.be/httpdocs/phpbb/install/module_base.php on line 134
[phpBB Debug] "password_hash(): A thread value other than 1 is not supported by this implementation" in file /var/www/vhosts/supportforum.be/httpdocs/phpbb/passwords/driver/base_native.php on line 57

Skip “installer.install_database.set_up_database” task

Post Reply