phpBB 3.3.0-b2 released

General discussion of development ideas and the approaches taken in the 3.x branch of phpBB. The current feature release of phpBB 3 is 3.3/Proteus.
Forum rules
Please do not post support questions regarding installing, updating, or upgrading phpBB 3.3.x. If you need support for phpBB 3.3.x please visit the 3.3.x Support Forum on phpbb.com.

If you have questions regarding writing extensions please post in Extension Writers Discussion to receive proper guidance from our staff and community.
rubencm
Development Team
Development Team
Posts: 30
Joined: Sun Mar 12, 2017 8:30 pm
Location: h[b]ell[/b]o

Re: phpBB 3.3.0-b2 released

Post by rubencm »

janus wrote:
Mon Nov 25, 2019 2:52 pm
Auto updating from 3.2.8 to 3.3.0-b2 gives me directly the error

Code: Select all

[phpBB Debug] "Declaration of phpbb\template\twig\loader::findTemplate($name) should be compatible with Twig\Loader\FilesystemLoader::findTemplate($name, $throw = true)" in file /home/public/sites/www.catroom.nl/forum/phpbb/template/twig/loader.php on line 19
php 7.2
Any ideas?
You haven't updated the vendor folder I think

janus
Registered User
Posts: 26
Joined: Thu Nov 26, 2015 1:06 pm

Re: phpBB 3.3.0-b2 released

Post by janus »

I did and updating from 3.2.8 to 3.3.0-b1 was no problem.
Full update to 3.3.0-b2 went well also.
Strange, but the host from that board only support php7.3 after this week so I had no other choose to update

User avatar
Scanialady
Registered User
Posts: 17
Joined: Sat Sep 12, 2015 3:17 pm

Re: phpBB 3.3.0-b2 released

Post by Scanialady »

david63: the same for me with a fresh new installation - this broken cron image.
Dr.Death wrote:
Mon Nov 25, 2019 12:43 pm
@Scanialady:

Try to add this line into the .htaccess file located in your phpBB root Folder:

Code: Select all

Options -MultiViews
Seems to help - the broken image is gone, thank you.
What does this option do? I can not find it with Google ("option" seems to be too common).

edit://
answered this question myself ;-)
https://stackoverflow.com/questions/254 ... n-htaccess

User avatar
P_I Online
Registered User
Posts: 92
Joined: Fri Oct 31, 2014 4:56 am

Re: phpBB 3.3.0-b2 released

Post by P_I »

janus wrote:
Mon Nov 25, 2019 5:35 pm
I did and updating from 3.2.8 to 3.3.0-b1 was no problem.
Me too. FWIW, I'm testing it on a localhost testbed, using CentOS 7.7.1908 and PHP 7.2.25 from the remi-php repositories.

User avatar
Tastenplayer
Registered User
Posts: 12
Joined: Thu Dec 06, 2018 11:14 am
Contact:

Re: phpBB 3.3.0-b2 released

Post by Tastenplayer »

I cannot install Quickinstall TB 3.3.0_b2 locally in Xampp (new installation no update) . An installation of 3.3.0_b1 was no problem.
Database server: MySQL(i) 10.1.34-MariaDB, PHP version: 7.1.19 , Win10

Code: Select all

General Error
SQL ERROR [ mysql_41 ]

Unknown column 'user_email_hash' in 'field list' [1054]

SQL

UPDATE phpbb_users SET username = 'Tastenplayer', user_password = 'XY', user_ip = '127.0.0.1', user_lang = 'en', user_email = 'qi_board@phpbb-quickinstall.tld', user_dateformat = 'M jS, ’y, H:i', user_email_hash = -38070570631, username_clean = 'tastenplayer', user_timezone = 'Europe/Zurich' WHERE username = 'Admin'

BACKTRACE

FILE: [ROOT]/sources/phpBB3/phpbb/db/driver/driver.php
LINE: 1023
CALL: trigger_error()

FILE: [ROOT]/sources/phpBB3/phpbb/db/driver/mysqli.php
LINE: 195
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/modules/qi_create.php
LINE: 457
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/includes/functions_module.php
LINE: 52
CALL: qi_create->__construct()

FILE: [ROOT]/index.php
LINE: 296
CALL: module_handler->load()
Edit: Must go now, try later to update from Beta1 to Beta 2. A new installation definitely does not work.
Be the best version of yourself rather than a bad copy of someone else!

User avatar
david63 Online
Registered User
Posts: 313
Joined: Mon Feb 07, 2005 7:23 am
Location: Lancashire, UK

Re: phpBB 3.3.0-b2 released

Post by david63 »

I don't think that Quick Install has been updated yet for 3.3
David
Remember: You only know what you know -
and you do not know what you do not know!

User avatar
Tastenplayer
Registered User
Posts: 12
Joined: Thu Dec 06, 2018 11:14 am
Contact:

Re: phpBB 3.3.0-b2 released

Post by Tastenplayer »

Update from Quickinstall TB 3.3.0_b1 to 3.3.0_b2 worked and found no problems yet.
david63 wrote:
Tue Nov 26, 2019 8:34 am
I don't think that Quick Install has been updated yet for 3.3
That will be the reason. But an installation of phpBB 3.3.0_b1 worked and so did the update to beta 2. Only a new installation was impossible :) .
Board version: 3.3.0-b2 [ Re-Check version ]
Be the best version of yourself rather than a bad copy of someone else!

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 1856
Joined: Thu Mar 02, 2006 4:29 pm
Location: Earth
Contact:

Re: phpBB 3.3.0-b2 released

Post by DavidIQ »

QI was updated to work with 3.3. Version 1.3.6 should be working with it: https://github.com/phpbb/quickinstall/releases/latest
Image

User avatar
Tastenplayer
Registered User
Posts: 12
Joined: Thu Dec 06, 2018 11:14 am
Contact:

Re: phpBB 3.3.0-b2 released

Post by Tastenplayer »

My mistake :oops: , thank you for pointing that out. Now it worked locally with a new installation. But the desired 2 categories and 5 forums were not installed. Only the First category with 1 forum was installed.
Be the best version of yourself rather than a bad copy of someone else!

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 1856
Joined: Thu Mar 02, 2006 4:29 pm
Location: Earth
Contact:

Re: phpBB 3.3.0-b2 released

Post by DavidIQ »

Can you report that as an issue here with any additional details please? Thanks.
Image

Post Reply