PHP requirement

General discussion of development ideas and the approaches taken in the 3.x branch of phpBB. The next feature release of phpBB 3 will be 3.3/Proteus.
Forum rules
Please do not post support questions regarding installing, updating, or upgrading phpBB 3.1. If you need support for phpBB 3.1 please visit the 3.1.x Support Forum on phpbb.com.

If you have questions regarding writing extensions please post in Extension Writers Discussion to receive proper guidance from our staff and community.
User avatar
Elsensee
Development Team
Development Team
Posts: 36
Joined: Sun Mar 16, 2014 1:08 pm
Location: Hamburg, Germany
Contact:

Re: PHP requirement

Post by Elsensee » Sat Aug 29, 2015 10:21 pm

JoshyPHP wrote:
Thu Aug 27, 2015 5:27 pm
Elsensee wrote:
Thu Aug 27, 2015 5:19 pm
If we use specific functions or language features which are not available in some php version, then it's okay to bump the version, but to bump the requirement so we could use some functions or language features is not okay IMHO.
I don't get it. You have to bump the requirements before you can use a new feature.
What I meant was just:
VSE wrote:
Thu Aug 27, 2015 5:52 pm
I just think our min req ver should be whatever the number truly is, based on what we are using/doing. Can't we increase it at any time if we decide to install or do something that leads to a higher requirement?


Nicofuma wrote:
Thu Aug 27, 2015 6:40 pm
The problem is that a lot of people would like to use new features like me, but they don't because it's not necessary.

Nothing is necessary, it's just convenient.
Some stuff isn't just convenience.

User avatar
Marc
Development Team Leader
Development Team Leader
Posts: 128
Joined: Thu Sep 09, 2010 11:36 am
Location: Munich, Germany

Re: PHP requirement

Post by Marc » Thu Sep 03, 2015 2:54 pm

I do now think that we should aim at PHP 5.5 for three reasons:
  • People that want to use PHP < 5.5. still can use phpBB 3.1 for a while
  • The chances that the remaining hosts offer PHP 5.5 or newer should highly increase once PHP 5.4 reaches EOL
  • Supporting a PHP version two years after it has reached EOL might cause issues we can' think of yet

Nicofuma
3.2 Release Manager
3.2 Release Manager
Posts: 297
Joined: Sun Apr 13, 2014 1:40 am
Location: Paris

Re: PHP requirement

Post by Nicofuma » Wed Sep 09, 2015 11:01 am

For the record: http://phpversions.info
Member of the phpBB Development-Team
No Support via PM

User avatar
VSE
Extension Customisations
Extension Customisations
Posts: 670
Joined: Mon Mar 08, 2010 9:18 am

Re: PHP requirement

Post by VSE » Sun Sep 13, 2015 5:10 am

Nicofuma wrote:
Wed Sep 09, 2015 11:01 am
For the record: http://phpversions.info
Hmm, well according to that. Bluehost, whom we have a relationship with and advertise on phpbb.com, use 5.2 as a default with 5.4 as an option. We also advertise Hostmonster (5.4). So, just sayin' we should try to still support the hosts we advertise to our visitors ;) (5.4)
Has an irascible disposition.

User avatar
JoshyPHP
Registered User
Posts: 350
Joined: Fri Jul 08, 2011 9:43 pm

Re: PHP requirement

Post by JoshyPHP » Sun Sep 13, 2015 5:06 pm

I think it's more of a case of contacting them to remind them that PHP 5.4 is dead and they need to upgrade. Your advertisers are selling a potentially unsafe product to your visitors. The way to fix it is not by lowering your standards, it's the other way around.

Lady_G
Registered User
Posts: 32
Joined: Sun Aug 31, 2014 3:02 pm

Re: PHP requirement

Post by Lady_G » Sun Sep 13, 2015 8:29 pm

Please consider users who are not on shared hosts. Instead, look at the latest versions supported by the OS.

The latest CentOS version is 5.4.16, I would be OK with that. I'll move to 5.5 when CentOS makes the update available.

User avatar
JoshyPHP
Registered User
Posts: 350
Joined: Fri Jul 08, 2011 9:43 pm

Re: PHP requirement

Post by JoshyPHP » Sun Sep 13, 2015 9:07 pm


Lady_G
Registered User
Posts: 32
Joined: Sun Aug 31, 2014 3:02 pm

Re: PHP requirement

Post by Lady_G » Sun Sep 13, 2015 9:51 pm

Here's another way to slice the data - look at the server distros, which is the target platform. ==============
My point is that phpBB needs to accommodate a business model whose users who can't upgrade their OS every few months.

PHP needs to support every application on the server, not just phpBB. If "other" software can't work with PHP 5.5, phpBB will not get updated until everything works together.

The objective is to cautiously increment the minimum version requirement while not breaking other (not phpBB) software. That's why I requested 5.4.16 (and that older phpBB versions will still work for a while).

User avatar
VSE
Extension Customisations
Extension Customisations
Posts: 670
Joined: Mon Mar 08, 2010 9:18 am

Re: PHP requirement

Post by VSE » Sun Sep 13, 2015 11:09 pm

Regarding the current (not developmental) versions of some popular server software and their PHP requirements:
Drupal: 5.2
Joomla: 5.3
Wordpress: 5.2
MediaWiki: 5.3
..and pretty much all our competitors are on at least 5.2/5.3 too.
Has an irascible disposition.

User avatar
JoshyPHP
Registered User
Posts: 350
Joined: Fri Jul 08, 2011 9:43 pm

Re: PHP requirement

Post by JoshyPHP » Sun Sep 13, 2015 11:38 pm

Lady_G wrote:
Sun Sep 13, 2015 9:51 pm
My point is that phpBB needs to accommodate a business model whose users who can't upgrade their OS every few months.
PHP 5.5 has been in most Linux distros for months, maybe more than a year by the time phpBB 3.2 is released. Are there really users who upgrade their OS software every other year but want to use PHP software on the day of the release?
VSE wrote:
Sun Sep 13, 2015 11:09 pm
Regarding the current (not developmental) versions of some popular server software and their PHP requirements:
Drupal: 5.2
Old versions of Drupal run on old versions of PHP. The beta version of Drupal requires PHP 5.5.9. I didn't check the others because it would be a pointless exercise; Is it your argument that obsolete versions of PHP should be supported by new software?

Post Reply