PHP requirement

General discussion of development ideas and the approaches taken in the 3.x branch of phpBB. The next feature release of phpBB 3 will be 3.2/Rhea followed by 3.3.
Forum rules
Please do not post support questions regarding installing, updating, or upgrading phpBB 3.1. If you need support for phpBB 3.1 please visit the 3.1.x Support Forum on phpbb.com.

If you have questions regarding writing extensions please post in Extension Writers Discussion to receive proper guidance from our staff and community.
Lady_G
Registered User
Posts: 32
Joined: Sun Aug 31, 2014 3:02 pm

Re: PHP requirement

Post by Lady_G » Mon Sep 14, 2015 1:11 am

JoshyPHP wrote:
Sun Sep 13, 2015 11:38 pm
Lady_G wrote:
Sun Sep 13, 2015 9:51 pm
My point is that phpBB needs to accommodate a business model whose users who can't upgrade their OS every few months.
PHP 5.5 has been in most Linux distros for months, maybe more than a year by the time phpBB 3.2 is released. Are there really users who upgrade their OS software every other year but want to use PHP software on the day of the release?
I'm not sure I understand your question (or perhaps I didn't phrase my comment clearly).

One of CentOS's strong points is that they do not continually update RPM packages with the "latest and greatest" release. It's all about maintaining a stable environment. (Ref: CentOS FAQ)

This is a very different environment than bleeding-edge releases, such as Fedora (the upstream version of Red Hat) which updates every year.

Combining a 10 year support cycle, along with focusing on stability, is a very strong selling point and is probably why CentOS is in the top 10 for server distros.

I'm not a fan of any particular OS. My point is that you need to support the major OS releases, as the decision to update software is not a trivial one. VSE's list of "popular server software" makes this point clear.

Decide if the features on 3.2 warrant breaking the earlier PHP releases and proceed from there.

User avatar
JoshyPHP
Registered User
Posts: 348
Joined: Fri Jul 08, 2011 9:43 pm

Re: PHP requirement

Post by JoshyPHP » Mon Sep 14, 2015 1:22 am

My point is this: why would someone want to run bleeding edge phpBB on stable (or in this case, unmaintained) PHP? People who want to run PHP 5.3 or 5.4 can use phpBB 3.1.

Lady_G
Registered User
Posts: 32
Joined: Sun Aug 31, 2014 3:02 pm

Re: PHP requirement

Post by Lady_G » Mon Sep 14, 2015 1:53 am

Because you need a stable testing platform. Otherwise, you won't know if you're testing bugs in phpBB or PHP.

Khaos-Rage
Registered User
Posts: 35
Joined: Wed Aug 06, 2014 12:27 am

Re: PHP requirement

Post by Khaos-Rage » Mon Sep 14, 2015 2:21 am

Lady_G wrote:
Mon Sep 14, 2015 1:53 am
Because you need a stable testing platform. Otherwise, you won't know if you're testing bugs in phpBB or PHP.
Current 'stable' release of php is 5.6, and its possible that by the time phpbb 3.2 comes out that php 7 may be released.

Also just because php 5.4 is old does not equate stable they just released bug/security patches for 5.4, 5.5, 5.6. So you could code for 5.4 and still experience php bugs, and by the time phpbb 3.2 is released 5.4 support may be ended.

Just because centos supports old versions of php does not mean its stable, especially if that version of php is no longer supported.
Lady_G wrote:One of CentOS's strong points is that they do not continually update RPM packages with the "latest and greatest" release. It's all about maintaining a stable environment. (Ref: CentOS FAQ)
centos 5 isn't eol till march 2017 and it is still using php 5.1.6. Stable does not equal secure! These are the people as JoshyPHP said can stay on phpbb 3.1 it's not like its going anywhere.

Edit: Also this is on the front page of php.net
php.net wrote:Please note that according to the PHP version support timelines, PHP 5.4.45 is the last scheduled release of PHP 5.4 branch. There may be additional release if we discover important security issues that warrant it, otherwise this release will be the final one in the PHP 5.4 branch. If your PHP installation is based on PHP 5.4, it may be a good time to start making the plans for the upgrade to PHP 5.5 or PHP 5.6.
So effective tomorrow php 5.4 is EOL

User avatar
VSE
Extension Customisations
Extension Customisations
Posts: 670
Joined: Mon Mar 08, 2010 9:18 am

Re: PHP requirement

Post by VSE » Mon Sep 14, 2015 7:36 am

JoshyPHP wrote:
Mon Sep 14, 2015 1:22 am
My point is this: why would someone want to run bleeding edge phpBB on stable (or in this case, unmaintained) PHP? People who want to run PHP 5.3 or 5.4 can use phpBB 3.1.
phpBB 3.2 is hardly "bleeding edge". It is scheduled to be released in a few months.
https://www.phpbb.com/about/release/

Also, people don't "want to run PHP 5.3 or 5.4". The sad reality is a lot of people are still stuck with what their hosts use, which needs to be part of discussions like this.
http://phpversions.info/shared-hosting/
Has an irascible disposition.

User avatar
JoshyPHP
Registered User
Posts: 348
Joined: Fri Jul 08, 2011 9:43 pm

Re: PHP requirement

Post by JoshyPHP » Mon Sep 14, 2015 12:24 pm

VSE wrote:
Mon Sep 14, 2015 7:36 am
phpBB 3.2 is hardly "bleeding edge".
Oh, are we playing this game now? Let me unsubscribe from this topic then.

User avatar
imkingdavid
Registered User
Posts: 1050
Joined: Thu Jul 30, 2009 12:06 pm

Re: PHP requirement

Post by imkingdavid » Sat Sep 19, 2015 11:39 am

I am all for bumping to PHP 5.4 or even 5.5. And hell if we're going to bump it to 5.5, why not just go ahead and bump to 5.6?

PHP 5.3.0 was released in June 2009. Just more than 6 years ago. If a host can't be bothered to update in 6 years, they're not worth using. Sure, we should expect to have a wide range of users with a wide range of system setups, but at some point we have to stop bending over backwards to support old, EOL (or nearly EOL) versions of PHP.

FYI:
JoshyPHP wrote:Whenever I write something for phpBB, I have to make a conscious effort to not use the short array notation and stay clear of those PHP 5.3 issues.
As much as I love the short array syntax (I use it almost exclusively in my own extensions), I don't think that a bump to 5.4+ is excuse enough to introduce the short syntax into the core codebase unless it's a global switch, so this would still be an issue. Code consistency is important when you have so many different people contributing to the software. I shouldn't necessarily be able to look at any give code and know who wrote it based on the code style alone.

That being said, a bump to 5.4+ would definitely be a great help so you don't have to keep including those workarounds for those other issues.
I do custom MODs. PM for a quote!
View My: MODs | Portfolio
Please do NOT contact for support via PM or email.
Remember, the enemy's gate is down.

Post Reply