PHP requirement

General discussion of development ideas and the approaches taken in the 3.x branch of phpBB. The next feature release of phpBB 3 will be 3.2/Rhea followed by 3.3.
Forum rules
Please do not post support questions regarding installing, updating, or upgrading phpBB 3.1. If you need support for phpBB 3.1 please visit the 3.1.x Support Forum on phpbb.com.

If you have questions regarding writing extensions please post in Extension Writers Discussion to receive proper guidance from our staff and community.
User avatar
MichaelC
Development Team
Development Team
Posts: 889
Joined: Thu Jan 28, 2010 6:29 pm

Re: PHP requirement

Post by MichaelC » Mon Aug 24, 2015 11:22 pm

<MichaelC> Tbh, with drupal bumping it's minimum requirement to 5.5, I don't think it's something we should be worrying about (hosts not having updated)
<MichaelC> Also, if we are only going to 5.5 in one year, then by the time we jump to php7 or 5.6, 7.4 will have been released.
<MichaelC> Drupal moving it's minimum requirement up is going to force most hosts to update, us following suit will only help.
<MichaelC> And don't forget, we are still going to be supporting 3.2 in the fall of 2017, by which point 5.4 will have been EOL 2 years
<MichaelC> We are already supporting PHP 5.3.x until Fall of 2016 with 3.1

Nicofuma, as you said, 2 years past EOL is a long time. We are going to be dropping 5.3 two and a half years after EOL already due to 3.1, let's not have the same situation with 3.2 (supporting PHP 5.4 two years after EOL).
Formerly known as Unknown Bliss
psoTFX wrote: I went with Olympus because as I said to the teams ... "It's been one hell of a hill to climb"
No unsolicited PMs please except for quotes.

Nicofuma
3.2 Release Manager
3.2 Release Manager
Posts: 297
Joined: Sun Apr 13, 2014 1:40 am
Location: Paris

Re: PHP requirement

Post by Nicofuma » Wed Aug 26, 2015 9:21 am

What do you think about:
  • 5.4 now (phpBB 3.2)
  • 5.5 (or 5.6) newt year (phpBB 3.3)
  • We announce both at the same time (before or just after phpBB 3.2-a1)
Member of the phpBB Development-Team
No Support via PM

User avatar
Marc
Development Team Leader
Development Team Leader
Posts: 123
Joined: Thu Sep 09, 2010 11:36 am
Location: Munich, Germany

Re: PHP requirement

Post by Marc » Wed Aug 26, 2015 9:46 am

Just a short list of current PHP versions by distros that are currently supported:
  • Ubuntu 14.04 LTS: 5.5.9
  • Ubuntu 15.04: 5.6.4
  • Debian 6: 5.3.3
  • Debian 7: 5.4.41
  • Debian 8: 5.6.9
  • CentOS 6.x: 5.3.3
  • Centos 7.x: 5.4.16
Based on that I'd rather stay on PHP 5.4 since Debian and CentOS are used rather often. There are a lot more distros still on 5.4 but I'll stop with this list for now. ;)

User avatar
Elsensee
Development Team
Development Team
Posts: 36
Joined: Sun Mar 16, 2014 1:08 pm
Location: Hamburg, Germany
Contact:

Re: PHP requirement

Post by Elsensee » Thu Aug 27, 2015 5:19 pm

As I already said: I'm not against a version bump to 5.4 for 3.2.

I just think we shouldn't set the php to require just because the current required php version is EOL'd. If we use specific functions or language features which are not available in some php version, then it's okay to bump the version, but to bump the requirement so we could use some functions or language features is not okay IMHO.
So I'd say, let's just require the lowest php version with which phpBB can run without any issues. This will save our users some time and hassle and they will happily continue to use phpBB. :)

User avatar
JoshyPHP
Registered User
Posts: 349
Joined: Fri Jul 08, 2011 9:43 pm

Re: PHP requirement

Post by JoshyPHP » Thu Aug 27, 2015 5:27 pm

Elsensee wrote:
Thu Aug 27, 2015 5:19 pm
If we use specific functions or language features which are not available in some php version, then it's okay to bump the version, but to bump the requirement so we could use some functions or language features is not okay IMHO.
I don't get it. You have to bump the requirements before you can use a new feature.

User avatar
VSE
Extension Customisations
Extension Customisations
Posts: 670
Joined: Mon Mar 08, 2010 9:18 am

Re: PHP requirement

Post by VSE » Thu Aug 27, 2015 5:52 pm

I just think our min req ver should be whatever the number truly is, based on what we are using/doing. Can't we increase it at any time if we decide to install or do something that leads to a higher requirement?
Has an irascible disposition.

Nicofuma
3.2 Release Manager
3.2 Release Manager
Posts: 297
Joined: Sun Apr 13, 2014 1:40 am
Location: Paris

Re: PHP requirement

Post by Nicofuma » Thu Aug 27, 2015 6:40 pm

The problem is that a lot of people would like to use new features like me, but they don't because it's not necessary.

Nothing is necessary, it's just convenient.
Member of the phpBB Development-Team
No Support via PM

User avatar
VSE
Extension Customisations
Extension Customisations
Posts: 670
Joined: Mon Mar 08, 2010 9:18 am

Re: PHP requirement

Post by VSE » Thu Aug 27, 2015 8:41 pm

Nicofuma wrote:
Thu Aug 27, 2015 6:40 pm
The problem is that a lot of people would like to use new features like me, but they don't because it's not necessary.

Nothing is necessary, it's just convenient.
OK.
Has an irascible disposition.

KnownSyntax
Registered User
Posts: 6
Joined: Thu Aug 27, 2015 10:39 pm
Location: Arizona, United States
Contact:

Re: PHP requirement

Post by KnownSyntax » Thu Aug 27, 2015 10:44 pm

Nicofuma wrote:
Wed Aug 26, 2015 9:21 am
What do you think about:
  • 5.4 now (phpBB 3.2)
  • 5.5 (or 5.6) newt year (phpBB 3.3)
  • We announce both at the same time (before or just after phpBB 3.2-a1)
I think that this would be the best, that way those hosts that are still using older versions of Debian and CentOS will have a chance to upgrade in order to stay with the new trend of software (as stated by another poster we can see that many other different types of software are already considering and making PHP 5.5 their minimum requirement). It's sad that many hosts probably do use older server operating systems, but it's just something that takes time for them to be forced to upgrade.

User avatar
A_Jelly_Doughnut
Registered User
Posts: 1780
Joined: Wed Jun 04, 2003 4:23 pm

Re: PHP requirement

Post by A_Jelly_Doughnut » Sat Aug 29, 2015 4:43 pm

According to phpversions.info 32 out of the 40 shared hosts in their database offer php 5.5. Bluehost & rackspace cloud are the only names on the list which I recognize, and doesn't offer 5.5 -- and Bluehost provisions 5.2 :!: on new accounts by default.

Quick summary:
17/40 offer 5.6
32/40 offer 5.5
37/40 offer 5.4 or higher (some of the smaller hosts on the list don't offer 5.4 but do offer 5.5)

So to my opinion for 3.2: 5.4 looks very safe, I wouldn't object to 5.5.
A_Jelly_Doughnut

Post Reply