PHP requirement

General discussion of development ideas and the approaches taken in the 3.x branch of phpBB. The next feature release of phpBB 3 will be 3.3/Proteus.
Forum rules
Please do not post support questions regarding installing, updating, or upgrading phpBB 3.2.x. If you need support for phpBB 3.2.x please visit the 3.2.x Support Forum on phpbb.com.

If you have questions regarding writing extensions please post in Extension Writers Discussion to receive proper guidance from our staff and community.
User avatar
MichaelC
Development Team
Development Team
Posts: 889
Joined: Thu Jan 28, 2010 6:29 pm

Re: PHP requirement

Post by MichaelC » Mon Aug 24, 2015 1:16 pm

+1 to 5.4 or, preferably 5.5 (As it won't be EOL).

Drupal 8 (release in a few months) requires PHP 5.5 (not 5.6 Tristan) so hosts will be forced to update in the next few months anyway although most major shared hosts are now running 5.5, one exception being BlueHost who Drupal are working with to upgrade to PHP 5.5.

5.6 is not workabale due to a lack of support in distros right now.
VSE wrote:
Mon Aug 24, 2015 6:53 am
Nicofuma wrote:
Sun Aug 23, 2015 8:30 pm
The thing is also that shared host like GoDaddy will never update if no one force them to. (refs GoPHP5)

About the version, we currently require 5.3.9 because that's what is required by Symfony.
And Symfony 3.0 will require php 5.5 http://symfony.com/blog/symfony-3-0-the-roadmap

P.S phpBB 3.2 will require Symfony 2.8, the next LTS and phpBB 3.3/4 may require Symfony 3.2, the following LTS
P.S2 Drupal8 requires php 5.6
I've dealt with a fair share of shared hosts, and the really big ones won't care how many people ask them to update. They are immovable forces and just won't care, and can more easily tell their users to stick with phpBB 3.1 or even 3.0.

We kinda need to let what is being used out there influence our minimum version more so than what the developers at PHP are up to. Otherwise we will just wind up shrinking our user base and alienating a lot of phpBB users from upgrading to our latest version. Just look at TWIG which supports still PHP 5.2.x ;) We should make our min version req. as minimum as it can be, which I guess is currently 5.3.9.
They don't care about people, they do care about projects saying to upgrade (GoPHP5)
brunoais wrote:
Sun Aug 23, 2015 9:17 pm
I think that announcing phpBB 5.2 requiring php 5.5 now is too late. I believe you should warn with much more time in advance.
However, announcing phpBB 5.3 requiring php 5.5 seems fine to me. We might even require php 7 if it comes out this year...
Don't forget in theory we are announcing that we will drop support for 5.3.x in November 2016 as we will continue to support 3.1.x until then. So that's 1 and 3 months notice.
Formerly known as Unknown Bliss
psoTFX wrote: I went with Olympus because as I said to the teams ... "It's been one hell of a hill to climb"
No unsolicited PMs please except for quotes.

User avatar
VSE
Extension Customisations
Extension Customisations
Posts: 670
Joined: Mon Mar 08, 2010 9:18 am

Re: PHP requirement

Post by VSE » Mon Aug 24, 2015 3:14 pm

MichaelC wrote:
Mon Aug 24, 2015 1:16 pm
They don't care about people, they do care about projects saying to upgrade (GoPHP5)
Nah. They only care about what WordPress minimum requirement is, since that what 95% of their users want to use, which is 5.2.

According to this, 5.3 is still dominant :/
http://w3techs.com/technologies/details/pl-php/5/all
Has an irascible disposition.

User avatar
MichaelC
Development Team
Development Team
Posts: 889
Joined: Thu Jan 28, 2010 6:29 pm

Re: PHP requirement

Post by MichaelC » Mon Aug 24, 2015 3:34 pm

VSE wrote:
Mon Aug 24, 2015 3:14 pm
MichaelC wrote:
Mon Aug 24, 2015 1:16 pm
They don't care about people, they do care about projects saying to upgrade (GoPHP5)
Nah. They only care about what WordPress minimum requirement is, since that what 95% of their users want to use, which is 5.2.

According to this, 5.3 is still dominant :/
http://w3techs.com/technologies/details/pl-php/5/all
Wordpress were not part of GoPHP5, yet we brought the entire web to update to PHP 5. History disagrees with you.
Formerly known as Unknown Bliss
psoTFX wrote: I went with Olympus because as I said to the teams ... "It's been one hell of a hill to climb"
No unsolicited PMs please except for quotes.

User avatar
nickvergessen
Former Team Member
Posts: 733
Joined: Sun Oct 07, 2007 11:54 am
Location: Stuttgart, Germany
Contact:

Re: PHP requirement

Post by nickvergessen » Mon Aug 24, 2015 5:36 pm

Member of the Development-TeamNo Support via PM

User avatar
brunoais
Registered User
Posts: 964
Joined: Fri Dec 18, 2009 3:55 pm

Re: PHP requirement

Post by brunoais » Mon Aug 24, 2015 5:38 pm

bantu wrote:
Mon Aug 24, 2015 12:59 pm
My suggestion for a trade off would probably be something like this: Support the PHP version not EOL on release of final, unless a dependency requires a larger version.
Seems good enough for me.
@Nicofuma, what do you think?

User avatar
MichaelC
Development Team
Development Team
Posts: 889
Joined: Thu Jan 28, 2010 6:29 pm

Re: PHP requirement

Post by MichaelC » Mon Aug 24, 2015 7:00 pm

brunoais wrote:
Mon Aug 24, 2015 5:38 pm
bantu wrote:
Mon Aug 24, 2015 12:59 pm
My suggestion for a trade off would probably be something like this: Support the PHP version not EOL on release of final, unless a dependency requires a larger version.
Seems good enough for me.
@Nicofuma, what do you think?
That would be 5.5 for phpBB 3.2.

I think we should leave establishing a set practice until https://groups.google.com/forum/?utm_me ... _EwD3Kd9t4 is more established as that would keep us in suit with other PHP projects (power in numbers) and hopefully we'll get hosts to agree to it too.
Formerly known as Unknown Bliss
psoTFX wrote: I went with Olympus because as I said to the teams ... "It's been one hell of a hill to climb"
No unsolicited PMs please except for quotes.

User avatar
JoshyPHP
Registered User
Posts: 364
Joined: Fri Jul 08, 2011 9:43 pm

Re: PHP requirement

Post by JoshyPHP » Mon Aug 24, 2015 7:08 pm

VSE wrote:
Mon Aug 24, 2015 3:14 pm
According to this, 5.3 is still dominant :/
http://w3techs.com/technologies/details/pl-php/5/all
That doesn't mean those people cannot a supported version of PHP, only that they don't. Some hosts offer multiple concurrent versions of PHP and users have to select in their hosting panel which one they'll run. Many users stay on whichever version was the default at the time they bought their hosting plan. For those, all it takes to upgrade is ticking a box.

Nicofuma
3.2 Release Manager
3.2 Release Manager
Posts: 298
Joined: Sun Apr 13, 2014 1:40 am
Location: Paris

Re: PHP requirement

Post by Nicofuma » Mon Aug 24, 2015 7:11 pm

Honestly I don't really want to be too quick/abrupt that's why I think I'd prefer 5.4 this year, 5.5 next year and then follow what bantu said: the latests not EOL version unless we want to use a package with an higher requirement
Member of the phpBB Development-Team
No Support via PM

User avatar
brunoais
Registered User
Posts: 964
Joined: Fri Dec 18, 2009 3:55 pm

Re: PHP requirement

Post by brunoais » Mon Aug 24, 2015 7:51 pm

MichaelC wrote:
Mon Aug 24, 2015 7:00 pm
brunoais wrote:
Mon Aug 24, 2015 5:38 pm
bantu wrote:
Mon Aug 24, 2015 12:59 pm
My suggestion for a trade off would probably be something like this: Support the PHP version not EOL on release of final, unless a dependency requires a larger version.
Seems good enough for me.
@Nicofuma, what do you think?
That would be 5.5 for phpBB 3.2.
I thought it was 5.4 O_O. Did I misread? 5.4 is still officially supported until the end of the year, right?

Nicofuma
3.2 Release Manager
3.2 Release Manager
Posts: 298
Joined: Sun Apr 13, 2014 1:40 am
Location: Paris

Re: PHP requirement

Post by Nicofuma » Mon Aug 24, 2015 7:55 pm

only 20 days from today: http://php.net/supported-versions.php
Member of the phpBB Development-Team
No Support via PM

Post Reply