phpBB 2 to phpBB 3.1 - Fatal error

General discussion of development ideas and the approaches taken in the 3.x branch of phpBB. The next feature release of phpBB 3 will be 3.3/Proteus.
Forum rules
Please do not post support questions regarding installing, updating, or upgrading phpBB 3.2.x. If you need support for phpBB 3.2.x please visit the 3.2.x Support Forum on phpbb.com.

If you have questions regarding writing extensions please post in Extension Writers Discussion to receive proper guidance from our staff and community.
Post Reply
User avatar
Meis2M
Registered User
Posts: 432
Joined: Fri Apr 23, 2010 10:18 am
Contact:

phpBB 2 to phpBB 3.1 - Fatal error

Post by Meis2M »

Hello

for upgrade from phpBB 2.0.0 to phpBB 3.1 after going to install page when i click on " Convert" i saw a "general error" that the "phpbb.ext" table not exist. i added manual in phpmyadmin
now when i try to go in convert tab i see this error:

Code: Select all

Fatal error: Uncaught exception 'Symfony\Component\DependencyInjection\Exception\RuntimeException' with message 'The definition for "cache.driver" has no class. If you intend to inject this service dynamically at runtime, please mark it as synthetic=true. If this is an abstract definition solely used by child definitions, please add abstract=true, otherwise specify a class to get rid of this error.' in /home/zohallco/public_html/2/phpbb-release-2.0.0/phpBB/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Compiler/CheckDefinitionValidityPass.php:69 Stack trace: #0 /home/zohallco/public_html/2/phpbb-release-2.0.0/phpBB/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Compiler/Compiler.php(118): Symfony\Component\DependencyInjection\Compiler\CheckDefinitionValidityPass->process(Object(Symfony\Component\DependencyInjection\ContainerBuilder)) #1 /home/zohallco/public_html/2/phpbb-release-2.0.0/phpBB/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Conta in /home/zohallco/public_html/2/phpbb-release-2.0.0/phpBB/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Compiler/CheckDefinitionValidityPass.php on line 69
address:
http://www.php-bb.ir/2/phpbb-release-2. ... anguage=en

User avatar
prototech
Former Team Member
Posts: 53
Joined: Mon Mar 12, 2007 12:25 am

Re: phpBB 2 to phpBB 3.1 - Fatal error

Post by prototech »

The directory name and the errors suggest that you simply extracted the 3.1 files over the existing 2.0 ones and that 3.1 was never installed. You need to install 3.1 in a separate directory and then you can run the convertor. The convertor will not actually touch the old installation; it will simply copy over what it can into the 3.1 installation.

Post Reply