Fatal error (using latest version on Git)

General discussion of development ideas and the approaches taken in the 3.x branch of phpBB. The next feature release of phpBB 3 will be 3.3/Proteus.
Forum rules
Please do not post support questions regarding installing, updating, or upgrading phpBB 3.2.x. If you need support for phpBB 3.2.x please visit the 3.2.x Support Forum on phpbb.com.

If you have questions regarding writing extensions please post in Extension Writers Discussion to receive proper guidance from our staff and community.
User avatar
Jessica.
Registered User
Posts: 144
Joined: Wed Feb 09, 2011 8:17 pm
Location: Pennsylvania, USA
Contact:

Fatal error (using latest version on Git)

Post by Jessica. » Sun Apr 20, 2014 6:38 pm

Yesterday I updated to the latest version on Git (EDIT: latest as in the version as it was yesterday when I downloaded it) and ran into a couple issues. I got a general error, which I fixed, and a fatal error, which I need help with fixing.

Code: Select all

Fatal error: Call to a member function set_forum_data() on a non-object in /home/jesschen/public_html/ascraeus/viewforum.php on line 231
Extensions I'm using:
  • Advanced BBCode Box
  • Breadcrumb Menu
  • Database Optimize & Repair Tool
  • Lightbox
  • Password Strength
  • Quickedit
  • Quick Login
  • Recent Topics
  • Topic Preview

User avatar
prototech
Former Team Member
Posts: 53
Joined: Mon Mar 12, 2007 12:25 am

Re: Fatal error (using latest version on Git)

Post by prototech » Sun Apr 20, 2014 10:00 pm

Purge your cache.

User avatar
Jessica.
Registered User
Posts: 144
Joined: Wed Feb 09, 2011 8:17 pm
Location: Pennsylvania, USA
Contact:

Re: Fatal error (using latest version on Git)

Post by Jessica. » Sun Apr 20, 2014 10:06 pm

Nope, didn't work...

tmarone
Registered User
Posts: 8
Joined: Sun Apr 06, 2014 4:38 am

Re: Fatal error (using latest version on Git)

Post by tmarone » Sun Apr 20, 2014 10:34 pm

Sorry but there are a lot of things not working here while I am tryng to quote the OP's message and so on, with quick-replay or not. :?

She/He is updating from which version and how?

The error msg I saw above posted seems to lies into a PHP file, I believe it doesn't belong to those things related to purging cache.

In any case.. to Jessica: Have you tried to do a fresh install/update first?

I mean without extensions (all of those are in DEV status, so to speak).

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 1823
Joined: Thu Mar 02, 2006 4:29 pm
Location: Earth
Contact:

Re: Fatal error (using latest version on Git)

Post by DavidIQ » Sun Apr 20, 2014 10:37 pm

tmarone wrote:Sorry but there are a lot of things not working here while I am tryng to quote the OP's message and so on, with quick-replay or not. :?
What isn't working?
Image

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 1823
Joined: Thu Mar 02, 2006 4:29 pm
Location: Earth
Contact:

Re: Fatal error (using latest version on Git)

Post by DavidIQ » Sun Apr 20, 2014 10:41 pm

Jessica. wrote:Nope, didn't work...
Try manually deleting all php files from your cache.
Image

User avatar
Jessica.
Registered User
Posts: 144
Joined: Wed Feb 09, 2011 8:17 pm
Location: Pennsylvania, USA
Contact:

Re: Fatal error (using latest version on Git)

Post by Jessica. » Sun Apr 20, 2014 10:52 pm

Did that, error's still there.

I thought that maybe somehow I didn't update properly (installed beta 2, then used files from Github)? I simply replaced all files, didn't run install/index.php as it said I had the most recent version released - beta2...the general error I got was related to pruning shadow topics - there were columns missing and I had to add them in...

Gonna do some more digging and research

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 1823
Joined: Thu Mar 02, 2006 4:29 pm
Location: Earth
Contact:

Re: Fatal error (using latest version on Git)

Post by DavidIQ » Sun Apr 20, 2014 11:04 pm

Well it is probably related then:
https://github.com/phpbb/phpbb/blob/dev ... m.php#L231

Code: Select all

		$task = $cron->find_task('cron.task.core.prune_shadow_topics');
		$task->set_forum_data($forum_data);
Image

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 1823
Joined: Thu Mar 02, 2006 4:29 pm
Location: Earth
Contact:

Re: Fatal error (using latest version on Git)

Post by DavidIQ » Sun Apr 20, 2014 11:17 pm

Also why didn't you just run database_update.php?
Image

User avatar
prototech
Former Team Member
Posts: 53
Joined: Mon Mar 12, 2007 12:25 am

Re: Fatal error (using latest version on Git)

Post by prototech » Sun Apr 20, 2014 11:35 pm

Did you skip the config directory when replacing the files by any chance? This sounds very familiar to an issue that you had before (viewtopic.php?p=259647#p259647) where a change was made to one of the files in the config directory.
tmarone wrote:The error msg I saw above posted seems to lies into a PHP file, I believe it doesn't belong to those things related to purging cache.
The object is loaded using the dependency injection container, which is cached.

Post Reply