[3.1a3] Extension problems

General discussion of development ideas and the approaches taken in the 3.x branch of phpBB. The next feature release of phpBB 3 will be 3.3/Proteus.
Forum rules
Please do not post support questions regarding installing, updating, or upgrading phpBB 3.2.x. If you need support for phpBB 3.2.x please visit the 3.2.x Support Forum on phpbb.com.

If you have questions regarding writing extensions please post in Extension Writers Discussion to receive proper guidance from our staff and community.
..::Frans::..
Registered User
Posts: 27
Joined: Wed Mar 01, 2006 8:20 am

Re: [3.1a3] Extension problems

Post by ..::Frans::.. »

MrR: did you clear cache and set the config boolean debug to true??

MrR
Registered User
Posts: 7
Joined: Fri Dec 06, 2013 5:13 pm

Re: [3.1a3] Extension problems

Post by MrR »

Yes, I did. :S

User avatar
nickvergessen
Former Team Member
Posts: 733
Joined: Sun Oct 07, 2007 11:54 am
Location: Stuttgart, Germany
Contact:

Re: [3.1a3] Extension problems

Post by nickvergessen »

Is your source ppublic anywhere, so one can have a look at all files?
Member of the Development-TeamNo Support via PM

MrR
Registered User
Posts: 7
Joined: Fri Dec 06, 2013 5:13 pm

Re: [3.1a3] Extension problems

Post by MrR »

Sure you can, here you go: https://github.com/RobinRump/phpBB-ext-rules/tree/dev Thanks! :)

User avatar
nickvergessen
Former Team Member
Posts: 733
Joined: Sun Oct 07, 2007 11:54 am
Location: Stuttgart, Germany
Contact:

Re: [3.1a3] Extension problems

Post by nickvergessen »

It works for me
Member of the Development-TeamNo Support via PM

MrR
Registered User
Posts: 7
Joined: Fri Dec 06, 2013 5:13 pm

Re: [3.1a3] Extension problems

Post by MrR »

Weird, I purged the cache again, disabled and deleted the extension and reinstalled it from GitHub, but I still receive the same mistake. If I remove the controller.helper, the same error happens with the other classes - somehow the dependency injection does not seem to work properly on my machine.

User avatar
nickvergessen
Former Team Member
Posts: 733
Joined: Sun Oct 07, 2007 11:54 am
Location: Stuttgart, Germany
Contact:

Re: [3.1a3] Extension problems

Post by nickvergessen »

do you have additional files in your ext folder maybe?
Member of the Development-TeamNo Support via PM

MrR
Registered User
Posts: 7
Joined: Fri Dec 06, 2013 5:13 pm

Re: [3.1a3] Extension problems

Post by MrR »

No, besides the folder it is totally empty. I don't understand why it doesn't seem to parse my services.yml correctly. :/

User avatar
nickvergessen
Former Team Member
Posts: 733
Joined: Sun Oct 07, 2007 11:54 am
Location: Stuttgart, Germany
Contact:

Re: [3.1a3] Extension problems

Post by nickvergessen »

Did you try deleting your ext/ folder and recreating it together with the source from github?
Member of the Development-TeamNo Support via PM

..::Frans::..
Registered User
Posts: 27
Joined: Wed Mar 01, 2006 8:20 am

Re: [3.1a3] Extension problems

Post by ..::Frans::.. »

Installed your extension directly from github, nothing wrong with your services.yml... there are some other problems though (for example, you are referring to a language file named 'rules.php' while there is only a 'common.php' available in your ext. language folder...

;-)

Post Reply