Failled clean install with 3.1.x

General discussion of development ideas and the approaches taken in the 3.x branch of phpBB. The next feature release of phpBB 3 will be 3.3/Proteus.
Forum rules
Please do not post support questions regarding installing, updating, or upgrading phpBB 3.2.x. If you need support for phpBB 3.2.x please visit the 3.2.x Support Forum on phpbb.com.

If you have questions regarding writing extensions please post in Extension Writers Discussion to receive proper guidance from our staff and community.
Post Reply
anhhi
Registered User
Posts: 5
Joined: Wed Jul 10, 2013 2:46 pm

Failled clean install with 3.1.x

Post by anhhi » Fri Jul 12, 2013 5:58 pm

Hey everyone. I am unsure if anyone has run into this issue. I just downloaded the latest phpbb3.1.x for testing, everything seems fine but once I got the step on Creating Database tables, an error was generated below:

Code: Select all

Catchable fatal error: Argument 3 passed to phpbb_create_dumped_container() must be an array, string given, called in /dir/user/public_html/rp/phpBB/includes/functions_container.php on line 215 and defined in /dir/user/public_html/rp/phpBB/includes/functions_container.php on line 172
I looked into the function, the 3rd argument needs array ( like error says ) , is this a bug or something on my end?

This is a new clean install.

Thanks

User avatar
bantu
3.0 Release Manager
3.0 Release Manager
Posts: 557
Joined: Thu Sep 07, 2006 11:22 am
Location: Karlsruhe, Germany
Contact:

Re: Failled clean install with 3.1.x

Post by bantu » Fri Jul 12, 2013 6:45 pm

This should be fixed on the develop branch.

anhhi
Registered User
Posts: 5
Joined: Wed Jul 10, 2013 2:46 pm

Re: Failled clean install with 3.1.x

Post by anhhi » Fri Jul 12, 2013 7:20 pm

Thanks bantu. I'll do a PR on --dev

User avatar
EXreaction
Registered User
Posts: 1555
Joined: Sat Sep 10, 2005 2:15 am

Re: Failled clean install with 3.1.x

Post by EXreaction » Sat Jul 13, 2013 8:49 pm

He meant this is already fixed, we don't need a PR to fix it, just update to the latest develop.

Post Reply