Imagick and security

General discussion of development ideas and the approaches taken in the 3.x branch of phpBB. The next feature release of phpBB 3 will be 3.3/Proteus.
Forum rules
Please do not post support questions regarding installing, updating, or upgrading phpBB 3.2.x. If you need support for phpBB 3.2.x please visit the 3.2.x Support Forum on phpbb.com.

If you have questions regarding writing extensions please post in Extension Writers Discussion to receive proper guidance from our staff and community.
Post Reply
kevinf
Registered User
Posts: 1
Joined: Tue Aug 17, 2010 4:33 pm

Imagick and security

Post by kevinf »

From what i understood, imagick is used to resize images in attachments, however for imagick to be used, we need passthru to be enabled which is often disabled in web hostings.
What would be great is to support Imagick-php or magickwand-php, as it is a security problem to enable passthru, especially if it's just because of attachments..

User avatar
A_Jelly_Doughnut
Registered User
Posts: 1780
Joined: Wed Jun 04, 2003 4:23 pm

Re: Imagick and security

Post by A_Jelly_Doughnut »

phpBB requires imageMagick or the GD extension to do resizing. While the IMagick class would probably be nice, one of the above should be enabled on most, if not all, hosts.

Moving to 3.2 discussion just because anything that would be implemented is associated with some version :)
A_Jelly_Doughnut

Post Reply