Email and activation options

Temporary forum to obtain support while phpBB.com is offline.
Please use the support forum on phpBB.com
Forum rules
Temporary forum to obtain support while phpBB.com is offline.
Please use the support forum on phpBB.com
Locked
dolk
Registered User
Posts: 4
Joined: Tue Feb 10, 2009 5:21 pm

Email and activation options

Post by dolk » Tue Feb 10, 2009 5:32 pm

I am running 3.0.4 now. I have upgraded a month ago from a 2.x.x version. Everything went well and the board was running. Except now my "new members" are not being activated without any authorization or control.

I used to have "user activation" selected. Under the new Control Panel under "user registration settings" I only have two options, "none" or "disable". There should be "user" and "Admin", isn't that correct?

Dolk

User avatar
Kevin Clark
Support Team
Support Team
Posts: 751
Joined: Thu Feb 10, 2005 5:34 pm
Location: UK
Contact:

Re: Email and activation options

Post by Kevin Clark » Tue Feb 10, 2009 5:45 pm

If you only have account activation options for 'disable' and 'none' it means you have the board email disabled.

Admin panel>email settings>enable board email

If the email is disabled, the board cannot send mail out to users or admins to activate their accounts so those options are not visible.
Image

alcarola
Registered User
Posts: 5
Joined: Mon Feb 09, 2009 2:34 pm

Re: Email and activation options

Post by alcarola » Tue Feb 10, 2009 6:34 pm

Hi!

Dolk, I at some point had to have at least one "normal administrator" receive the activation emails. I got no registration emails if I only had the super admin (who is also the group leader) in the admin group. Once I added another "approved group member" both admins started getting the registration emails again.

Of course, I don't know if this is really your issue. I'm also not sure I had the problem in version 3.0.4, could also be that was in 3.0.0. (Just upgraded a few weeks ago.)

Mikael

dolk
Registered User
Posts: 4
Joined: Tue Feb 10, 2009 5:21 pm

Re: Email and activation options

Post by dolk » Tue Feb 10, 2009 10:56 pm

Kevin Clark wrote:If you only have account activation options for 'disable' and 'none' it means you have the board email disabled.

Admin panel>email settings>enable board email

If the email is disabled, the board cannot send mail out to users or admins to activate their accounts so those options are not visible.
OK, That fixed that. Some how it was not enabled. I don't know how, but sometime during the upgrade I guess.

However, now a new person can register and it gives the message that they have to respond to an email sent (to activate account), but no email is sent. I do not use the SMTP. It is set at "No". I never had to use SMTP before.

Dolk

bolverk
I've been banned
Posts: 280
Joined: Mon Feb 02, 2009 5:39 pm

Re: Email and activation options

Post by bolverk » Tue Feb 10, 2009 11:06 pm

Check your ACP -> Maintenance -> Error log for any email errors

dolk
Registered User
Posts: 4
Joined: Tue Feb 10, 2009 5:21 pm

Re: Email and activation options

Post by dolk » Wed Feb 11, 2009 3:02 am

bolverk wrote:Check your ACP -> Maintenance -> Error log for any email errors
yes............... I had 3 errors. all the same. One for each time I tried it I guess.
Now...what the heck does this mean?????

Image

dolk
Registered User
Posts: 4
Joined: Tue Feb 10, 2009 5:21 pm

Re: Email and activation options

Post by dolk » Wed Feb 11, 2009 4:16 am

OK, I found it. Made a mistake in the email address. It runs now. I want to thank all of you for your kind help!

Dolk

Locked