I've upgraded to 3.0.4 but now my forums aren't working!

Temporary forum to obtain support while phpBB.com is offline.
Please use the support forum on phpBB.com
Forum rules
Temporary forum to obtain support while phpBB.com is offline.
Please use the support forum on phpBB.com
Locked
zeforce
Registered User
Posts: 5
Joined: Tue Feb 10, 2009 9:38 am

I've upgraded to 3.0.4 but now my forums aren't working!

Post by zeforce »

Hello everyone,
I have had my forums up for about a year now and I just upgraded from 3.0.0 to 3.0.4 and they don't work anymore, http://www.zeforce.com/forums the forums show up but once you try click on a topic an error comes up, can anyone help?

Here is the error:
Fatal error: Not able to open ./cache/data_global.php in /home/zeforce/public_html/forums/includes/acm/acm_file.php on line 112

Very stressed out at the momment. GGRRR
User avatar
Kevin Clark
Support Team
Support Team
Posts: 751
Joined: Thu Feb 10, 2005 5:34 pm
Location: UK
Contact:

Re: I've upgraded to 3.0.4 but now my forums aren't working!

Post by Kevin Clark »

Image
zeforce
Registered User
Posts: 5
Joined: Tue Feb 10, 2009 9:38 am

Re: I've upgraded to 3.0.4 but now my forums aren't working!

Post by zeforce »

Awesome forums are working great now!
zeforce
Registered User
Posts: 5
Joined: Tue Feb 10, 2009 9:38 am

Re: I've upgraded to 3.0.4 but now my forums aren't working!

Post by zeforce »

Oh no, theyt were working fine for a bit now it's coming up with a new error:

General Error
SQL ERROR [ mysql4 ]

Unknown column 'Array' in 'where clause' [1054]

SQL

SELECT notify_status FROM phpbb_forums_watch WHERE forum_id = 84 AND user_id = Array

BACKTRACE

FILE: includes/db/mysql.php
LINE: 158
CALL: dbal->sql_error()

FILE: includes/functions_display.php
LINE: 1041
CALL: dbal_mysql->sql_query()

FILE: viewforum.php
LINE: 198
CALL: watch_topic_forum()
User avatar
Kevin Clark
Support Team
Support Team
Posts: 751
Joined: Thu Feb 10, 2005 5:34 pm
Location: UK
Contact:

Re: I've upgraded to 3.0.4 but now my forums aren't working!

Post by Kevin Clark »

How did you update from 3.0.0 to 3.0.4?
Image
zeforce
Registered User
Posts: 5
Joined: Tue Feb 10, 2009 9:38 am

Re: I've upgraded to 3.0.4 but now my forums aren't working!

Post by zeforce »

Well, It said that I had 3.0.0 installed and the lastest was 3.0.4 so I downloaded the update package and installed it. Did I do something wrong?
User avatar
Kevin Clark
Support Team
Support Team
Posts: 751
Joined: Thu Feb 10, 2005 5:34 pm
Location: UK
Contact:

Re: I've upgraded to 3.0.4 but now my forums aren't working!

Post by Kevin Clark »

I'm guessing you got the autoupdate form 3.0.2 or 3.0.3 instead of 3.0.0.

So, get the full version of the download.
Upload all the files except for config.php, /files and /images.
Go to yoursite.com/forumfolder/install/database_update.php
Let it run
delete the install folder.

You should be working again but this will lose any MODs you might have had.
Image
zeforce
Registered User
Posts: 5
Joined: Tue Feb 10, 2009 9:38 am

Re: I've upgraded to 3.0.4 but now my forums aren't working!

Post by zeforce »

Thank you so much! It works great now!
Locked