Field 'topic_last_poster_name' doesn't have a default value

Temporary forum to obtain support while phpBB.com is offline.
Please use the support forum on phpBB.com
Forum rules
Temporary forum to obtain support while phpBB.com is offline.
Please use the support forum on phpBB.com
Locked
double9s
Registered User
Posts: 6
Joined: Mon Feb 09, 2009 4:15 pm

Field 'topic_last_poster_name' doesn't have a default value

Post by double9s »

I recently migrated my site from one hosting provider to another, including my phpBB3 forums database. On Saturday, everything was working fine, but now I get this error whenever I try to post a new topic:
Field 'topic_last_poster_name' doesn't have a default value
There's more to the error but I figure that's the meat of it. Let me know if you need the rest of the error.

Here's how I migrated the database:

1) DB backup and download from old site's admin pages.
2) In phpmyadmin on my new site, I created a db and then imported the gzip file I downloaded.
3) Deployed phpBB on my new site.
4) Changed the values in config.php to point to the imported db.

For the record, I searched for a solution but the only page I found was on the currently hacked phpBB boards, which I can't get to.


double9s
Registered User
Posts: 6
Joined: Mon Feb 09, 2009 4:15 pm

Re: Field 'topic_last_poster_name' doesn't have a default value

Post by double9s »

Cool, thanks. I'll give this a try and let you know how it goes.

double9s
Registered User
Posts: 6
Joined: Mon Feb 09, 2009 4:15 pm

Re: Field 'topic_last_poster_name' doesn't have a default value

Post by double9s »

So I followed the instructions and copy pasted the SQL commands that the script created for me and I get this error in phpmyadmin when I try to run it:

Code: Select all

SQL query:

# Table: 'phpbb3_groups' ALTER TABLE phpbb3_groups MODIFY group_id mediumint(8) UNSIGNED NOT NULL auto_increment, MODIFY group_type tinyint(4) DEFAULT '1' NOT NULL, MODIFY group_founder_manage tinyint(1) UNSIGNED DEFAULT '0' NOT NULL, MODIFY group_name varchar(255) DEFAULT '' NOT NULL COLLATE utf8_bin, MODIFY group_desc text NOT NULL COLLATE utf8_bin, MODIFY group_desc_bitfield varchar(255) DEFAULT '' NOT NULL COLLATE utf8_bin, MODIFY group_desc_options int(11) UNSIGNED DEFAULT '7' NOT NULL, MODIFY group_desc_uid varchar(8) DEFAULT '' NOT NULL COLLATE utf8_bin, MODIFY group_display tinyint(1) UNSIGNED DEFAULT '0' NOT NULL, MODIFY group_avatar varchar(255) DEFAULT '' NOT NULL COLLATE utf8_bin, MODIFY group_avatar_type tinyint(2) DEFAULT '0' NOT NULL, MODIFY group_avatar_width smallint(4) UNSIGNED DEFAULT '0' NOT NULL, MODIFY group_avatar_height smallint(4) UNSIGNED DEFAULT '0' NOT NULL, MODIFY group_rank mediumint(8) UNSIGNED DEFAULT '0' NOT NULL, MODIFY group_col[...]

MySQL said: 

#1091 - Can't DROP 'group_legend_name'; check that column/key exists

double9s
Registered User
Posts: 6
Joined: Mon Feb 09, 2009 4:15 pm

Re: Field 'topic_last_poster_name' doesn't have a default value

Post by double9s »

After some research, I noticed that the server version for mysql of my old site was "Server version: 4.0.24" and on my new site it's "Server version: 5.0.75-community". Seems like this could have something to do with the problem.

The link you sent seems to offer instructions on how to perform this "upgrade" but as I said, I get errors and now I'm stuck.

double9s
Registered User
Posts: 6
Joined: Mon Feb 09, 2009 4:15 pm

Re: Field 'topic_last_poster_name' doesn't have a default value

Post by double9s »

urgent Help cant see forum Need help ASAP

User avatar
Noxwizard
Support Team Leader
Support Team Leader
Posts: 135
Joined: Sun Dec 18, 2005 5:44 pm
Location: Texas
Contact:

Re: Field 'topic_last_poster_name' doesn't have a default value

Post by Noxwizard »

Please note that we have a six hour bump limit.

As for your error, remove that drop statement from the list of queries if it is giving a problem.

double9s
Registered User
Posts: 6
Joined: Mon Feb 09, 2009 4:15 pm

Re: Field 'topic_last_poster_name' doesn't have a default value

Post by double9s »

Sorry, didn't realize you had that limit.

You suggestion got me past that error but now I get:

Code: Select all

#1283 - Column 'post_text' cannot be part of FULLTEXT index
I then remove the only line with 'post_text' in it:

Code: Select all

MODIFY post_text mediumtext NOT NULL COLLATE utf8_bin,
But I still get the same error. I can't believe it's this difficult to update from MySQL 4.0 to 5.0.

Locked